summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-10-17 04:24:59 +0000
committerMike Frysinger <vapier@gentoo.org>2003-10-17 04:24:59 +0000
commit08b3c280f03e0e3d401668070da42ed1695e3f43 (patch)
treef02e4f416fcc3abe93bf263bc4a51b0ebf7617e0 /net-www/dillo
parentfix compilation on amd64 (diff)
downloadgentoo-2-08b3c280f03e0e3d401668070da42ed1695e3f43.tar.gz
gentoo-2-08b3c280f03e0e3d401668070da42ed1695e3f43.tar.bz2
gentoo-2-08b3c280f03e0e3d401668070da42ed1695e3f43.zip
old
Diffstat (limited to 'net-www/dillo')
-rw-r--r--net-www/dillo/dillo-0.6.6-r1.ebuild76
-rw-r--r--net-www/dillo/dillo-0.6.6-r3.ebuild75
-rw-r--r--net-www/dillo/dillo-0.7.1.2.ebuild99
-rw-r--r--net-www/dillo/dillo-0.7.2.ebuild99
-rw-r--r--net-www/dillo/dillo-0.7.3-r1.ebuild4
-rw-r--r--net-www/dillo/dillo-0.7.3.ebuild99
-rw-r--r--net-www/dillo/files/digest-dillo-0.6.6-r12
-rw-r--r--net-www/dillo/files/digest-dillo-0.6.6-r32
-rw-r--r--net-www/dillo/files/digest-dillo-0.7.1.22
-rw-r--r--net-www/dillo/files/digest-dillo-0.7.22
-rw-r--r--net-www/dillo/files/digest-dillo-0.7.32
11 files changed, 2 insertions, 460 deletions
diff --git a/net-www/dillo/dillo-0.6.6-r1.ebuild b/net-www/dillo/dillo-0.6.6-r1.ebuild
deleted file mode 100644
index 801b3ef8ec5c..000000000000
--- a/net-www/dillo/dillo-0.6.6-r1.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/dillo/dillo-0.6.6-r1.ebuild,v 1.5 2003/09/06 01:54:08 msterret Exp $
-
-S=${WORKDIR}/${P}
-S2=${WORKDIR}/${PN}-gentoo-extra
-DESCRIPTION="Lean GTK+-based web browser"
-SRC_URI="http://dillo.cipsga.org.br/download/${P}.tar.gz
- mirror://gentoo/dillo-gentoo-extra.tar.bz2"
-HOMEPAGE="http://dillo.cipsga.org.br"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 ppc sparc "
-
-DEPEND="=x11-libs/gtk+-1.2*
- >=media-libs/jpeg-6b
- >=sys-libs/zlib-1.1.3
- >=media-libs/libpng-1.2.1"
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
- patch -p1 < ${S2}/${P}-gentoo-patch || die
-
- if use mozilla
- then
- cp ${S2}/pixmaps.netscape.h ${S}/src/pixmaps.h
- elif use kde
- then
- cp ${S2}/pixmaps.konq.h ${S}/src/pixmaps.h
- elif use gnome
- then
- cp ${S2}/pixmaps.ximian.h ${S}/src/pixmaps.h
- fi
-
-}
-
-src_compile() {
- econf || die
- emake || die
-}
-
-src_install () {
-
- dodir /etc
-
- make \
- DESTDIR=${D} \
- install || die
-
- dodoc AUTHORS COPYING ChangeLog ChangeLog.old INSTALL README NEWS
-
- docinto doc
- dodoc doc/*.txt doc/README
-
-}
-
-pkg_postinst() {
-
- einfo "This ebuild for dillo comes with different toolbar icons"
- einfo "If you want mozilla style icons then try"
- einfo " USE=\"-kde -gnome mozilla\" emerge dillo"
- einfo
- einfo "If you prefer konqueror style icons then try"
- einfo " USE=\"-mozilla -gnome kde\" emerge dillo"
- einfo
- einfo "If you prefer ximian gnome style icons then try"
- einfo " USE=\"-mozilla -kde gnome\" emerge dillo"
- einfo
- einfo "Otherwise, if you want the default icon set, then do"
- einfo " USE=\"-mozilla -kde -gnome\" emerge dillo"
- einfo
- einfo "Do not worry, no extra dependencies will be pulled in"
-}
diff --git a/net-www/dillo/dillo-0.6.6-r3.ebuild b/net-www/dillo/dillo-0.6.6-r3.ebuild
deleted file mode 100644
index a40fba4e3aff..000000000000
--- a/net-www/dillo/dillo-0.6.6-r3.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/dillo/dillo-0.6.6-r3.ebuild,v 1.5 2003/09/06 01:54:08 msterret Exp $
-
-inherit eutils
-S2=${WORKDIR}/gentoo-dillo-extras-patch
-EPATCH_SOURCE="${S2}"
-EPATCH_SUFFIX="patch"
-
-DESCRIPTION="Lean GTK+-based web browser"
-SRC_URI="http://dillo.cipsga.org.br/download/${P}.tar.gz
- mirror://gentoo/gentoo-dillo-extras-patch.tar.bz2"
-HOMEPAGE="http://dillo.cipsga.org.br/"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 ~ppc ~sparc ~alpha ~mips ~hppa"
-
-DEPEND="=x11-libs/gtk+-1.2*
- >=media-libs/jpeg-6b
- >=sys-libs/zlib-1.1.3
- >=media-libs/libpng-1.2.1"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- if use libwww
- then
- epatch
- export WANT_AUTOMAKE_1_4=1
- automake
- fi
-
- if use mozilla
- then
- cp ${S2}/pixmaps.netscape.h ${S}/src/pixmaps.h
- elif use kde
- then
- cp ${S2}/pixmaps.konq.h ${S}/src/pixmaps.h
- elif use gnome
- then
- cp ${S2}/pixmaps.ximian.h ${S}/src/pixmaps.h
- fi
-}
-
-src_compile() {
- econf || die
- emake || die
-}
-
-src_install() {
- dodir /etc
- einstall
- dodoc AUTHORS COPYING ChangeLog ChangeLog.old INSTALL README NEWS
- docinto doc
- dodoc doc/*.txt doc/README
-}
-
-pkg_postinst() {
- einfo "This ebuild for dillo comes with different toolbar icons"
- einfo "If you want mozilla style icons then try"
- einfo " USE=\"-kde -gnome mozilla\" emerge dillo"
- einfo
- einfo "If you prefer konqueror style icons then try"
- einfo " USE=\"-mozilla -gnome kde\" emerge dillo"
- einfo
- einfo "If you prefer ximian gnome style icons then try"
- einfo " USE=\"-mozilla -kde gnome\" emerge dillo"
- einfo
- einfo "Otherwise, if you want the default icon set, then do"
- einfo " USE=\"-mozilla -kde -gnome\" emerge dillo"
- einfo
- einfo "Do not worry, no extra dependencies will be pulled in"
-}
diff --git a/net-www/dillo/dillo-0.7.1.2.ebuild b/net-www/dillo/dillo-0.7.1.2.ebuild
deleted file mode 100644
index 986f60904cfd..000000000000
--- a/net-www/dillo/dillo-0.7.1.2.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/dillo/dillo-0.7.1.2.ebuild,v 1.4 2003/09/06 01:54:08 msterret Exp $
-
-inherit flag-o-matic
-
-IUSE="ipv6 kde gnome mozilla"
-
-S=${WORKDIR}/${PN}-0.7.1
-S2=${WORKDIR}/gentoo-dillo-extras-patch
-
-DESCRIPTION="Lean GTK+-based web browser"
-HOMEPAGE="http://dillo.auriga.wearlab.de/"
-SRC_URI="http://dillo.auriga.wearlab.de/download/${P}.tar.gz
- mirror://gentoo/dillo-gentoo-extras-patch.tar.bz2"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 ~ppc sparc ~alpha ~mips ~hppa"
-
-replace-flags "-O2 -mcpu=k6" "-O2 -mcpu=pentium"
-
-DEPEND="=x11-libs/gtk+-1.2*
- >=media-libs/jpeg-6b
- >=sys-libs/zlib-1.1.3
- >=media-libs/libpng-1.2.1"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- if [ "${DILLO_ICONSET}" = "kde" ]
- then
- ebegin "Using Konqueror style icon set"
- cp ${S2}/pixmaps.konq.h ${S}/src/pixmaps.h
- eend 0
- elif [ "${DILLO_ICONSET}" = "gnome" ]
- then
- ebegin "Using Ximian style icon set"
- cp ${S2}/pixmaps.ximian.h ${S}/src/pixmaps.h
- eend 0
- elif [ "${DILLO_ICONSET}" = "mozilla" ]
- then
- ebegin "Using Netscape style icon set"
- cp ${S2}/pixmaps.netscape.h ${S}/src/pixmaps.h
- eend 0
- elif [ "${DILLO_ICONSET}" = "bold" ]
- then
- ebegin "Using bold style icon set"
- cp ${S2}/pixmaps.bold.h ${S}/src/pixmaps.h
- eend 0
- elif [ "${DILLO_ICONSET}" = "trans" ]
- then
- ebegin "Using transparent style icon set"
- cp ${S2}/pixmaps.trans.h ${S}/src/pixmaps.h
- eend 0
- else
- ebegin "Using default Dillo icon set"
- eend 0
- fi
-}
-
-src_compile() {
- econf `use_enable ipv6` || die
- emake || make || die
-}
-
-src_install() {
- dodir /etc
- einstall
- dodoc AUTHORS COPYING ChangeLog* INSTALL README NEWS
- docinto doc
- dodoc doc/*.txt doc/README
-}
-
-pkg_postinst() {
- einfo "This ebuild for dillo comes with different toolbar icons"
- einfo "If you want mozilla style icons then try"
- einfo " DILLO_ICONSET=\"mozilla\" emerge dillo"
- einfo
- einfo "If you prefer konqueror style icons then try"
- einfo " DILLO_ICONSET=\"kde\" emerge dillo"
- einfo
- einfo "If you prefer ximian gnome style icons then try"
- einfo " DILLO_ICONSET=\"gnome\" emerge dillo"
- einfo
- einfo "If you prefer bold style icons then try"
- einfo " DILLO_ICONSET=\"bold\" emerge dillo"
- einfo
- einfo "If you prefer transparent style icons then try"
- einfo " DILLO_ICONSET=\"trans\" emerge dillo"
- einfo
- einfo "If the DILLO_ICONSET variable is not set, you will get the"
- einfo "default iconset"
- einfo
- einfo "To see what the icons look like, please point your browser to:"
- einfo "http://dillo.auriga.wearlab.de/Icons/"
- einfo
-}
diff --git a/net-www/dillo/dillo-0.7.2.ebuild b/net-www/dillo/dillo-0.7.2.ebuild
deleted file mode 100644
index 7343d3e28935..000000000000
--- a/net-www/dillo/dillo-0.7.2.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/dillo/dillo-0.7.2.ebuild,v 1.4 2003/09/06 01:54:08 msterret Exp $
-
-inherit flag-o-matic
-
-IUSE="ipv6 kde gnome mozilla"
-
-S=${WORKDIR}/${P}
-S2=${WORKDIR}/gentoo-dillo-extras-patch
-
-DESCRIPTION="Lean GTK+-based web browser"
-HOMEPAGE="http://dillo.auriga.wearlab.de/"
-SRC_URI="http://dillo.auriga.wearlab.de/download/${P}.tar.bz2
- mirror://gentoo/dillo-gentoo-extras-patch.tar.bz2"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 ~ppc sparc ~alpha ~mips ~hppa"
-
-replace-flags "-O2 -mcpu=k6" "-O2 -mcpu=pentium"
-
-DEPEND="=x11-libs/gtk+-1.2*
- >=media-libs/jpeg-6b
- >=sys-libs/zlib-1.1.3
- >=media-libs/libpng-1.2.1"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- if [ "${DILLO_ICONSET}" = "kde" ]
- then
- ebegin "Using Konqueror style icon set"
- cp ${S2}/pixmaps.konq.h ${S}/src/pixmaps.h
- eend 0
- elif [ "${DILLO_ICONSET}" = "gnome" ]
- then
- ebegin "Using Ximian style icon set"
- cp ${S2}/pixmaps.ximian.h ${S}/src/pixmaps.h
- eend 0
- elif [ "${DILLO_ICONSET}" = "mozilla" ]
- then
- ebegin "Using Netscape style icon set"
- cp ${S2}/pixmaps.netscape.h ${S}/src/pixmaps.h
- eend 0
- elif [ "${DILLO_ICONSET}" = "bold" ]
- then
- ebegin "Using bold style icon set"
- cp ${S2}/pixmaps.bold.h ${S}/src/pixmaps.h
- eend 0
- elif [ "${DILLO_ICONSET}" = "trans" ]
- then
- ebegin "Using transparent style icon set"
- cp ${S2}/pixmaps.trans.h ${S}/src/pixmaps.h
- eend 0
- else
- ebegin "Using default Dillo icon set"
- eend 0
- fi
-}
-
-src_compile() {
- econf `use_enable ipv6` || die
- emake || make || die
-}
-
-src_install() {
- dodir /etc
- einstall
- dodoc AUTHORS COPYING ChangeLog* INSTALL README NEWS
- docinto doc
- dodoc doc/*.txt doc/README
-}
-
-pkg_postinst() {
- einfo "This ebuild for dillo comes with different toolbar icons"
- einfo "If you want mozilla style icons then try"
- einfo " DILLO_ICONSET=\"mozilla\" emerge dillo"
- einfo
- einfo "If you prefer konqueror style icons then try"
- einfo " DILLO_ICONSET=\"kde\" emerge dillo"
- einfo
- einfo "If you prefer ximian gnome style icons then try"
- einfo " DILLO_ICONSET=\"gnome\" emerge dillo"
- einfo
- einfo "If you prefer bold style icons then try"
- einfo " DILLO_ICONSET=\"bold\" emerge dillo"
- einfo
- einfo "If you prefer transparent style icons then try"
- einfo " DILLO_ICONSET=\"trans\" emerge dillo"
- einfo
- einfo "If the DILLO_ICONSET variable is not set, you will get the"
- einfo "default iconset"
- einfo
- einfo "To see what the icons look like, please point your browser to:"
- einfo "http://dillo.auriga.wearlab.de/Icons/"
- einfo
-}
diff --git a/net-www/dillo/dillo-0.7.3-r1.ebuild b/net-www/dillo/dillo-0.7.3-r1.ebuild
index e23cef2237d4..b699fc71a1b4 100644
--- a/net-www/dillo/dillo-0.7.3-r1.ebuild
+++ b/net-www/dillo/dillo-0.7.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/dillo/dillo-0.7.3-r1.ebuild,v 1.3 2003/10/01 20:02:45 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/dillo/dillo-0.7.3-r1.ebuild,v 1.4 2003/10/17 04:24:59 vapier Exp $
inherit flag-o-matic
@@ -16,7 +16,7 @@ SRC_URI="http://www.dillo.org/download/${P}.tar.bz2
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 ~ppc sparc alpha ~mips ~hppa"
+KEYWORDS="x86 ppc sparc alpha ~mips ~hppa"
replace-flags "-O2 -mcpu=k6" "-O2 -mcpu=pentium"
diff --git a/net-www/dillo/dillo-0.7.3.ebuild b/net-www/dillo/dillo-0.7.3.ebuild
deleted file mode 100644
index 128559054d34..000000000000
--- a/net-www/dillo/dillo-0.7.3.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/dillo/dillo-0.7.3.ebuild,v 1.3 2003/09/06 01:54:08 msterret Exp $
-
-inherit flag-o-matic
-
-IUSE="ipv6"
-
-S=${WORKDIR}/${P}
-S2=${WORKDIR}/gentoo-dillo-extras-patch
-
-DESCRIPTION="Lean GTK+-based web browser"
-HOMEPAGE="http://dillo.auriga.wearlab.de/"
-SRC_URI="http://www.dillo.org/download/${P}.tar.bz2
- mirror://gentoo/dillo-gentoo-extras-patch.tar.bz2"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 ~ppc sparc ~alpha ~mips ~hppa"
-
-replace-flags "-O2 -mcpu=k6" "-O2 -mcpu=pentium"
-
-DEPEND="=x11-libs/gtk+-1.2*
- >=media-libs/jpeg-6b
- >=sys-libs/zlib-1.1.3
- >=media-libs/libpng-1.2.1"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- if [ "${DILLO_ICONSET}" = "kde" ]
- then
- ebegin "Using Konqueror style icon set"
- cp ${S2}/pixmaps.konq.h ${S}/src/pixmaps.h
- eend 0
- elif [ "${DILLO_ICONSET}" = "gnome" ]
- then
- ebegin "Using Ximian style icon set"
- cp ${S2}/pixmaps.ximian.h ${S}/src/pixmaps.h
- eend 0
- elif [ "${DILLO_ICONSET}" = "mozilla" ]
- then
- ebegin "Using Netscape style icon set"
- cp ${S2}/pixmaps.netscape.h ${S}/src/pixmaps.h
- eend 0
- elif [ "${DILLO_ICONSET}" = "bold" ]
- then
- ebegin "Using bold style icon set"
- cp ${S2}/pixmaps.bold.h ${S}/src/pixmaps.h
- eend 0
- elif [ "${DILLO_ICONSET}" = "trans" ]
- then
- ebegin "Using transparent style icon set"
- cp ${S2}/pixmaps.trans.h ${S}/src/pixmaps.h
- eend 0
- else
- ebegin "Using default Dillo icon set"
- eend 0
- fi
-}
-
-src_compile() {
- econf `use_enable ipv6` || die
- emake || make || die
-}
-
-src_install() {
- dodir /etc
- einstall
- dodoc AUTHORS COPYING ChangeLog* INSTALL README NEWS
- docinto doc
- dodoc doc/*.txt doc/README
-}
-
-pkg_postinst() {
- einfo "This ebuild for dillo comes with different toolbar icons"
- einfo "If you want mozilla style icons then try"
- einfo " DILLO_ICONSET=\"mozilla\" emerge dillo"
- einfo
- einfo "If you prefer konqueror style icons then try"
- einfo " DILLO_ICONSET=\"kde\" emerge dillo"
- einfo
- einfo "If you prefer ximian gnome style icons then try"
- einfo " DILLO_ICONSET=\"gnome\" emerge dillo"
- einfo
- einfo "If you prefer bold style icons then try"
- einfo " DILLO_ICONSET=\"bold\" emerge dillo"
- einfo
- einfo "If you prefer transparent style icons then try"
- einfo " DILLO_ICONSET=\"trans\" emerge dillo"
- einfo
- einfo "If the DILLO_ICONSET variable is not set, you will get the"
- einfo "default iconset"
- einfo
- einfo "To see what the icons look like, please point your browser to:"
- einfo "http://dillo.auriga.wearlab.de/Icons/"
- einfo
-}
diff --git a/net-www/dillo/files/digest-dillo-0.6.6-r1 b/net-www/dillo/files/digest-dillo-0.6.6-r1
deleted file mode 100644
index 476fe46d22ba..000000000000
--- a/net-www/dillo/files/digest-dillo-0.6.6-r1
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 01d681ba8bec7fdb074d1bbf99c13285 dillo-0.6.6.tar.gz 310331
-MD5 13ef77220819bc16dff81b21bb1e2b73 dillo-gentoo-extra.tar.bz2 48479
diff --git a/net-www/dillo/files/digest-dillo-0.6.6-r3 b/net-www/dillo/files/digest-dillo-0.6.6-r3
deleted file mode 100644
index e264f741d927..000000000000
--- a/net-www/dillo/files/digest-dillo-0.6.6-r3
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 01d681ba8bec7fdb074d1bbf99c13285 dillo-0.6.6.tar.gz 310331
-MD5 eff4bdc4276d554d8e105b32b626f38b gentoo-dillo-extras-patch.tar.bz2 25407
diff --git a/net-www/dillo/files/digest-dillo-0.7.1.2 b/net-www/dillo/files/digest-dillo-0.7.1.2
deleted file mode 100644
index 87cfa21696d4..000000000000
--- a/net-www/dillo/files/digest-dillo-0.7.1.2
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 b6b340d30657e51a48dc32f926be45c0 dillo-0.7.1.2.tar.gz 365171
-MD5 e803699d5472790046837e8d33b3db39 dillo-gentoo-extras-patch.tar.bz2 26644
diff --git a/net-www/dillo/files/digest-dillo-0.7.2 b/net-www/dillo/files/digest-dillo-0.7.2
deleted file mode 100644
index 7fab05f191af..000000000000
--- a/net-www/dillo/files/digest-dillo-0.7.2
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 8072ff85bde54f9e421ddadd642d6722 dillo-0.7.2.tar.bz2 329088
-MD5 e803699d5472790046837e8d33b3db39 dillo-gentoo-extras-patch.tar.bz2 26644
diff --git a/net-www/dillo/files/digest-dillo-0.7.3 b/net-www/dillo/files/digest-dillo-0.7.3
deleted file mode 100644
index 6650dec41f93..000000000000
--- a/net-www/dillo/files/digest-dillo-0.7.3
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 896f4d8c752b86376bfb445740f01470 dillo-0.7.3.tar.bz2 345295
-MD5 e803699d5472790046837e8d33b3db39 dillo-gentoo-extras-patch.tar.bz2 26644