summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2005-02-14 17:14:50 +0000
committerBenedikt Boehm <hollow@gentoo.org>2005-02-14 17:14:50 +0000
commit14cfe33570b8eac249f919dc1216510d6a8ba82c (patch)
treee86c525509e9cdfb5a295d8f362aaf36c6d4c054 /net-www/mod_bw
parent~amd64 (diff)
downloadgentoo-2-14cfe33570b8eac249f919dc1216510d6a8ba82c.tar.gz
gentoo-2-14cfe33570b8eac249f919dc1216510d6a8ba82c.tar.bz2
gentoo-2-14cfe33570b8eac249f919dc1216510d6a8ba82c.zip
initial ebuild for mod_bw
(Portage version: 2.0.51.16)
Diffstat (limited to 'net-www/mod_bw')
-rw-r--r--net-www/mod_bw/ChangeLog10
-rw-r--r--net-www/mod_bw/Manifest5
-rw-r--r--net-www/mod_bw/files/11_mod_bw.conf21
-rw-r--r--net-www/mod_bw/files/digest-mod_bw-0.5_rc11
-rw-r--r--net-www/mod_bw/metadata.xml9
-rw-r--r--net-www/mod_bw/mod_bw-0.5_rc1.ebuild30
6 files changed, 76 insertions, 0 deletions
diff --git a/net-www/mod_bw/ChangeLog b/net-www/mod_bw/ChangeLog
new file mode 100644
index 000000000000..646843e1314b
--- /dev/null
+++ b/net-www/mod_bw/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-www/mod_bw
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_bw/ChangeLog,v 1.1 2005/02/14 17:14:50 hollow Exp $
+
+*mod_bw-0.5_rc1 (14 Feb 2005)
+
+ 14 Feb 2005; Benedikt Boehm <hollow@gentoo.org> +metadata.xml,
+ +files/11_mod_bw.conf, +mod_bw-0.5_rc1.ebuild:
+ initial ebuild for mod_bw
+
diff --git a/net-www/mod_bw/Manifest b/net-www/mod_bw/Manifest
new file mode 100644
index 000000000000..4d0680706fda
--- /dev/null
+++ b/net-www/mod_bw/Manifest
@@ -0,0 +1,5 @@
+MD5 41d6c0ba999d7b4af929e07368693a3f metadata.xml 261
+MD5 7c8f1b8fc72af5819eef7d7fc30742bd mod_bw-0.5_rc1.ebuild 730
+MD5 520c167fe5a8a01e063eadb77a25e3a2 ChangeLog 289
+MD5 3df4aa027274bb447f076aef3d2ba92f files/11_mod_bw.conf 518
+MD5 e115388638f885e2b23d665bae2bed12 files/digest-mod_bw-0.5_rc1 61
diff --git a/net-www/mod_bw/files/11_mod_bw.conf b/net-www/mod_bw/files/11_mod_bw.conf
new file mode 100644
index 000000000000..279e7b2d260b
--- /dev/null
+++ b/net-www/mod_bw/files/11_mod_bw.conf
@@ -0,0 +1,21 @@
+<IfDefine BW>
+ <IfModule !mod_bw.c>
+ LoadModule bw_module modules/mod_bw.so
+ </IfModule>
+</IfDefine>
+
+<IfModule mod_bandwidth.c>
+ # This must be turned on for mod_bandwidth to actually do anything
+ # These directives can go inside a VirtualHost or Directory, etc...
+ #
+ # BandWidthModule On
+
+ # Limit 196.168.0.0/24 to 80KB/sec, with a minimum of 60KB/sec
+ #
+ # BandWidth 196.168.0 80000
+ # BandWidth 196.168.0 60000
+
+ # Everyone else shares 50KB/sec
+ #
+ # Bandwidth all 50000
+</IfModule>
diff --git a/net-www/mod_bw/files/digest-mod_bw-0.5_rc1 b/net-www/mod_bw/files/digest-mod_bw-0.5_rc1
new file mode 100644
index 000000000000..76bcb471a979
--- /dev/null
+++ b/net-www/mod_bw/files/digest-mod_bw-0.5_rc1
@@ -0,0 +1 @@
+MD5 ba35ef9676e29c7fbf200bce1b112c1e bw_mod-0.5rc1.tgz 12088
diff --git a/net-www/mod_bw/metadata.xml b/net-www/mod_bw/metadata.xml
new file mode 100644
index 000000000000..22bb50eb3661
--- /dev/null
+++ b/net-www/mod_bw/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>apache</herd>
+ <maintainer>
+ <email>hollow@gentoo.org</email>
+ <name>Benedikt Boehm</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-www/mod_bw/mod_bw-0.5_rc1.ebuild b/net-www/mod_bw/mod_bw-0.5_rc1.ebuild
new file mode 100644
index 000000000000..78ab8b5973f7
--- /dev/null
+++ b/net-www/mod_bw/mod_bw-0.5_rc1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_bw/mod_bw-0.5_rc1.ebuild,v 1.1 2005/02/14 17:14:50 hollow Exp $
+
+inherit eutils apache-module
+
+MYP="bw_mod-${PV}"
+
+DESCRIPTION="Bandwidth Management Module for Apache 2.0"
+HOMEPAGE="http://www.ivn.cl/apache/"
+SRC_URI="http://www.ivn.cl/apache/${MYP/_rc/rc}.tgz"
+
+KEYWORDS="~x86"
+DEPEND=""
+LICENSE="Apache-1.1"
+SLOT="1"
+IUSE=""
+
+APXS2_ARGS="-c ${PN}.c"
+APACHE2_MOD_CONF="11_${PN}"
+APACHE2_MOD_DEFINE="BW"
+
+need_apache2
+
+S=${WORKDIR}/${MYP/_rc*}
+
+src_unpack() {
+ unpack ${A} || die "unpack failed"
+ mv ${S}/{${MYP/_rc/rc}.c,${PN}.c} || die "cannot move source file"
+}