summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-06-28 11:42:56 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-06-28 11:42:56 +0000
commit0ae58b939376cc748cd3fc4e9f8103e88bccedc4 (patch)
tree94752dd54d7be3f28356c95ae9e290468854aeed /net-www
parentstable amd64, bug 229875 (diff)
downloadgentoo-2-0ae58b939376cc748cd3fc4e9f8103e88bccedc4.tar.gz
gentoo-2-0ae58b939376cc748cd3fc4e9f8103e88bccedc4.tar.bz2
gentoo-2-0ae58b939376cc748cd3fc4e9f8103e88bccedc4.zip
Fix a compilation problem on amd64, bug #229453.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25.8 i686)
Diffstat (limited to 'net-www')
-rw-r--r--net-www/gnash/ChangeLog7
-rw-r--r--net-www/gnash/files/gnash-0.8.3-boost-dynamic-link.patch31
-rw-r--r--net-www/gnash/files/gnash-0.8.3-libtool-2.2.patch35
-rw-r--r--net-www/gnash/gnash-0.8.3.ebuild14
4 files changed, 83 insertions, 4 deletions
diff --git a/net-www/gnash/ChangeLog b/net-www/gnash/ChangeLog
index f253a0dce661..75c7a7418064 100644
--- a/net-www/gnash/ChangeLog
+++ b/net-www/gnash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/gnash
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/ChangeLog,v 1.57 2008/06/25 18:35:28 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/ChangeLog,v 1.58 2008/06/28 11:42:55 loki_val Exp $
+
+ 28 Jun 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +files/gnash-0.8.3-boost-dynamic-link.patch,
+ +files/gnash-0.8.3-libtool-2.2.patch, gnash-0.8.3.ebuild:
+ Fix a compilation problem on amd64, bug #229453.
*gnash-0.8.3 (25 Jun 2008)
diff --git a/net-www/gnash/files/gnash-0.8.3-boost-dynamic-link.patch b/net-www/gnash/files/gnash-0.8.3-boost-dynamic-link.patch
new file mode 100644
index 000000000000..2612328b8a14
--- /dev/null
+++ b/net-www/gnash/files/gnash-0.8.3-boost-dynamic-link.patch
@@ -0,0 +1,31 @@
+Index: boost.m4
+===================================================================
+RCS file: /sources/gnash/gnash/macros/boost.m4,v
+retrieving revision 1.74
+diff -u -r1.74 boost.m4
+--- macros/boost.m4 16 Jan 2008 00:42:55 -0000 1.74
++++ macros/boost.m4 19 Jan 2008 18:35:14 -0000
+@@ -127,9 +127,9 @@
+ missing_libs=""
+ fi
+ for j in ${boost_libs}; do
+- dirs="`ls -dr $i/libboost_${j}*.${shlibext} $i/libboost_${j}*.a 2>/dev/null`"
++ dirs="`ls -dr $i/libboost_${j}*.${shlibext} 2>/dev/null`"
+ if test -n "${dirs}"; then
+- libname="`echo ${dirs} | sed -e 's:^.*/lib::' -e "s:\.${shlibext}::" -e "s:\.a::"`"
++ libname="`echo ${dirs} | sed -e 's:^.*/lib::' -e "s:\.${shlibext}::"`"
+ if test x$dirname = x; then
+ dirname="`echo ${dirs} | sed -e 's:/libboost.*$::'`"
+ if test x"${dirname}" != "x/usr/lib"; then
+@@ -143,9 +143,9 @@
+ done
+ done
+ for j in ${extra_boost_libs}; do
+- dirs="`ls -dr ${dirname}/libboost_${j}*.${shlibext} ${dirname}/libboost_${j}*.a 2>/dev/null`"
++ dirs="`ls -dr ${dirname}/libboost_${j}*.${shlibext} 2>/dev/null`"
+ if test -n "${dirs}"; then
+- libname="`echo ${dirs} | sed -e 's:^.*/lib::' -e "s:\.${shlibext}::" -e "s:\.a::"`"
++ libname="`echo ${dirs} | sed -e 's:^.*/lib::' -e "s:\.${shlibext}::"`"
+ ac_cv_path_boost_extra_lib="${ac_cv_path_boost_extra_lib} -l${libname}"
+ else
+ extra_missing_libs="${extra_missing_libs} $j"
diff --git a/net-www/gnash/files/gnash-0.8.3-libtool-2.2.patch b/net-www/gnash/files/gnash-0.8.3-libtool-2.2.patch
new file mode 100644
index 000000000000..f0ec274104b3
--- /dev/null
+++ b/net-www/gnash/files/gnash-0.8.3-libtool-2.2.patch
@@ -0,0 +1,35 @@
+diff -NrU5 gnash-0.8.3.orig/libbase/Makefile.am gnash-0.8.3/libbase/Makefile.am
+--- gnash-0.8.3.orig/libbase/Makefile.am 2008-06-26 22:56:12.000000000 +0200
++++ gnash-0.8.3/libbase/Makefile.am 2008-06-26 22:57:48.000000000 +0200
+@@ -19,13 +19,13 @@
+
+ # this is where Gnash plugins get installed
+ pluginsdir = $(prefix)/lib/gnash/plugins
+
+ if INSTALL_LTDL
+-include_HEADERS = $(top_srcdir)/libltdl/ltdl.h
+-LIBLTDLLIB = libltdl.la
+-LIBLTDLHEAD = $(top_srcdir)/libltdl/ltdl.h
++#include_HEADERS = $(top_srcdir)/libltdl/ltdl.h
++#LIBLTDLLIB = libltdl.la
++#LIBLTDLHEAD = $(top_srcdir)/libltdl/ltdl.h
+ endif
+
+ sysconf_DATA = gnashrc gnashpluginrc
+
+ edit = sed \
+@@ -174,12 +174,12 @@
+
+ libgnashbase_la_LDFLAGS = -release $(VERSION)
+
+ libltdlc_la_CPPFLAGS = $(LTDLINCL)
+ if CONVENIENCE_LTDL
+-noinst_LTLIBRARIES = libltdlc.la
+-libltdlc_la_SOURCES = $(top_srcdir)/libltdl/ltdl.c
++#noinst_LTLIBRARIES = libltdlc.la
++#libltdlc_la_SOURCES = $(top_srcdir)/libltdl/ltdl.c
+ endif
+ CLEANFILES = libltdl.la libltdlc.la gnashrc gnashpluginrc
+
+ libltdl_la_SOURCES = $(top_srcdir)/libltdl/ltdl.c
+ libltdl_la_LDFLAGS = -no-undefined -version-info 4:4:1
diff --git a/net-www/gnash/gnash-0.8.3.ebuild b/net-www/gnash/gnash-0.8.3.ebuild
index 480f0896b5ee..fd2072768fc1 100644
--- a/net-www/gnash/gnash-0.8.3.ebuild
+++ b/net-www/gnash/gnash-0.8.3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/gnash-0.8.3.ebuild,v 1.2 2008/06/26 02:17:56 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/gnash-0.8.3.ebuild,v 1.3 2008/06/28 11:42:55 loki_val Exp $
EAPI=1
-inherit nsplugins kde-functions qt3 multilib
+inherit autotools nsplugins kde-functions qt3 multilib
set-kdedir 3.5
@@ -74,6 +74,7 @@ RDEPEND="
x11-libs/libXt
x11-proto/xproto
dbus? ( sys-apps/dbus )
+ sys-devel/libtool
"
DEPEND="${RDEPEND}
dev-util/pkgconfig
@@ -149,6 +150,9 @@ src_unpack() {
sed -i \
-e 's,config.h,gnashconfig.h,' \
./extensions/dbus/dbus_ext.h || die
+ epatch "${FILESDIR}"/${P}-boost-dynamic-link.patch
+ epatch "${FILESDIR}"/${P}-libtool-2.2.patch
+ eautoreconf
}
src_compile() {
@@ -209,6 +213,9 @@ src_compile() {
--with-extensions=${extensions} \
--with-ffmpeg-incl=/usr/include \
--with-kde-pluginprefix=${KDEDIR} \
+ --without-included-ltdl \
+ --with-ltdl-include=/usr/include \
+ --with-ltdl-lib=/usr/lib \
${myconf} \
|| die "econf failed"
emake || die "emake failed"
@@ -217,7 +224,8 @@ src_compile() {
src_test() {
cd testsuite
make check || die "make check failed"
- ./anaylse-results.sh > TESTRESULTS.txt || die "Analyzing results failed."
+ ./anaylse-results.sh > TESTRESULTS.txt
+ cat TESTRESULTS.txt
}
src_install() {