summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-07-07 00:51:16 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-07-07 00:51:16 +0000
commit17b47c6f92a91a57b7753ce01e33b36442341448 (patch)
tree11a300bf3680ba1b52824b63f9994bb809a785ad /net-www
parentStable on amd64. Remove old versions. Add net-p2p to metadata. (diff)
downloadgentoo-2-17b47c6f92a91a57b7753ce01e33b36442341448.tar.gz
gentoo-2-17b47c6f92a91a57b7753ce01e33b36442341448.tar.bz2
gentoo-2-17b47c6f92a91a57b7753ce01e33b36442341448.zip
Add patch for CXXFLAGS and RPATH thanks to vapier in bug 139457 and 139459
(Portage version: 2.1.1_pre2-r4)
Diffstat (limited to 'net-www')
-rw-r--r--net-www/gnash/ChangeLog6
-rw-r--r--net-www/gnash/files/gnash-fix-cxxflags-rpath.patch50
-rw-r--r--net-www/gnash/gnash-0.7.1_p20060704.ebuild11
3 files changed, 63 insertions, 4 deletions
diff --git a/net-www/gnash/ChangeLog b/net-www/gnash/ChangeLog
index e82e95bbc177..7548ca1f0473 100644
--- a/net-www/gnash/ChangeLog
+++ b/net-www/gnash/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-www/gnash
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/ChangeLog,v 1.14 2006/07/04 17:48:12 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/ChangeLog,v 1.15 2006/07/07 00:51:16 genstef Exp $
+
+ 07 Jul 2006; Stefan Schweizer <genstef@gentoo.org>
+ +files/gnash-fix-cxxflags-rpath.patch, gnash-0.7.1_p20060704.ebuild:
+ Add patch for CXXFLAGS and RPATH thanks to vapier in bug 139457 and 139459
*gnash-0.7.1_p20060704 (04 Jul 2006)
diff --git a/net-www/gnash/files/gnash-fix-cxxflags-rpath.patch b/net-www/gnash/files/gnash-fix-cxxflags-rpath.patch
new file mode 100644
index 000000000000..c490ca0216c3
--- /dev/null
+++ b/net-www/gnash/files/gnash-fix-cxxflags-rpath.patch
@@ -0,0 +1,50 @@
+diff -u gnash/libgeometry/Makefile.am.orig gnash/libgeometry/Makefile.am
+--- gnash/libgeometry/Makefile.am.orig 2006-07-07 01:39:00.000000000 +0200
++++ gnash/libgeometry/Makefile.am 2006-07-07 01:39:23.000000000 +0200
+@@ -38,7 +38,7 @@
+
+ AUTOMAKE_OPTIONS =
+
+-AM_CXXFLAGS = $(CFLAGS) $(SDL_CFLAGS) $(INCLUDES)
++AM_CXXFLAGS = $(CXXFLAGS) $(SDL_CFLAGS) $(INCLUDES)
+ AM_CPPFLAGS = #-Wall
+ # AM_LDFLAGS = $(OPENGL_LIBNS) $(SDL_LIBS)
+
+diff -u gnash/libamf/Makefile.am.orig gnash/libamf/Makefile.am
+--- gnash/libamf/Makefile.am.orig 2006-07-07 01:39:06.000000000 +0200
++++ gnash/libamf/Makefile.am 2006-07-07 01:39:37.000000000 +0200
+@@ -38,7 +38,7 @@
+
+ AUTOMAKE_OPTIONS =
+
+-AM_CXXFLAGS = $(CFLAGS) $(SDL_CFLAGS) $(INCLUDES)
++AM_CXXFLAGS = $(CXXFLAGS) $(SDL_CFLAGS) $(INCLUDES)
+ AM_CPPFLAGS =
+ AM_LDFLAGS = \
+ ../libbase/libgnashbase.la \
+diff -u gnash/plugin/mozilla-sdk/Makefile.am.orig gnash/plugin/mozilla-sdk/Makefile.am
+--- gnash/plugin/mozilla-sdk/Makefile.am.orig 2006-07-07 01:39:12.000000000 +0200
++++ gnash/plugin/mozilla-sdk/Makefile.am 2006-07-07 01:39:52.000000000 +0200
+@@ -42,7 +42,7 @@
+ -I$(srcdir) \
+ -I$(srcdir)/include
+
+-AM_CXXFLAGS = $(CFLAGS) $(INCLUDES)
++AM_CXXFLAGS = $(CXXFLAGS) $(INCLUDES)
+ AM_CPPFLAGS = -DPLUGIN_TRACE -DXP_UNIX # $(FIREFOX_DEFS)
+ # AM_LDFLAGS = $(FIREFOX_LIBS)
+
+diff -u gnash/plugin/Makefile.am.orig gnash/plugin/Makefile.am
+--- gnash/plugin/Makefile.am.orig 2006-07-07 01:40:02.000000000 +0200
++++ gnash/plugin/Makefile.am 2006-07-07 01:40:16.000000000 +0200
+@@ -152,8 +152,8 @@
+ # won't load due to errors with an undefined MaiAtkObject.
+ install-pluginLTLIBRARIES: $(plugin_LTLIBRARIES)
+ test -d "$(DESTDIR)$(plugindir)" || $(mkinstalldirs) "$(DESTDIR)$(plugindir)"
+- cp .libs/libgnashplugin.so $(DESTDIR)$(plugindir)/libgnashplugin.so
+-# $(LIBTOOL) --mode=install $(INSTALL) $(INSTALL_STRIP_FLAG) $(plugin_LTLIBRARIES) "$(DESTDIR)$(plugindir)/$(plugin_LTLIBRARIES)"
++# cp .libs/libgnashplugin.so $(DESTDIR)$(plugindir)/libgnashplugin.so
++ $(LIBTOOL) --mode=install $(INSTALL) $(INSTALL_STRIP_FLAG) $(plugin_LTLIBRARIES) "$(DESTDIR)$(plugindir)/$(plugin_LTLIBRARIES)"
+ $(RM) $(DESTDIR)$(plugindir)/libgnashplugin.*a
+
+
diff --git a/net-www/gnash/gnash-0.7.1_p20060704.ebuild b/net-www/gnash/gnash-0.7.1_p20060704.ebuild
index 9bf02f7bd106..259a8daec030 100644
--- a/net-www/gnash/gnash-0.7.1_p20060704.ebuild
+++ b/net-www/gnash/gnash-0.7.1_p20060704.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/gnash-0.7.1_p20060704.ebuild,v 1.1 2006/07/04 17:48:12 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/gnash-0.7.1_p20060704.ebuild,v 1.2 2006/07/07 00:51:16 genstef Exp $
inherit nsplugins kde-functions autotools
@@ -50,10 +50,15 @@ set-kdedir
src_unpack() {
unpack ${A}
-
- #Fix a busted opengl as-needed
cd ${S}
+
+ # as-needed patch
+ # http://savannah.gnu.org/bugs/?func=detailitem&item_id=16684
epatch ${FILESDIR}/${P}-opengl.diff
+ # CXXFLAGS should be ussed for cpp code and libtool for installation
+ # http://savannah.gnu.org/bugs/?func=detailitem&item_id=17049
+ epatch ${FILESDIR}/gnash-fix-cxxflags-rpath.patch
+
# we want sound
sed -i -e "s:bool do_sound = .*:bool do_sound = true;:" backend/gnash.cpp