summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2001-11-23 04:34:24 +0000
committerMartin Schlemmer <azarah@gentoo.org>2001-11-23 04:34:24 +0000
commit2866570896625dfc648fc67fe3527e61fa31927d (patch)
tree48bc4327d304fa4691bde3768e0946333688f209 /net-www
parentAdded some extra extensions... (diff)
downloadgentoo-2-2866570896625dfc648fc67fe3527e61fa31927d.tar.gz
gentoo-2-2866570896625dfc648fc67fe3527e61fa31927d.tar.bz2
gentoo-2-2866570896625dfc648fc67fe3527e61fa31927d.zip
1\) why didnt you use the \.tar\.bz2 \? 2\) please dont enable irc for all \.\.\. we wont take it out if not for a reason \!
Diffstat (limited to 'net-www')
-rw-r--r--net-www/mozilla/mozilla-0.9.6.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/net-www/mozilla/mozilla-0.9.6.ebuild b/net-www/mozilla/mozilla-0.9.6.ebuild
index c50884194559..3ccae68b1594 100644
--- a/net-www/mozilla/mozilla-0.9.6.ebuild
+++ b/net-www/mozilla/mozilla-0.9.6.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-0.9.6.ebuild,v 1.2 2001/11/23 01:04:00 verwilst Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-0.9.6.ebuild,v 1.3 2001/11/23 04:34:24 azarah Exp $
S=${WORKDIR}/mozilla
DESCRIPTION="The Mozilla web browser"
-
-SRC_URI="ftp://ftp.mozilla.org/pub/mozilla/releases/mozilla${PV}/src/${PN}-source-${PV}.tar.gz"
+SRC_URI="ftp://ftp.mozilla.org/pub/mozilla/releases/mozilla${PV}/src/${PN}-source-${PV}.tar.bz2"
HOMEPAGE="http://www.mozilla.org"
PROVIDE="virtual/x11-web-browser"
@@ -41,6 +40,14 @@ src_compile() {
myconf="${myconf} --enable-strip-libs"
fi
+ # If this dont buildwith mozirc in USE, then you are on your own
+ # Dont enable venkman, etc, as it is already build ...
+ if [ "`use mozirc`" ] ; then
+ myconf="${myconf} --with-extensions=default,irc"
+ else
+ myconf="${myconf} --with-extensions=default"
+ fi
+
export BUILD_MODULES=all
./configure --host=${CHOST} \
@@ -55,7 +62,6 @@ src_compile() {
--with-java-supplement \
--with-extensions=default \
--enable-optimize=-O3 \
- --with-extensions=default,inspector,venkman,irc \
--with-default-mozilla-five-home=/usr/lib/mozilla \
${myconf} || die