summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2007-05-12 12:08:27 +0000
committerLuca Longinotti <chtekk@gentoo.org>2007-05-12 12:08:27 +0000
commitac2968c508445b73b05bc87571059530ab1ce4cf (patch)
tree9172bc0e5a1c25f5dcdec6cfa63d6766e040f3f1 /net-www
parentRegen digest to remove unused entry. (diff)
downloadgentoo-2-ac2968c508445b73b05bc87571059530ab1ce4cf.tar.gz
gentoo-2-ac2968c508445b73b05bc87571059530ab1ce4cf.tar.bz2
gentoo-2-ac2968c508445b73b05bc87571059530ab1ce4cf.zip
Remove apache1 support and dep upon mod_ssl.
(Portage version: 2.1.2.7)
Diffstat (limited to 'net-www')
-rw-r--r--net-www/mod_log_sql/ChangeLog6
-rw-r--r--net-www/mod_log_sql/mod_log_sql-1.100.ebuild12
-rw-r--r--net-www/mod_log_sql/mod_log_sql-1.101.ebuild12
3 files changed, 11 insertions, 19 deletions
diff --git a/net-www/mod_log_sql/ChangeLog b/net-www/mod_log_sql/ChangeLog
index 2355d9dc0585..5d4d870fe997 100644
--- a/net-www/mod_log_sql/ChangeLog
+++ b/net-www/mod_log_sql/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-www/mod_log_sql
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_log_sql/ChangeLog,v 1.30 2007/01/14 17:29:26 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_log_sql/ChangeLog,v 1.31 2007/05/12 12:08:27 chtekk Exp $
+
+ 12 May 2007; Luca Longinotti <chtekk@gentoo.org> mod_log_sql-1.100.ebuild,
+ mod_log_sql-1.101.ebuild:
+ Remove apache1 support and dep upon mod_ssl.
14 Jan 2007; Luca Longinotti <chtekk@gentoo.org>
-files/1.100/42_mod_log_sql.conf, -files/10_mod_log_sql.conf,
diff --git a/net-www/mod_log_sql/mod_log_sql-1.100.ebuild b/net-www/mod_log_sql/mod_log_sql-1.100.ebuild
index c23ff5196d77..5054c1ada531 100644
--- a/net-www/mod_log_sql/mod_log_sql-1.100.ebuild
+++ b/net-www/mod_log_sql/mod_log_sql-1.100.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_log_sql/mod_log_sql-1.100.ebuild,v 1.11 2007/01/14 17:29:26 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_log_sql/mod_log_sql-1.100.ebuild,v 1.12 2007/05/12 12:08:27 chtekk Exp $
inherit apache-module
@@ -15,16 +15,12 @@ IUSE="dbi ssl"
DEPEND="virtual/mysql
dbi? ( dev-db/libdbi )
- ssl? ( dev-libs/openssl !apache2? ( net-www/mod_ssl ) )"
+ ssl? ( dev-libs/openssl )"
RDEPEND="${DEPEND}"
-APACHE1_MOD_CONF="42_${PN}"
APACHE2_MOD_CONF="42_${PN}"
-
-APACHE1_MOD_DEFINE="LOG_SQL"
APACHE2_MOD_DEFINE="LOG_SQL"
-APACHE1_EXECFILES="${PN}_mysql.so ${PN}_dbi.so ${PN}_ssl.so"
APACHE2_EXECFILES=".libs/${PN}_mysql.so .libs/${PN}_dbi.so .libs/${PN}_ssl.so"
DOCFILES="AUTHORS CHANGELOG docs/README docs/manual.html \
@@ -33,9 +29,7 @@ contrib/create_tables.sql contrib/make_combined_log.pl contrib/mysql_import_comb
need_apache
src_compile() {
- local myconf=""
- use apache2 && myconf="--with-apxs=${APXS2}"
- use apache2 || myconf="--with-apxs=${APXS1}"
+ local myconf="--with-apxs=${APXS2}"
use ssl && myconf="${myconf} --with-ssl-inc=/usr"
use ssl || myconf="${myconf} --without-ssl-inc"
use dbi && myconf="${myconf} --with-dbi=/usr"
diff --git a/net-www/mod_log_sql/mod_log_sql-1.101.ebuild b/net-www/mod_log_sql/mod_log_sql-1.101.ebuild
index 88829275dbf0..7155a33ae0ba 100644
--- a/net-www/mod_log_sql/mod_log_sql-1.101.ebuild
+++ b/net-www/mod_log_sql/mod_log_sql-1.101.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_log_sql/mod_log_sql-1.101.ebuild,v 1.2 2007/01/14 17:29:26 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_log_sql/mod_log_sql-1.101.ebuild,v 1.3 2007/05/12 12:08:27 chtekk Exp $
inherit apache-module
@@ -15,16 +15,12 @@ IUSE="dbi ssl"
DEPEND="virtual/mysql
dbi? ( dev-db/libdbi )
- ssl? ( dev-libs/openssl !apache2? ( net-www/mod_ssl ) )"
+ ssl? ( dev-libs/openssl )"
RDEPEND="${DEPEND}"
-APACHE1_MOD_CONF="42_${PN}"
APACHE2_MOD_CONF="42_${PN}"
-
-APACHE1_MOD_DEFINE="LOG_SQL"
APACHE2_MOD_DEFINE="LOG_SQL"
-APACHE1_EXECFILES="${PN}_mysql.so ${PN}_dbi.so ${PN}_ssl.so"
APACHE2_EXECFILES=".libs/${PN}_mysql.so .libs/${PN}_dbi.so .libs/${PN}_ssl.so"
DOCFILES="AUTHORS CHANGELOG docs/README docs/manual.html \
@@ -33,9 +29,7 @@ contrib/create_tables.sql contrib/make_combined_log.pl contrib/mysql_import_comb
need_apache
src_compile() {
- local myconf=""
- use apache2 && myconf="--with-apxs=${APXS2}"
- use apache2 || myconf="--with-apxs=${APXS1}"
+ local myconf="--with-apxs=${APXS2}"
use ssl && myconf="${myconf} --with-ssl-inc=/usr"
use ssl || myconf="${myconf} --without-ssl-inc"
use dbi && myconf="${myconf} --with-dbi=/usr"