summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-01-28 04:18:50 +0000
committerAron Griffis <agriffis@gentoo.org>2004-01-28 04:18:50 +0000
commitd8ade2d7e4ffb958c2f590080a26248d5e963c4c (patch)
tree0b470835e95aa02ab8083f0b7432dddbdb7713d0 /net-www
parentfix #39423, revision bump. (Manifest recommit) (diff)
downloadgentoo-2-d8ade2d7e4ffb958c2f590080a26248d5e963c4c.tar.gz
gentoo-2-d8ade2d7e4ffb958c2f590080a26248d5e963c4c.tar.bz2
gentoo-2-d8ade2d7e4ffb958c2f590080a26248d5e963c4c.zip
Update files/MozillaFirebird to handle the case when Thunderbird is running. Thanks to Denys Dmytriyenko in bug 38102
Diffstat (limited to 'net-www')
-rw-r--r--net-www/mozilla-firebird/ChangeLog9
-rw-r--r--net-www/mozilla-firebird/files/MozillaFirebird15
2 files changed, 16 insertions, 8 deletions
diff --git a/net-www/mozilla-firebird/ChangeLog b/net-www/mozilla-firebird/ChangeLog
index 10e10e370f2f..c544062fb91d 100644
--- a/net-www/mozilla-firebird/ChangeLog
+++ b/net-www/mozilla-firebird/ChangeLog
@@ -1,11 +1,18 @@
# ChangeLog for net-www/mozilla-firebird
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firebird/ChangeLog,v 1.33 2004/01/27 19:42:56 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firebird/ChangeLog,v 1.34 2004/01/28 04:18:50 agriffis Exp $
+
+ 27 Jan 2004; Aron Griffis <agriffis@gentoo.org> files/MozillaFirebird:
+ Update files/MozillaFirebird to handle the case when Thunderbird is running.
+ Thanks to Denys Dmytriyenko in bug 38102
27 Jan 2004; Aron Griffis <agriffis@gentoo.org>
mozilla-firebird-0.7-r1.ebuild:
stable on alpha and ia64
+ 21 Jan 2004; Aron Griffis <agriffis@gentoo.org> files/MozillaFirebird:
+ Use full path to xdpyinfo which can help when executing MozillaFirebird via ssh
+
14 Jan 2004; Aron Griffis <agriffis@gentoo.org> files/MozillaFirebird:
Use more powerful MozillaFirebird startup script from bug 38102. Not doing a
rev-bump since it's not really necessary to make everybody rebuild for this
diff --git a/net-www/mozilla-firebird/files/MozillaFirebird b/net-www/mozilla-firebird/files/MozillaFirebird
index 3f8c2f6ecbc1..8e1dabfa9f24 100644
--- a/net-www/mozilla-firebird/files/MozillaFirebird
+++ b/net-www/mozilla-firebird/files/MozillaFirebird
@@ -2,7 +2,7 @@
#
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firebird/files/MozillaFirebird,v 1.2 2004/01/14 20:50:49 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firebird/files/MozillaFirebird,v 1.3 2004/01/28 04:18:50 agriffis Exp $
# Set to "window" if you prefer new Firebird windows instead of new tabs
newtype=${MOZILLA_NEWTYPE:-"tab"}
@@ -44,7 +44,7 @@ done
# Try to start in an existing session; check all screens
declare -a screens=(
- $(xdpyinfo | awk '
+ $(/usr/X11R6/bin/xdpyinfo | awk '
/^name of display:/ {
disp = substr($NF, 0, index($NF, ".")-1)
}
@@ -58,14 +58,15 @@ for s in $DISPLAY "${screens[@]}"; do
done
retval=$?
-if [[ $retval -eq 2 ]] ; then
- # No running windows found, so start a new instance
- ${fbpath}/MozillaFirebird "${args[@]}"
+if [[ $retval -eq 2 || $retval -eq 3 ]] ; then
+ # 2 = No running windows found, so start a new instance
+ # 3 = Thunderbird is running, but doesn't handle openURL command
+ # (or it might be an unresponsive Firebird)
+ ${fbpath}/MozillaFirebird "${args[@]}" && exit 0
retval=$?
+ echo "MozillaFirebird exited with non-zero status ($retval)" >&2
elif [[ $retval -eq 1 ]] ; then
echo "Unable to connect to X server" >&2
-elif [[ $retval -eq 3 ]] ; then
- echo "Unable to send command to running Mozilla Firebird instance" >&2
else
echo "Unknown error $retval from mozilla-xremote-client" >&2
fi