summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2003-08-03 19:20:50 +0000
committerStuart Herbert <stuart@gentoo.org>2003-08-03 19:20:50 +0000
commitf24617b79a72425545a4e1719a202a132fae0a9e (patch)
tree4ab8210252ad4758b34d80660d6598cd66823de3 /net-www
parentFix for bug #24294 (diff)
downloadgentoo-2-f24617b79a72425545a4e1719a202a132fae0a9e.tar.gz
gentoo-2-f24617b79a72425545a4e1719a202a132fae0a9e.tar.bz2
gentoo-2-f24617b79a72425545a4e1719a202a132fae0a9e.zip
Fix for bug #24294
Diffstat (limited to 'net-www')
-rw-r--r--net-www/phpBB/Manifest2
-rw-r--r--net-www/phpBB/phpBB-2.0.4.ebuild27
2 files changed, 16 insertions, 13 deletions
diff --git a/net-www/phpBB/Manifest b/net-www/phpBB/Manifest
index f38f049e8b51..d4d0763f83b9 100644
--- a/net-www/phpBB/Manifest
+++ b/net-www/phpBB/Manifest
@@ -1,5 +1,5 @@
MD5 4a19fcfcfcffdc9ae043a36e093cb222 phpBB-2.0.5.ebuild 1498
-MD5 fec17592f5eac31045d15b4972fa077e phpBB-2.0.4.ebuild 1445
+MD5 f6af7020b2e58fda3d18fb6650f9921c phpBB-2.0.4.ebuild 1444
MD5 e3ffd195d56f5b33813705d1b0a2a438 ChangeLog 528
MD5 1c9cf1de5be80b37285838551452ebf4 files/digest-phpBB-2.0.4 63
MD5 b0e9ee3a18db6416eedbe05a7c409b36 files/digest-phpBB-2.0.5 63
diff --git a/net-www/phpBB/phpBB-2.0.4.ebuild b/net-www/phpBB/phpBB-2.0.4.ebuild
index c4b2092205fc..167a19b24d7d 100644
--- a/net-www/phpBB/phpBB-2.0.4.ebuild
+++ b/net-www/phpBB/phpBB-2.0.4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Tim Raedisch <tim.raedisch@udo.edu>
-# $Header: /var/cvsroot/gentoo-x86/net-www/phpBB/phpBB-2.0.4.ebuild,v 1.2 2003/02/10 16:21:53 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/phpBB/phpBB-2.0.4.ebuild,v 1.3 2003/08/03 19:20:42 stuart Exp $
S=${WORKDIR}/${PN}2
DESCRIPTION="phpBB is a high powered, fully scalable, and highly customisable open-source bulletin board package."
@@ -14,20 +14,24 @@ KEYWORDS="~x86 ~ppc ~sparc ~alpha"
DEPEND="virtual/php"
-HTTPD_ROOT="`grep '^DocumentRoot' /etc/apache/conf/apache.conf | cut -d\ -f2`"
-[ -z "${HTTPD_ROOT}" ] && HTTPD_ROOT="`grep '^DocumentRoot' /etc/apache2/conf/apache.conf | cut -d\ -f2`"
-[ -z "${HTTPD_ROOT}" ] && HTTPD_ROOT="/home/httpd/htdocs"
-HTTPD_USER="apache"
-HTTPD_GROUP="apache"
+# this is the eclass that handles apache-specific stuff
+inherit webapp-apache
+
+# these are the functions provided by the webapp eclass solution
+
+webapp-determine-installowner
+webapp-determine-htdocsdir
pkg_setup() {
- if [ -L ${HTTPD_ROOT}/phpbb ] ; then
+ if [ -d "${HTTPD_ROOT}/phpbb" ] ; then
ewarn "You need to unmerge your old phpBB version first."
ewarn "phpBB will be installed into ${HTTPD_ROOT}/phpbb"
ewarn "directly instead of a version-dependant directory."
die "need to unmerge old version first"
fi
+
+ einfo "Installing for ${WEBAPP_SERVER}"
}
src_compile() {
@@ -37,11 +41,10 @@ src_compile() {
src_install() {
cd ${S}
- dodir ${HTTPD_ROOT}/phpbb
- cp -r * ${D}/${HTTPD_ROOT}/phpbb
- cd ${D}/${HTTPD_ROOT}
- chown -R ${HTTPD_USER}.${HTTPD_GROUP} ${D}/${HTTPD_ROOT}/phpbb
- dodoc ${S}/docs/*
+ dodir "${HTTPD_ROOT}/phpbb"
+ cp -a * "${D}/${HTTPD_ROOT}/phpbb"
+ chown -R "${HTTPD_USER}.${HTTPD_GROUP}" "${D}/${HTTPD_ROOT}/phpbb"
+ dodoc "${S}/docs/*"
}