summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Morgan <jmorgan@gentoo.org>2003-01-09 12:45:34 +0000
committerJack Morgan <jmorgan@gentoo.org>2003-01-09 12:45:34 +0000
commitf249275030851083b209b7e21a8b85b141635b2e (patch)
tree3445310e5bd53c2982ffeab9a9fbe7201889cc81 /net-www
parentAdded 'use dns logger' (diff)
downloadgentoo-2-f249275030851083b209b7e21a8b85b141635b2e.tar.gz
gentoo-2-f249275030851083b209b7e21a8b85b141635b2e.tar.bz2
gentoo-2-f249275030851083b209b7e21a8b85b141635b2e.zip
added sparc support with replace-flags
Diffstat (limited to 'net-www')
-rw-r--r--net-www/mozilla/ChangeLog14
-rw-r--r--net-www/mozilla/mozilla-1.2.1-r4.ebuild9
2 files changed, 12 insertions, 11 deletions
diff --git a/net-www/mozilla/ChangeLog b/net-www/mozilla/ChangeLog
index c392ca1c7ed5..2e448bc2bb1e 100644
--- a/net-www/mozilla/ChangeLog
+++ b/net-www/mozilla/ChangeLog
@@ -1,43 +1,37 @@
# ChangeLog for net-www/mozilla
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/ChangeLog,v 1.79 2003/01/08 22:29:02 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/ChangeLog,v 1.80 2003/01/09 12:45:34 jmorgan Exp $
- 09 Jan 2003; Martin Schlemmer <azarah@gentoo.org> mozilla-1.2.1-r4.ebuild :
+ 09 Jan 2003; Jack Morgan <jmorgan@gentoo.org> mozilla-1.2.1-r4.ebuild :
+ Added sparc support with replace-flags (bug #13554 - thanks to Kumba)
+ 09 Jan 2003; Martin Schlemmer <azarah@gentoo.org> mozilla-1.2.1-r4.ebuild :
We set -O in ./configure to -O1, as -O2 cause crashes on startup ...
(bug #13287)
26 Dec 2002; Martin Schlemmer <azarah@gentoo.org> mozilla-1.2.1-r4.ebuild :
-
Same as last -r3, just created to make sure we have all the fixes, and
marked stable for x86.
26 Dec 2002; Martin Schlemmer <azarah@gentoo.org> mozilla-1.2.1-r3.ebuild :
-
Update google search plugin, closing bug #10605.
-
Fix my braindead stuff up with the "WANT_GTK2" fix of yesterday.
25 Dec 2002; Martin Schlemmer <azarah@gentoo.org> mozilla-1.2.1-r3.ebuild :
-
Add pkg_setup() to not build with gtk2 support if the user did not export
WANT_GTK2="yes". I did this due to the multitude of problems with gtk2
support (plugins do not work, crashes, etc).
23 Dec 2002; Martin Schlemmer <azarah@gentoo.org> mozilla-1.2.1-r3.ebuild :
-
Some cleanups for the java-config stuff in an effort to resolve bug #12610.
17 Dec 2002; Martin Schlemmer <azarah@gentoo.org> mozilla-1.2.1-r3.ebuild :
-
Update mozilla-1.2.1-Xrender-includes.patch.bz2 to hopefully (?) fix #12223.
16 Dec 2002; Martin Schlemmer <azarah@gentoo.org> mozilla-1.2.1-r3.ebuild :
-
Update mozilla-1.2.1-Xrender-includes.patch.bz2 to truely fix #12223.
16 Dec 2002; Martin Schlemmer <azarah@gentoo.org> mozilla-1.2.1-r3.ebuild :
-
Currently --enable-elf-dynstr-gc only works for x86 and ppc, thanks
to Jason Wever <weeve@gentoo.org> for the fix.
diff --git a/net-www/mozilla/mozilla-1.2.1-r4.ebuild b/net-www/mozilla/mozilla-1.2.1-r4.ebuild
index 7ff1d83fd311..75806ac1513f 100644
--- a/net-www/mozilla/mozilla-1.2.1-r4.ebuild
+++ b/net-www/mozilla/mozilla-1.2.1-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.2.1-r4.ebuild,v 1.2 2003/01/08 22:29:02 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.2.1-r4.ebuild,v 1.3 2003/01/09 12:45:34 jmorgan Exp $
IUSE="java crypt ipv6 gtk2 ssl ldap gnome"
# Internal USE flags that I do not really want to advertise ...
@@ -12,6 +12,10 @@ inherit flag-o-matic gcc makeedit eutils nsplugins
# Crashes on start when compiled with -fomit-frame-pointer
filter-flags "-fomit-frame-pointer"
+# Sparc support ...
+replace-flags "-mcpu=ultrasparc" "-mcpu=v8 -mtune=v9 -O2 -pipe"
+replace-flags "-mcpu=v9" "-mcpu=v8 -mtune=v9 -o2 -pipe"
+
# Recently there has been a lot of stability problem in Gentoo-land. Many
# things can be the cause to this, but I believe that it is due to gcc3
# still having issues with optimizations, or with it not filtering bad
@@ -739,3 +743,6 @@ pkg_postrm() {
fi
}
+# Sparc support ...
+replace-flags "-mcpu=ultrasparc" "-mcpu=v8"
+replace-flags "-mcpu=v9" "-mcpu=v8"