summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJodok Batlogg <batlogg@gentoo.org>2004-07-27 20:22:17 +0000
committerJodok Batlogg <batlogg@gentoo.org>2004-07-27 20:22:17 +0000
commit56fe648cd59c0df6e4e29edf1ff2b3f3dc982c7f (patch)
tree143cb73ccc5663c2a24bf0089b0a6f534f6783ee /net-zope/externaleditor/externaleditor-0.8.ebuild
parentstable on x86, since xorg-x11 is stable and lots of people want these. (Manif... (diff)
downloadgentoo-2-56fe648cd59c0df6e4e29edf1ff2b3f3dc982c7f.tar.gz
gentoo-2-56fe648cd59c0df6e4e29edf1ff2b3f3dc982c7f.tar.bz2
gentoo-2-56fe648cd59c0df6e4e29edf1ff2b3f3dc982c7f.zip
version bump, removed old ebuild, added IUSE
Diffstat (limited to 'net-zope/externaleditor/externaleditor-0.8.ebuild')
-rw-r--r--net-zope/externaleditor/externaleditor-0.8.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/net-zope/externaleditor/externaleditor-0.8.ebuild b/net-zope/externaleditor/externaleditor-0.8.ebuild
new file mode 100644
index 000000000000..8d76dc140493
--- /dev/null
+++ b/net-zope/externaleditor/externaleditor-0.8.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/externaleditor/externaleditor-0.8.ebuild,v 1.1 2004/07/27 20:22:17 batlogg Exp $
+
+inherit zproduct
+
+MY_PN="ExternalEditor"
+MY_P="${MY_PN}-${PV}-src"
+MY_P2="zopeedit-${PV}-src"
+DESCRIPTION="Allows you to use your favorite editor(s) from ZMI."
+HOMEPAGE="http://www.zope.org/Members/Caseman/${MY_PN}/"
+SRC_URI_BASE="${HOMEPAGE}/${PV}"
+SRC_URI="${SRC_URI_BASE}/${MY_P}.tgz
+ ${SRC_URI_BASE}/${MY_P2}.tgz"
+LICENSE="ZPL"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+ZPROD_LIST="${MY_PN}"
+
+# the base of teh application is in Python2.1, but zopeedit.py wants Python2.2
+RDEPEND="${RDEPEND}
+ >=dev-lang/python-2.2*"
+
+S_ZPROD=${WORKDIR}/${MY_PN}
+S_SRC=${WORKDIR}/${MY_P2}
+S=${S_SRC}
+MYDOC="*.txt ${MYDOC}"
+
+src_unpack() {
+ mkdir ${S_ZPROD}.tmp
+ unpack ${MY_P}.tgz
+ mv ${S_ZPROD} ${S_ZPROD}.tmp
+ mv ${S_ZPROD}.tmp ${S_ZPROD}
+ unpack ${MY_P2}.tgz
+}
+
+DOCDIR=/usr/share/doc/${PF}
+
+src_install()
+{
+ S=${S_ZPROD} zproduct_src_install
+ mkdir -p ${T}${DOCDIR}/${MY_PN}
+ mv ${D}${DOCDIR}/* ${T}${DOCDIR}/${MY_PN}
+ mv ${T}${DOCDIR}/${MY_PN} ${D}${DOCDIR}
+
+ into /usr
+ dobin zopeedit.py
+ doman man/zopeedit.1
+ docinto zopeedit
+ dodoc *.txt
+ insinto /usr/share/${PN}/Plugins
+ doins Plugins/*.py
+}
+
+pkg_postinst()
+{
+ zproduct_pkg_postinst
+ ewarn "To use the External Editor Zope Product you will need to manually"
+ ewarn "configure the helper application(/usr/bin/zopeedit.py) for your"
+ ewarn "browser. Read the documention in ${DOCDIR}."
+}