summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-10 16:29:31 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-10 16:29:31 +0000
commit1a2828cfe13f549511062e9fad9114a0ef2b740e (patch)
tree908d09db8f13a7d4409961d18ea4e355ae66ff3d /net-zope/zope-proxy/zope-proxy-3.5.0.ebuild
parentold (diff)
downloadgentoo-2-1a2828cfe13f549511062e9fad9114a0ef2b740e.tar.gz
gentoo-2-1a2828cfe13f549511062e9fad9114a0ef2b740e.tar.bz2
gentoo-2-1a2828cfe13f549511062e9fad9114a0ef2b740e.zip
Initial import from python overlay (bug #191259).
(Portage version: 14556-svn/cvs/Linux x86_64)
Diffstat (limited to 'net-zope/zope-proxy/zope-proxy-3.5.0.ebuild')
-rw-r--r--net-zope/zope-proxy/zope-proxy-3.5.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-zope/zope-proxy/zope-proxy-3.5.0.ebuild b/net-zope/zope-proxy/zope-proxy-3.5.0.ebuild
new file mode 100644
index 000000000000..666303822855
--- /dev/null
+++ b/net-zope/zope-proxy/zope-proxy-3.5.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-proxy/zope-proxy-3.5.0.ebuild,v 1.1 2009/10/10 16:29:31 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_PN="${PN/-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Generic Transparent Proxies"
+HOMEPAGE="http://pypi.python.org/pypi/zope.proxy"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="net-zope/zope-interface"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="${PN/-//}"
+DOCS="CHANGES.txt README.txt"