summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2008-05-27 20:59:50 +0000
committerAlfredo Tupone <tupone@gentoo.org>2008-05-27 20:59:50 +0000
commit84d556487afb5fe4a8247866344c3a20d6c0906e (patch)
tree07b19e976858259f43fe1dc164079188b58f47d4 /net-zope/zope/zope-3.3.1.ebuild
parentStable for HPPA (bug #223437). (diff)
downloadgentoo-2-84d556487afb5fe4a8247866344c3a20d6c0906e.tar.gz
gentoo-2-84d556487afb5fe4a8247866344c3a20d6c0906e.tar.bz2
gentoo-2-84d556487afb5fe4a8247866344c3a20d6c0906e.zip
Making repoman happy
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-zope/zope/zope-3.3.1.ebuild')
-rw-r--r--net-zope/zope/zope-3.3.1.ebuild14
1 files changed, 5 insertions, 9 deletions
diff --git a/net-zope/zope/zope-3.3.1.ebuild b/net-zope/zope/zope-3.3.1.ebuild
index 6d45f180580b..f1249f6d5901 100644
--- a/net-zope/zope/zope-3.3.1.ebuild
+++ b/net-zope/zope/zope-3.3.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/zope-3.3.1.ebuild,v 1.2 2007/11/25 01:31:27 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/zope-3.3.1.ebuild,v 1.3 2008/05/27 20:59:50 tupone Exp $
inherit eutils multilib
@@ -30,16 +30,12 @@ ZINSTDIR=/var/lib/zope/${P}
src_compile() {
- cd ${S}
-
- ./configure --prefix=${D}${ZSERVDIR} --with-python=/usr/bin/python2.4 || die "Failed to configure."
+ ./configure --prefix="${D}"${ZSERVDIR} --with-python=/usr/bin/python2.4 || die "Failed to configure."
emake || die "Failed to compile."
}
src_install() {
- cd ${S}
-
dodoc README.txt
dodoc Zope/doc/*.txt
for DIR in schema security skins style zcml zsync
@@ -48,12 +44,12 @@ src_install() {
dodoc Zope/doc/${DIR}/*
done
- make install prefix=${D}${ZSERVDIR}
+ make install prefix="${D}"${ZSERVDIR}
dosym ../../share/doc/${PF} ${ZSERVDIR}/doc
# copy the init script skeleton to zopeskel directory of our installation
- cp ${FILESDIR}/zope.initd ${D}${ZSKELDIR}/zope.initd
+ cp "${FILESDIR}"/zope.initd "${D}"${ZSKELDIR}/zope.initd
}
pkg_postinst() {