summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-13 18:18:04 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-13 18:18:04 +0000
commit36faf7b2768e6fa772ff26208d1fd3d3d107feb1 (patch)
treeaeb69dc749798b5ca9873a26b5013cb4dd58d431 /net-zope/zope
parentMask =net-zope/zope-2.12*. (diff)
downloadgentoo-2-36faf7b2768e6fa772ff26208d1fd3d3d107feb1.tar.gz
gentoo-2-36faf7b2768e6fa772ff26208d1fd3d3d107feb1.tar.bz2
gentoo-2-36faf7b2768e6fa772ff26208d1fd3d3d107feb1.zip
Version bump (bug #287188).
(Portage version: 15094-svn/cvs/Linux x86_64)
Diffstat (limited to 'net-zope/zope')
-rw-r--r--net-zope/zope/ChangeLog8
-rw-r--r--net-zope/zope/files/zope-2.12.1-fix_build.patch25
-rw-r--r--net-zope/zope/zope-2.12.1.ebuild140
3 files changed, 172 insertions, 1 deletions
diff --git a/net-zope/zope/ChangeLog b/net-zope/zope/ChangeLog
index ff603cc26dd1..8f28a45910d5 100644
--- a/net-zope/zope/ChangeLog
+++ b/net-zope/zope/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-zope/zope
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/ChangeLog,v 1.160 2009/09/11 19:12:11 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/ChangeLog,v 1.161 2009/12/13 18:18:04 arfrever Exp $
+
+*zope-2.12.1 (13 Dec 2009)
+
+ 13 Dec 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +zope-2.12.1.ebuild, +files/zope-2.12.1-fix_build.patch:
+ Version bump (bug #287188).
11 Sep 2009; Markus Meier <maekke@gentoo.org> zope-2.9.10-r1.ebuild,
zope-2.10.7-r1.ebuild:
diff --git a/net-zope/zope/files/zope-2.12.1-fix_build.patch b/net-zope/zope/files/zope-2.12.1-fix_build.patch
new file mode 100644
index 000000000000..35d35ee8bd64
--- /dev/null
+++ b/net-zope/zope/files/zope-2.12.1-fix_build.patch
@@ -0,0 +1,25 @@
+--- inst/Makefile.in
++++ inst/Makefile.in
+@@ -53,10 +53,10 @@
+ ${RMRF} ${BUILD_BASE}
+
+ # install: Install a software home.
+-install: build version_txt
+- ${PYTHON} "${BASE_DIR}/setup.py" ${DISTUTILS_OPTS} install \
+- --home="${PREFIX}" ${BUILD_FLAGS} ${INSTALL_FLAGS}
+- [ -f ${PREFIX}/bin/python ] || ${LN} ${PYTHON} ${PREFIX}/bin/python
++install: version_txt
++ ${PYTHON} "${BASE_DIR}/setup.py" ${DISTUTILS_OPTS} build \
++ ${BUILD_FLAGS} install --home="${PREFIX}" --root="${DESTDIR}" ${INSTALL_FLAGS}
++ [ -f "${PREFIX}/bin/python" ] || ${LN} "${PYTHON}" "${DESTDIR}${PREFIX}/bin/python"
+ @echo
+ @echo Zope binaries installed successfully.
+ @echo Now run \'${PREFIX}/bin/mkzopeinstance.py\'
+@@ -111,6 +111,7 @@
+
+ # version_txt: create a version file in lib/python/version.txt
+ version_txt:
++ ${MKDIR} "${BASE_DIR}/lib/python/Zope2"
+ printf "Zope ${MAJOR_VERSION}.${MINOR_VERSION}-${RELEASE_TAG}" >\
+ "${BASE_DIR}/lib/python/Zope2/version.txt"
+
diff --git a/net-zope/zope/zope-2.12.1.ebuild b/net-zope/zope/zope-2.12.1.ebuild
new file mode 100644
index 000000000000..6c55ac29506c
--- /dev/null
+++ b/net-zope/zope/zope-2.12.1.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/zope-2.12.1.ebuild,v 1.1 2009/12/13 18:18:04 arfrever Exp $
+
+EAPI="2"
+
+inherit eutils multilib versionator
+
+MY_PN="Zope2"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Zope is a web application platform used for building high-performance, dynamic web sites"
+HOMEPAGE="http://www.zope.org http://pypi.python.org/pypi/Zope2"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64"
+IUSE="doc"
+RESTRICT="test"
+
+RDEPEND="( >=dev-lang/python-2.5.4 =dev-lang/python-2* )
+ dev-python/docutils
+ dev-python/restrictedpython
+ dev-python/setuptools
+ net-zope/acquisition
+ net-zope/datetime
+ net-zope/extensionclass
+ net-zope/persistence
+ net-zope/tempstorage
+ net-zope/transaction
+ net-zope/zdaemon
+ net-zope/zconfig
+ net-zope/zlog
+ >=net-zope/zodb-3.9
+ net-zope/zope-app-form
+ net-zope/zope-app-publication
+ net-zope/zope-app-publisher
+ net-zope/zope-app-schema
+ net-zope/zope-component
+ net-zope/zope-configuration
+ net-zope/zope-container
+ net-zope/zope-contentprovider
+ net-zope/zope-contenttype
+ net-zope/zope-deferredimport
+ net-zope/zope-event
+ net-zope/zope-exceptions
+ net-zope/zope-formlib
+ net-zope/zope-i18n
+ net-zope/zope-i18nmessageid
+ net-zope/zope-interface
+ net-zope/zope-lifecycleevent
+ net-zope/zope-location
+ net-zope/zope-pagetemplate
+ net-zope/zope-processlifetime
+ net-zope/zope-proxy
+ net-zope/zope-publisher
+ net-zope/zope-schema
+ net-zope/zope-security
+ net-zope/zope-sendmail
+ net-zope/zope-sequencesort
+ net-zope/zope-site
+ net-zope/zope-size
+ net-zope/zope-structuredtext
+ net-zope/zope-tales
+ net-zope/zope-testbrowser
+ net-zope/zope-testing
+ net-zope/zope-traversing
+ net-zope/zope-viewlet
+"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx )"
+
+S="${WORKDIR}/${MY_P}"
+
+ZUID="zope"
+ZGID="zope"
+ZS_DIR="${ROOT}usr/$(get_libdir)"
+ZSERVDIR="${ZS_DIR}/${PN}-${SLOT}"
+
+# Narrow the scope of ownership/permissions.
+# Security plan:
+# * ZUID is the superuser for all zope instances.
+# * ZGID is for a single instance's administration.
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-fix_build.patch"
+}
+
+src_configure() {
+ local python2_version="$(readlink /usr/bin/python2)"
+ if [[ "${python2_version}" != "python2."* ]]; then
+ die "'/usr/bin/python2' isn't valid symlink"
+ fi
+
+ ./configure --prefix="${ZSERVDIR}" --with-python="/usr/bin/${python2_version}" || die "Configuration failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+
+ if use doc; then
+ cd doc
+ emake html || die "Building of documentation failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ for file in "${D}usr/$(get_libdir)/${PN}-${SLOT}/bin/"*; do
+ if [[ -f "${file}" && ! -L "${file}" ]]; then
+ sed -e '/import sys/iimport os\nos.environ["PYTHONPATH"] = os.path.abspath(os.path.join(os.path.dirname(__file__), "..", "lib", "python"))' -e '/import sys/asys.path.insert(0, os.path.abspath(os.path.join(os.path.dirname(__file__), "..", "lib", "python")))' -i "${file}" || die "Changing of os.environ and sys.path in ${file} failed"
+ fi
+ done
+
+ touch "${D}usr/$(get_libdir)/${PN}-${SLOT}/lib/python/Products/__init__.py" || die "touch failed"
+
+ if use doc; then
+ pushd doc/.build/html > /dev/null
+ dodoc _sources/* || die "Installation of documentation failed"
+ docinto html
+ dohtml -r [A-Za-z]* _static || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
+
+ # Copy the init script skeleton to skel directory of our installation.
+ insinto "${ZSERVDIR}/skel"
+ doins "${FILESDIR}/zope.initd" || die "doins failed"
+}
+
+pkg_postinst() {
+ # Create the zope user and group for backward compatibility.
+ enewgroup ${ZGID} 261
+ usermod -g ${ZGID} ${ZUID} 2>&1 >/dev/null || \
+ enewuser ${ZUID} 261 -1 /var/$(get_libdir)/zope ${ZGID}
+
+ einfo "Be warned that you need at least one zope instance to run zope."
+ einfo "Please emerge zope-config for further instance management."
+}