summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-02-11 21:40:36 +0000
committerMichał Górny <mgorny@gentoo.org>2013-02-11 21:40:36 +0000
commit58a445fda82f43e807e2a9ebefaa2afb0f88df16 (patch)
tree4562dfd8d321cb1df1db3f2fd2c1eaa004ac1417 /net-zope
parentadd python2_6 support (diff)
downloadgentoo-2-58a445fda82f43e807e2a9ebefaa2afb0f88df16.tar.gz
gentoo-2-58a445fda82f43e807e2a9ebefaa2afb0f88df16.tar.bz2
gentoo-2-58a445fda82f43e807e2a9ebefaa2afb0f88df16.zip
Migrate to distutils-r1.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'net-zope')
-rw-r--r--net-zope/zope-interface/ChangeLog7
-rw-r--r--net-zope/zope-interface/zope-interface-4.0.3-r1.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/net-zope/zope-interface/ChangeLog b/net-zope/zope-interface/ChangeLog
index 8c6f7097f3a1..7971b2e1e770 100644
--- a/net-zope/zope-interface/ChangeLog
+++ b/net-zope/zope-interface/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-zope/zope-interface
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-interface/ChangeLog,v 1.43 2013/02/02 05:42:26 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-interface/ChangeLog,v 1.44 2013/02/11 21:40:36 mgorny Exp $
+
+*zope-interface-4.0.3-r1 (11 Feb 2013)
+
+ 11 Feb 2013; Michał Górny <mgorny@gentoo.org> +zope-interface-4.0.3-r1.ebuild:
+ Migrate to distutils-r1.
02 Feb 2013; Patrick Lauer <patrick@gentoo.org> zope-interface-4.0.3.ebuild:
Restrict py 2.5 #455088
diff --git a/net-zope/zope-interface/zope-interface-4.0.3-r1.ebuild b/net-zope/zope-interface/zope-interface-4.0.3-r1.ebuild
new file mode 100644
index 000000000000..589f81dbffbd
--- /dev/null
+++ b/net-zope/zope-interface/zope-interface-4.0.3-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-interface/zope-interface-4.0.3-r1.ebuild,v 1.1 2013/02/11 21:40:36 mgorny Exp $
+
+EAPI=5
+
+# Tests fail with py3.1
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy{1_9,2_0} )
+
+inherit distutils-r1 flag-o-matic
+
+MY_PN="${PN/-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Interfaces for Python"
+HOMEPAGE="http://pypi.python.org/pypi/zope.interface"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# net-zope/zope-fixers is required for building with Python 3.
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ net-zope/zope-fixers[$(python_gen_usedep python3*)]"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( CHANGES.txt README.txt )
+
+python_compile() {
+ if [[ ${EPYTHON} != python3* ]]; then
+ local CFLAGS CXXFLAGS
+ append-flags -fno-strict-aliasing
+ fi
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ esetup.py test
+}