summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRadoslaw Stachowiak <radek@gentoo.org>2006-10-21 21:30:06 +0000
committerRadoslaw Stachowiak <radek@gentoo.org>2006-10-21 21:30:06 +0000
commita2dc079a016d7d48860a8f317b9711a1faef3fd0 (patch)
treef263a8bbfa622facdcdfac6f915ca7af265f9f86 /net-zope
parentRemove monolithic X from dependencies and fix quotes. (diff)
downloadgentoo-2-a2dc079a016d7d48860a8f317b9711a1faef3fd0.tar.gz
gentoo-2-a2dc079a016d7d48860a8f317b9711a1faef3fd0.tar.bz2
gentoo-2-a2dc079a016d7d48860a8f317b9711a1faef3fd0.zip
initial version of slot 3.3.0 of zope
(Portage version: 2.1.2_pre3-r6)
Diffstat (limited to 'net-zope')
-rw-r--r--net-zope/zope/ChangeLog7
-rw-r--r--net-zope/zope/files/digest-zope-3.3.03
-rw-r--r--net-zope/zope/zope-3.3.0.ebuild124
3 files changed, 133 insertions, 1 deletions
diff --git a/net-zope/zope/ChangeLog b/net-zope/zope/ChangeLog
index 94c072c28689..977c71cd8ca1 100644
--- a/net-zope/zope/ChangeLog
+++ b/net-zope/zope/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-zope/zope
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/ChangeLog,v 1.115 2006/10/03 11:53:33 radek Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/ChangeLog,v 1.116 2006/10/21 21:30:06 radek Exp $
+
+*zope-3.3.0 (21 Oct 2006)
+
+ 21 Oct 2006; Radoslaw Stachowiak <radek@gentoo.org> +zope-3.3.0.ebuild:
+ initial version of slot 3.3.0 of zope
*zope-2.10.0 (03 Oct 2006)
diff --git a/net-zope/zope/files/digest-zope-3.3.0 b/net-zope/zope/files/digest-zope-3.3.0
new file mode 100644
index 000000000000..8f9ec241aa81
--- /dev/null
+++ b/net-zope/zope/files/digest-zope-3.3.0
@@ -0,0 +1,3 @@
+MD5 a0c36d7db1e821d12cdd990953c7da8a Zope-3.3.0.tgz 6634834
+RMD160 e8dd6c74d83646d1e9093bb3147450088dcd06e3 Zope-3.3.0.tgz 6634834
+SHA256 a1f9decff79265f487b2ee27c07c9f7a7930a4c7b061f93d110c6fe1f1f02b30 Zope-3.3.0.tgz 6634834
diff --git a/net-zope/zope/zope-3.3.0.ebuild b/net-zope/zope/zope-3.3.0.ebuild
new file mode 100644
index 000000000000..1207a6426401
--- /dev/null
+++ b/net-zope/zope/zope-3.3.0.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/zope-3.3.0.ebuild,v 1.1 2006/10/21 21:30:06 radek Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="Zope is a web application platform used for building high-performance, dynamic web sites"
+HOMEPAGE="http://www.zope.org"
+SRC_URI="http://www.zope.org/Products/Zope3/${PV}/Zope-${PV}.tgz"
+
+LICENSE="ZPL"
+SLOT="${PV}"
+KEYWORDS="~sparc ~x86"
+IUSE=""
+
+RDEPEND="=dev-lang/python-2.4*"
+DEPEND="${RDEPEND}
+ >=app-shells/bash-2.0
+ >=sys-apps/sed-4.0.5"
+
+S=${WORKDIR}/Zope-${PV}
+
+ZUNAME=zope
+ZGNAME=zope
+
+ZS_DIR=${ROOT%/}/usr/$(get_libdir)
+ZSERVDIR=${ZS_DIR}/${P}
+ZSKELDIR=${ZSERVDIR}/zopeskel
+ZINSTDIR=/var/lib/zope/${P}
+
+src_compile() {
+
+ cd ${S}
+
+ ./configure --prefix=${D}${ZSERVDIR} --with-python=/usr/bin/python2.4 || die "Failed to configure."
+ emake || die "Failed to compile."
+}
+
+src_install() {
+
+ cd ${S}
+
+ dodoc README.txt
+ dodoc Zope/doc/*.txt
+ for DIR in schema security skins style zcml zsync
+ do
+ docinto ${DIR}
+ dodoc Zope/doc/${DIR}/*
+ done
+
+ make install prefix=${D}${ZSERVDIR}
+
+ dosym ../../share/doc/${PF} ${ZSERVDIR}/doc
+
+ # copy the init script skeleton to zopeskel directory of our installation
+ cp ${FILESDIR}/zope.initd ${D}${ZSKELDIR}/zope.initd
+}
+
+pkg_postinst() {
+ # create the zope user and group for backward compatibility
+ enewgroup ${ZGNAME} 261
+ usermod -g ${ZGNAME} -c "Zope Admin User" -d /var/lib/zope -s /bin/bash ${ZUNAME} 2>&1 >/dev/null || \
+ enewuser ${ZUNAME} 261 /bin/bash /var/lib/zope ${ZGNAME} -c "Zope Admin User"
+
+ einfo "This release can create a default instance using the command: "
+ einfo " emerge --config =${PF}"
+ einfo "Instance (${P}) will be created in ${ZINSTDIR} as its home."
+ einfo "System uid/gid for instance will be: ${ZUNAME}:${ZGNAME}"
+}
+
+pkg_prerm() {
+
+ find ${ZSERVDIR}/lib/python -name \*.py[co] -exec rm -f {} \;
+}
+
+pkg_postrm() {
+
+ rmdir /usr/$(get_libdir)/${ZSERVDIR} 2>/dev/null
+ ewarn "Instances created for this package are NOT automaticaly deleted!"
+ ewarn "Inspect these locations and manually remove them (if needed):"
+ ewarn " /etc/init.d/${P}"
+ ewarn " ${ZINSTDIR}"
+}
+
+pkg_config() {
+
+ if [ -f /etc/init.d/${P} -o -d ${ZINSTDIR} ]
+ then
+ ewarn "Default instance already exists, aborting.."
+ ewarn "Please delete first /etc/init.d/${P} and ${ZINSTDIR}"
+ die "Failed to create default instance."
+ fi
+
+ mkdir -p ${ZINSTDIR}
+ einfo "Instance ${P} creation, calling mkzopeinstance.."
+ ${ZSERVDIR}/bin/mkzopeinstance --non-interactive -d ${ZINSTDIR} -u admin:admin
+
+ # bug in zope
+ einfo "Patching ${ZINSTDIR}/etc/zdaemon.conf"
+ sed -i -e 's|daemon on|daemon on\n\n # socket has to be defined inside of instance\n socket-name $INSTANCE/var/zdsock|' ${ZINSTDIR}/etc/zdaemon.conf
+
+ # remove unnecessary zope.initd
+ rm -f ${ZINSTDIR}/zope.initd
+
+ # log symlink
+ rm -rf ${ZINSTDIR}/log
+ mkdir -p /var/log/zope/${PN}
+ ln -s /var/log/zope/${PN} ${ZINSTDIR}/log
+
+ # permissions changes
+ chmod go-rwx -R ${ZINSTDIR}
+ chown ${ZUNAME}:${ZGNAME} -R ${ZINSTDIR} /var/log/zope/${PN}
+
+ cp ${ZSKELDIR}/zope.initd /etc/init.d/${P}
+ chmod 755 /etc/init.d/${P}
+ sed -i -e "s|INSTANCE_HOME|${ZINSTDIR}|" /etc/init.d/${P}
+ sed -i -e "s|zopectl|zopectl -u ${ZUNAME}|" /etc/init.d/${P}
+
+ einfo "Default instance created at ${ZINSTDIR}"
+ einfo "Created default zope user 'admin' with password 'admin'."
+ einfo "System uid/gid for instance is: ${ZUNAME}:${ZGNAME}."
+ einfo "To start instance (default ports 8080,8021) use: /etc/init.d/${P} start"
+ einfo "To start instance on every restart use: rc-update -a ${P} default"
+}