summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2010-07-26 05:41:58 +0000
committerTorsten Veller <tove@gentoo.org>2010-07-26 05:41:58 +0000
commit6c38dc0db05f219a73f842b980e8f606d977f9df (patch)
tree0ca921690e50362d48fd6245fd6549caaa20920c /perl-core/Compress-Raw-Zlib
parentVersion bump (diff)
downloadgentoo-2-6c38dc0db05f219a73f842b980e8f606d977f9df.tar.gz
gentoo-2-6c38dc0db05f219a73f842b980e8f606d977f9df.tar.bz2
gentoo-2-6c38dc0db05f219a73f842b980e8f606d977f9df.zip
Version bump
(Portage version: 2.2_rc67_p240/cvs/Linux x86_64)
Diffstat (limited to 'perl-core/Compress-Raw-Zlib')
-rw-r--r--perl-core/Compress-Raw-Zlib/ChangeLog8
-rw-r--r--perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.030.ebuild34
2 files changed, 41 insertions, 1 deletions
diff --git a/perl-core/Compress-Raw-Zlib/ChangeLog b/perl-core/Compress-Raw-Zlib/ChangeLog
index c25e41c4dafc..c54333405f43 100644
--- a/perl-core/Compress-Raw-Zlib/ChangeLog
+++ b/perl-core/Compress-Raw-Zlib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for perl-core/Compress-Raw-Zlib
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/perl-core/Compress-Raw-Zlib/ChangeLog,v 1.28 2010/04/25 06:44:06 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Compress-Raw-Zlib/ChangeLog,v 1.29 2010/07/26 05:41:58 tove Exp $
+
+*Compress-Raw-Zlib-2.030 (26 Jul 2010)
+
+ 26 Jul 2010; Torsten Veller <tove@gentoo.org>
+ +Compress-Raw-Zlib-2.030.ebuild:
+ Version bump
*Compress-Raw-Zlib-2.027 (25 Apr 2010)
diff --git a/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.030.ebuild b/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.030.ebuild
new file mode 100644
index 000000000000..9eb47ba3259a
--- /dev/null
+++ b/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.030.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.030.ebuild,v 1.1 2010/07/26 05:41:58 tove Exp $
+
+EAPI=2
+
+MODULE_AUTHOR=PMQS
+inherit multilib perl-module
+
+DESCRIPTION="Low-Level Interface to zlib compression library"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=sys-libs/zlib-1.2.5"
+DEPEND="${RDEPEND}"
+# test? ( dev-perl/Test-Pod )"
+
+SRC_TEST="do"
+
+src_prepare() {
+ use prefix || EPREFIX=
+ perl-module_src_prepare
+
+ cat <<-EOF > "${S}/config.in"
+ BUILD_ZLIB = False
+ INCLUDE = ${EPREFIX}/usr/include
+ LIB = ${EPREFIX}/usr/$(get_libdir)
+
+ OLD_ZLIB = False
+ GZIP_OS_CODE = AUTO_DETECT
+ EOF
+}