summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2009-05-21 15:11:54 +0000
committerJim Ramsay <lack@gentoo.org>2009-05-21 15:11:54 +0000
commitb76f0676ee2740ff3b6c4269724310a54caccbe0 (patch)
tree2f3a246b7f8601798531158a591b34057a830c14 /rox-base/zeroinstall-injector
parentold (diff)
downloadgentoo-2-b76f0676ee2740ff3b6c4269724310a54caccbe0.tar.gz
gentoo-2-b76f0676ee2740ff3b6c4269724310a54caccbe0.tar.bz2
gentoo-2-b76f0676ee2740ff3b6c4269724310a54caccbe0.zip
Version 0.40 is released. Also updates 0distutils script to handle changes in rox-base/rox-2.9
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'rox-base/zeroinstall-injector')
-rw-r--r--rox-base/zeroinstall-injector/ChangeLog9
-rwxr-xr-xrox-base/zeroinstall-injector/files/0distutils-r1116
-rw-r--r--rox-base/zeroinstall-injector/zeroinstall-injector-0.40.ebuild49
3 files changed, 173 insertions, 1 deletions
diff --git a/rox-base/zeroinstall-injector/ChangeLog b/rox-base/zeroinstall-injector/ChangeLog
index 922b60bb7ca2..411a5b91d64f 100644
--- a/rox-base/zeroinstall-injector/ChangeLog
+++ b/rox-base/zeroinstall-injector/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for rox-base/zeroinstall-injector
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/rox-base/zeroinstall-injector/ChangeLog,v 1.11 2009/04/09 13:34:38 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/rox-base/zeroinstall-injector/ChangeLog,v 1.12 2009/05/21 15:11:54 lack Exp $
+
+*zeroinstall-injector-0.40 (21 May 2009)
+
+ 21 May 2009; Jim Ramsay <lack@gentoo.org> +files/0distutils-r1,
+ +zeroinstall-injector-0.40.ebuild:
+ Version 0.40 is released. Also updates 0distutils script to handle changes
+ in rox-base/rox-2.9
09 Apr 2009; Jim Ramsay <lack@gentoo.org>
zeroinstall-injector-0.33.ebuild:
diff --git a/rox-base/zeroinstall-injector/files/0distutils-r1 b/rox-base/zeroinstall-injector/files/0distutils-r1
new file mode 100755
index 000000000000..2d40282e80b5
--- /dev/null
+++ b/rox-base/zeroinstall-injector/files/0distutils-r1
@@ -0,0 +1,116 @@
+#!/usr/bin/python
+
+import os
+from xml.dom import minidom
+import xml.dom
+
+ns0compile = "http://zero-install.sourceforge.net/2006/namespaces/0compile"
+
+def escape(uri):
+ import zeroinstall.injector.model
+ return zeroinstall.injector.model._pretty_escape(uri)
+
+def cacheescape(uri):
+ import zeroinstall.injector.model
+ return zeroinstall.injector.model.escape(uri)
+
+def strip(node):
+ torm = []
+ for c in node.childNodes:
+ if c.nodeType == xml.dom.Node.TEXT_NODE and \
+ c.nodeValue.strip() == "":
+ torm.append(c)
+ elif c.hasChildNodes():
+ strip(c)
+ for c in torm:
+ node.removeChild(c)
+ c.unlink()
+
+class LocalFeed(object):
+ def __init__(self, xmlfile):
+ self.xml = minidom.parse(xmlfile)
+ if self.xml.documentElement.nodeName != "interface":
+ raise TypeError("Not an interface")
+ strip(self.xml.documentElement)
+
+ def getUri(self):
+ for element in self.xml.documentElement.getElementsByTagName("feed-for"):
+ if element.hasAttribute("interface"):
+ return element.getAttribute("interface")
+ return None
+
+ def edit(self, id=".", main="AppRun", stability="packaged"):
+ for attribute in ("main", "uri"):
+ if self.xml.documentElement.hasAttribute(attribute):
+ self.xml.documentElement.removeAttribute(attribute)
+ for group in self.xml.documentElement.getElementsByTagName("group"):
+ group.setAttribute("main", "AppRun")
+ if group.hasAttribute("arch") and group.getAttribute("arch") == "*-src":
+ uname = os.uname()
+ group.setAttribute("arch", "%s-%s" % (uname[0], uname[-1]))
+ attr0comp = []
+ for aidx in range(0, group.attributes.length):
+ attr = group.attributes.item(aidx)
+ if attr.namespaceURI == ns0compile:
+ attr0comp.append(attr)
+ for attr in attr0comp:
+ group.removeAttributeNode(attr)
+ reqlist = group.getElementsByTagName("requires")
+ for req in reqlist:
+ group.removeChild(req)
+ req.unlink()
+ for imp in group.getElementsByTagName("implementation"):
+ imp.setAttribute("stability",stability)
+ imp.setAttribute("id",id)
+
+ def dump(self):
+ print self.xml.toprettyxml()
+
+def main(xmlfile, mode="edit"):
+ try:
+ feed = LocalFeed(xmlfile)
+ if mode == "uri":
+ print feed.getUri()
+ elif mode == "escape":
+ print escape(feed.getUri())
+ elif mode == "cache":
+ print cacheescape(feed.getUri())
+ else:
+ feed.edit()
+ feed.dump()
+ except Exception, e:
+ import sys
+ print "Fatal:", e
+ sys.exit(2)
+
+def usage(program):
+ import os.path
+ progname = os.path.basename(program)
+ print "Usage:", progname, "[-u|-e] <xmlfile>"
+ print "Options:"
+ print "\t-u --uri: Finds the URI from the feed"
+ print "\t-e --escape: Escapes the URI from the feed"
+
+if __name__ == "__main__":
+ from optparse import OptionParser
+ import sys
+ parser = OptionParser(usage="usage: %prog [options] feed.xml",
+ description="By default, edits the given feed and prints the result on stdout.")
+ parser.add_option("-e", "--escape", action="store_const",
+ const="escape", dest="mode",
+ help="Return the cache-escaped URI from the feed on stdout.")
+ parser.add_option("-c", "--cache", action="store_const",
+ const="cache", dest="mode",
+ help="Return the file-escaped URI from the feed on stdout.")
+ parser.add_option("-u", "--uri", action="store_const",
+ const="uri", dest="mode",
+ help="Return the original URI from the feed on stdout.")
+ (options, args) = parser.parse_args()
+ if len(args) == 0:
+ parser.print_help()
+ else:
+ if len(args) > 1:
+ parser.error("requires exactly one .xml file")
+ main(args[0], options.mode)
+
+# vim: nosta noet sw=4 ts=4
diff --git a/rox-base/zeroinstall-injector/zeroinstall-injector-0.40.ebuild b/rox-base/zeroinstall-injector/zeroinstall-injector-0.40.ebuild
new file mode 100644
index 000000000000..90c886520bf4
--- /dev/null
+++ b/rox-base/zeroinstall-injector/zeroinstall-injector-0.40.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/rox-base/zeroinstall-injector/zeroinstall-injector-0.40.ebuild,v 1.1 2009/05/21 15:11:54 lack Exp $
+
+EAPI=2
+inherit distutils
+
+DESCRIPTION="Zeroinstall Injector allows regular users to install software themselves"
+HOMEPAGE="http://0install.net/"
+SRC_URI="mirror://sourceforge/zero-install/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="!<=rox-base/rox-session-0.30"
+RDEPEND=">=dev-python/pygtk-2.0
+ app-crypt/gnupg"
+
+PYTHON_MODNAME="zeroinstall"
+
+src_prepare() {
+ # Change manpage install path (Bug 207495)
+ sed -i 's:man/man1:share/man/man1:' setup.py
+}
+
+src_install() {
+ distutils_src_install
+
+ exeinto "/usr/sbin/"
+ newexe "${FILESDIR}/0distutils-r1" 0distutils
+
+ local BASE_XDG_CONFIG="/etc/xdg/0install.net"
+ local BASE_XDG_DATA="/usr/share/0install.net"
+
+ insinto "${BASE_XDG_CONFIG}/injector"
+ newins "${FILESDIR}/global.cfg" global
+
+ dodir "${BASE_XDG_DATA}/native_feeds"
+}
+
+pkg_postinst() {
+ python_version
+ # Note: Must use '-f' because python_mod_optimize sometimes leaves old files
+ # around.
+ python_mod_optimize -f \
+ /usr/$(get_libdir)/python${PYVER}/site-packages/zeroinstall
+}