summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Kuleshov <svyatogor@gentoo.org>2005-10-08 18:22:01 +0000
committerSergey Kuleshov <svyatogor@gentoo.org>2005-10-08 18:22:01 +0000
commit96c8f576a038c4c71188f17dbf4702a5e4e0a1b8 (patch)
tree2d6a0275f67478a6a8c8162f3b685344e7d2f770 /rox-extra/diff/diff-2.1.2.ebuild
parentnagios-core-1.2-r2 and -r3 were already obsolete (diff)
downloadgentoo-2-96c8f576a038c4c71188f17dbf4702a5e4e0a1b8.tar.gz
gentoo-2-96c8f576a038c4c71188f17dbf4702a5e4e0a1b8.tar.bz2
gentoo-2-96c8f576a038c4c71188f17dbf4702a5e4e0a1b8.zip
new application for rox.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'rox-extra/diff/diff-2.1.2.ebuild')
-rw-r--r--rox-extra/diff/diff-2.1.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/rox-extra/diff/diff-2.1.2.ebuild b/rox-extra/diff/diff-2.1.2.ebuild
new file mode 100644
index 000000000000..979053bbe03b
--- /dev/null
+++ b/rox-extra/diff/diff-2.1.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/rox-extra/diff/diff-2.1.2.ebuild,v 1.1 2005/10/08 18:22:01 svyatogor Exp $
+
+inherit eutils rox
+
+MY_PN="Diff"
+PATCH_FN="diff-2.1.2_unified-fix.patch"
+DESCRIPTION="This is a helper program for ROX-Filer. It provides images for video files. By Stephen Watson"
+HOMEPAGE="http://www.kerofin.demon.co.uk/rox/diff.html"
+SRC_URI="http://www.kerofin.demon.co.uk/rox/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86"
+
+ROX_CLIB=2.1.0
+SET_PERM=true
+
+APPNAME=${MY_PN}
+S=${WORKDIR}
+
+# patch to make unified diffs work. Thanks to Stephen Watson, author
+src_unpack() {
+ unpack ${A}
+ cd ${S}/${APPNAME}/src
+ epatch ${FILESDIR}/${PATCH_FN}
+}