summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-11-04 01:39:55 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-11-04 01:39:55 +0000
commitdd906eb5a420f6102a921490d6d85485e6321947 (patch)
tree0865272c079b61a8a30eeafa4211005078678417 /sci-astronomy/ast
parentVersion bump (diff)
downloadgentoo-2-dd906eb5a420f6102a921490d6d85485e6321947.tar.gz
gentoo-2-dd906eb5a420f6102a921490d6d85485e6321947.tar.bz2
gentoo-2-dd906eb5a420f6102a921490d6d85485e6321947.zip
Version bump
(Portage version: 2.2_rc48/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy/ast')
-rw-r--r--sci-astronomy/ast/ChangeLog7
-rw-r--r--sci-astronomy/ast/ast-5.2.0.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/sci-astronomy/ast/ChangeLog b/sci-astronomy/ast/ChangeLog
index 8e1582d815b1..dfb005f0a9d6 100644
--- a/sci-astronomy/ast/ChangeLog
+++ b/sci-astronomy/ast/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-astronomy/ast
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/ast/ChangeLog,v 1.9 2009/09/16 03:33:14 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/ast/ChangeLog,v 1.10 2009/11/04 01:39:55 bicatali Exp $
+
+*ast-5.2.0 (04 Nov 2009)
+
+ 04 Nov 2009; Sébastien Fabbro <bicatali@gentoo.org> +ast-5.2.0.ebuild:
+ Version bump
16 Sep 2009; Markus Dittrich <markusle@gentoo.org>
files/ast-5.1.0-makefile.in.patch:
diff --git a/sci-astronomy/ast/ast-5.2.0.ebuild b/sci-astronomy/ast/ast-5.2.0.ebuild
new file mode 100644
index 000000000000..78eaa01aed5b
--- /dev/null
+++ b/sci-astronomy/ast/ast-5.2.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/ast/ast-5.2.0.ebuild,v 1.1 2009/11/04 01:39:55 bicatali Exp $
+
+EAPI=2
+inherit eutils versionator
+
+MYP="${PN}-$(replace_version_separator 2 '-')"
+
+DESCRIPTION="Library for handling World Coordinate Systems in astronomy"
+HOMEPAGE="http://www.starlink.ac.uk/~dsb/ast/ast.html"
+SRC_URI="http://www.starlink.ac.uk/~dsb/${PN}/${MYP}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+RDEPEND="sci-libs/pgplot"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MYP}"
+
+src_prepare() {
+ # dont patch/sed Makefile.am because it requires special upstream automake
+ # not shipped
+ epatch "${FILESDIR}"/${PN}-5.1.0-makefile.in.patch
+}
+
+#src_configure() {
+# PATH=".:${PATH}" econf
+#}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ rm -rf "${D}"usr/{docs,help,manifests,news,share} || die
+ dodoc ast.news fac_1521_err
+ if use doc; then
+ dodoc *.ps || die "doc install failed"
+ fi
+}