summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-06-06 20:52:49 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-06-06 20:52:49 +0000
commit8a34e2ca21ab8614bb78d32e36500b9dbfd3ff8e (patch)
treed3094e7131a1223b70fd439483b62e12ba85aeb3 /sci-astronomy/predict
parentDo not use relative paths in patch, bug 457548 (diff)
downloadgentoo-2-8a34e2ca21ab8614bb78d32e36500b9dbfd3ff8e.tar.gz
gentoo-2-8a34e2ca21ab8614bb78d32e36500b9dbfd3ff8e.tar.bz2
gentoo-2-8a34e2ca21ab8614bb78d32e36500b9dbfd3ff8e.zip
fix AM_CONFIG_HEADER issue (bug #469704); fix another buffer warning; tidy epatch work
(Portage version: 2.1.11.62/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sci-astronomy/predict')
-rw-r--r--sci-astronomy/predict/ChangeLog8
-rw-r--r--sci-astronomy/predict/predict-2.2.3-r1.ebuild15
2 files changed, 14 insertions, 9 deletions
diff --git a/sci-astronomy/predict/ChangeLog b/sci-astronomy/predict/ChangeLog
index 0052e9f38d1b..7e060f90b904 100644
--- a/sci-astronomy/predict/ChangeLog
+++ b/sci-astronomy/predict/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-astronomy/predict
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/predict/ChangeLog,v 1.16 2012/08/06 20:23:47 bicatali Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/predict/ChangeLog,v 1.17 2013/06/06 20:52:49 mr_bones_ Exp $
+
+ 06 Jun 2013; Michael Sterrett <mr_bones_@gentoo.org> predict-2.2.3-r1.ebuild:
+ fix AM_CONFIG_HEADER issue (bug #469704); fix another buffer warning; tidy
+ epatch work
*predict-2.2.3-r1 (06 Aug 2012)
diff --git a/sci-astronomy/predict/predict-2.2.3-r1.ebuild b/sci-astronomy/predict/predict-2.2.3-r1.ebuild
index 521896ff9a6c..16d9e8038eb7 100644
--- a/sci-astronomy/predict/predict-2.2.3-r1.ebuild
+++ b/sci-astronomy/predict/predict-2.2.3-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/predict/predict-2.2.3-r1.ebuild,v 1.2 2012/08/07 04:00:29 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/predict/predict-2.2.3-r1.ebuild,v 1.3 2013/06/06 20:52:49 mr_bones_ Exp $
EAPI=4
@@ -31,19 +31,20 @@ src_prepare() {
debian/patches/140*.diff || die
sed -i -e 's:\(a\|b\)/:predict-2.2.3/:g' \
debian/patches/180*.diff || die
- local p
- for p in $(cat debian/patches/series); do
- epatch -p1 debian/patches/${p}
- done
+ EPATCH_SOURCE=debian/patches epatch -p1 $(cat debian/patches/series)
# fix some further array out of bounds errors
sed -i -e "s/satname\[ 26/satname\[ 25/g" \
clients/gsat-1.1.0/src/db.c || die
sed -i -e "s/satname\[ 26/satname\[ 25/g" \
clients/gsat-1.1.0/src/comms.c || die
+ sed -i -e "s/output\[20\];/output[21];/" \
+ utils/moontracker/moontracker.c || die
# fix underlinking
sed -i -e '/AC_OUTPUT/i \
AC_CHECK_LIB(m,cos) \
-AC_CHECK_LIB(dl,dlclose)' clients/gsat-1.1.0/configure.in || die
+AC_CHECK_LIB(dl,dlclose)' \
+ -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' \
+ clients/gsat-1.1.0/configure.in || die
sed -i \
-e 's/gcc/$(CC) $(CFLAGS) $(LDFLAGS)/g' \
-e 's/-o/-lm -o/g' \