summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-09-15 13:02:00 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-09-15 13:02:00 +0000
commitdf96dc42c1e39d09ee7f0c7de4f775cfa95ff2b2 (patch)
tree05a17ec35fccc776cce663f7484ef509554f643a /sci-astronomy/xfitsview/xfitsview-2.2-r1.ebuild
parentRevision bump directly to stable to apply previous changes as talked with lei... (diff)
downloadgentoo-2-df96dc42c1e39d09ee7f0c7de4f775cfa95ff2b2.tar.gz
gentoo-2-df96dc42c1e39d09ee7f0c7de4f775cfa95ff2b2.tar.bz2
gentoo-2-df96dc42c1e39d09ee7f0c7de4f775cfa95ff2b2.zip
Fix parallel build, respect LDFLAGS, fix build with make 3.82 wrt bug 337479. Thanks to Diego for the report. Drop old.
(Portage version: 2.2_rc77/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy/xfitsview/xfitsview-2.2-r1.ebuild')
-rw-r--r--sci-astronomy/xfitsview/xfitsview-2.2-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-astronomy/xfitsview/xfitsview-2.2-r1.ebuild b/sci-astronomy/xfitsview/xfitsview-2.2-r1.ebuild
new file mode 100644
index 000000000000..f38f565ad376
--- /dev/null
+++ b/sci-astronomy/xfitsview/xfitsview-2.2-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/xfitsview/xfitsview-2.2-r1.ebuild,v 1.1 2010/09/15 13:01:59 xarthisius Exp $
+
+EAPI=2
+inherit eutils
+
+MY_PN=XFITSview
+MY_P=${MY_PN}${PV}
+
+DESCRIPTION="Viewer for astronomical images in FITS format"
+HOMEPAGE="http://www.nrao.edu/software/fitsview/"
+SRC_URI="ftp://ftp.cv.nrao.edu/fits/os-support/unix/xfitsview/${PN}${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/openmotif"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_PN}
+
+src_prepare() {
+ find "${S}" -name "*old.c" -delete || die
+ epatch "${FILESDIR}"/${P}-build_system.patch
+}
+
+src_install() {
+ dobin XFITSview || die
+ dodoc README changes notes.text || die
+}