summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2011-12-28 12:21:18 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2011-12-28 12:21:18 +0000
commit722a70e34c55800f0b1b45b2c75a08a9b48c9014 (patch)
tree130216dc6bba56dc4932fb01dbff0cd65652b75f /sci-astronomy
parentVersion bump, drop old (diff)
downloadgentoo-2-722a70e34c55800f0b1b45b2c75a08a9b48c9014.tar.gz
gentoo-2-722a70e34c55800f0b1b45b2c75a08a9b48c9014.tar.bz2
gentoo-2-722a70e34c55800f0b1b45b2c75a08a9b48c9014.zip
Fix deps, use fdo-mime for desktop update
(Portage version: 2.2.0_alpha83/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/galaxy/ChangeLog5
-rw-r--r--sci-astronomy/galaxy/galaxy-2.0.ebuild17
2 files changed, 17 insertions, 5 deletions
diff --git a/sci-astronomy/galaxy/ChangeLog b/sci-astronomy/galaxy/ChangeLog
index b4b81cbaa733..b788c444a67f 100644
--- a/sci-astronomy/galaxy/ChangeLog
+++ b/sci-astronomy/galaxy/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-astronomy/galaxy
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/galaxy/ChangeLog,v 1.4 2011/12/28 12:14:11 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/galaxy/ChangeLog,v 1.5 2011/12/28 12:21:18 xarthisius Exp $
+
+ 28 Dec 2011; Kacper Kowalik <xarthisius@gentoo.org> galaxy-2.0.ebuild:
+ Fix deps, use fdo-mime for desktop update
*galaxy-2.0 (28 Dec 2011)
diff --git a/sci-astronomy/galaxy/galaxy-2.0.ebuild b/sci-astronomy/galaxy/galaxy-2.0.ebuild
index 4f5057028064..3ded5d608e74 100644
--- a/sci-astronomy/galaxy/galaxy-2.0.ebuild
+++ b/sci-astronomy/galaxy/galaxy-2.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/galaxy/galaxy-2.0.ebuild,v 1.1 2011/12/28 12:14:11 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/galaxy/galaxy-2.0.ebuild,v 1.2 2011/12/28 12:21:18 xarthisius Exp $
EAPI=4
-inherit toolchain-funcs
+inherit fdo-mime toolchain-funcs
DESCRIPTION="stellar simulation program"
HOMEPAGE="http://kornelix.squarespace.com/galaxy/"
@@ -15,9 +15,9 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="x11-libs/gtk+:2
+DEPEND="x11-libs/gtk+:2"
+RDEPEND="${DEPEND}
x11-misc/xdg-utils"
-RDEPEND="${DEPEND}"
pkg_setup() {
tc-export CXX
@@ -25,5 +25,14 @@ pkg_setup() {
src_prepare() {
sed -e '/DOCDIR/ s/PROGRAM)/&-\$(VERSION)/g' \
+ -e '/xdg-desktop-menu/d' \
-i Makefile || die
}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}