summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2014-05-28 16:15:04 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2014-05-28 16:15:04 +0000
commit75e58d6ec46f4380e8b607764a42ecc06661f593 (patch)
tree85891dd6cb14f8962c1bb148b04be7e95e3fd92a /sci-astronomy
parentVersion bump (diff)
downloadgentoo-2-75e58d6ec46f4380e8b607764a42ecc06661f593.tar.gz
gentoo-2-75e58d6ec46f4380e8b607764a42ecc06661f593.tar.bz2
gentoo-2-75e58d6ec46f4380e8b607764a42ecc06661f593.zip
Version bump
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/wcslib/ChangeLog7
-rw-r--r--sci-astronomy/wcslib/wcslib-4.23.ebuild74
2 files changed, 80 insertions, 1 deletions
diff --git a/sci-astronomy/wcslib/ChangeLog b/sci-astronomy/wcslib/ChangeLog
index ee74d9154cae..f5db35d46793 100644
--- a/sci-astronomy/wcslib/ChangeLog
+++ b/sci-astronomy/wcslib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-astronomy/wcslib
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/ChangeLog,v 1.40 2014/05/06 15:55:36 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/ChangeLog,v 1.41 2014/05/28 16:15:04 bicatali Exp $
+
+*wcslib-4.23 (28 May 2014)
+
+ 28 May 2014; Sébastien Fabbro <bicatali@gentoo.org> +wcslib-4.23.ebuild:
+ Version bump
*wcslib-4.22 (06 May 2014)
diff --git a/sci-astronomy/wcslib/wcslib-4.23.ebuild b/sci-astronomy/wcslib/wcslib-4.23.ebuild
new file mode 100644
index 000000000000..2fbf192cdd73
--- /dev/null
+++ b/sci-astronomy/wcslib/wcslib-4.23.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/wcslib-4.23.ebuild,v 1.1 2014/05/28 16:15:04 bicatali Exp $
+
+EAPI=5
+
+FORTRAN_NEEDED=fortran
+
+inherit eutils fortran-2 multilib
+
+DESCRIPTION="Astronomical World Coordinate System transformations library"
+HOMEPAGE="http://www.atnf.csiro.au/people/mcalabre/WCS/"
+SRC_URI="ftp://ftp.atnf.csiro.au/pub/software/${PN}/${P}.tar.bz2"
+
+SLOT="0/4"
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc fortran fits pgplot static-libs"
+
+RDEPEND="
+ fits? ( sci-libs/cfitsio:0= )
+ pgplot? ( sci-libs/pgplot:0= )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i -e 's/COPYING\*//' GNUmakefile || die
+}
+
+src_configure() {
+ local myconf=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable static-libs static)
+ $(use_enable fortran)
+ )
+ # hacks because cfitsio and pgplot directories are hard-coded
+ if use fits; then
+ myconf+=(
+ --with-cfitsioinc="${EPREFIX}/usr/include"
+ --with-cfitsiolib="${EPREFIX}/usr/$(get_libdir)"
+ )
+ else
+ myconf+=( --without-cfitsio )
+ fi
+ if use pgplot; then
+ myconf+=(
+ --with-pgplotinc="${EPREFIX}/usr/include"
+ --with-pgplotlib="${EPREFIX}/usr/$(get_libdir)"
+ )
+ else
+ myconf+=( --without-pgplot )
+ fi
+ econf ${myconf[@]}
+}
+
+src_compile() {
+ # nasty makefile, debugging means probably full rewrite
+ emake -j1
+}
+
+src_test() {
+ emake -j1 check
+}
+
+src_install () {
+ default
+ # static libs are same as shared (compiled with PIC)
+ # so they are not compiled twice
+ use static-libs || rm "${ED}"/usr/$(get_libdir)/lib*.a
+ use doc || rm -r \
+ "${ED}"/usr/share/doc/${PF}/html \
+ "${ED}"/usr/share/doc/${PF}/*.pdf
+}