summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-09-06 16:34:35 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-09-06 16:34:35 +0000
commitbf2483d28520ae1eabf9f51d43333d121cc35128 (patch)
treea5cb2e3a4f8f60fecb6f25c0ea66a557fefe2478 /sci-astronomy
parentStable for HPPA (bug #433193). (diff)
downloadgentoo-2-bf2483d28520ae1eabf9f51d43333d121cc35128.tar.gz
gentoo-2-bf2483d28520ae1eabf9f51d43333d121cc35128.tar.bz2
gentoo-2-bf2483d28520ae1eabf9f51d43333d121cc35128.zip
Compile and install html documentation properly, thanks Peter Weilbacher, bug #434134
(Portage version: 2.2.01.20894-prefix/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/cpl/ChangeLog6
-rw-r--r--sci-astronomy/cpl/cpl-6.1.1.ebuild13
2 files changed, 15 insertions, 4 deletions
diff --git a/sci-astronomy/cpl/ChangeLog b/sci-astronomy/cpl/ChangeLog
index 957469d5927c..f919cc58e8b9 100644
--- a/sci-astronomy/cpl/ChangeLog
+++ b/sci-astronomy/cpl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-astronomy/cpl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/cpl/ChangeLog,v 1.10 2012/08/05 15:03:02 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/cpl/ChangeLog,v 1.11 2012/09/06 16:34:35 bicatali Exp $
+
+ 06 Sep 2012; Sébastien Fabbro <bicatali@gentoo.org> cpl-6.1.1.ebuild:
+ Compile and install html documentation properly, thanks Peter Weilbacher, bug
+ #434134
05 Aug 2012; Sébastien Fabbro <bicatali@gentoo.org> -cpl-5.3.1.ebuild,
cpl-6.1.1.ebuild:
diff --git a/sci-astronomy/cpl/cpl-6.1.1.ebuild b/sci-astronomy/cpl/cpl-6.1.1.ebuild
index 39412d329636..fa1bbf82d358 100644
--- a/sci-astronomy/cpl/cpl-6.1.1.ebuild
+++ b/sci-astronomy/cpl/cpl-6.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/cpl/cpl-6.1.1.ebuild,v 1.3 2012/08/05 15:03:02 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/cpl/cpl-6.1.1.ebuild,v 1.4 2012/09/06 16:34:35 bicatali Exp $
EAPI=4
@@ -19,11 +19,13 @@ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc gasgano static-libs threads"
-RDEPEND=">=sci-libs/cfitsio-3.270
+RDEPEND="
>=sci-astronomy/wcslib-4.8.4
+ >=sci-libs/cfitsio-3.270
>=sci-libs/fftw-3.1.2
gasgano? ( sci-astronomy/gasgano )"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
PATCHES=(
"${FILESDIR}"/${P}-check-shared-libs.patch
@@ -41,6 +43,7 @@ src_configure() {
--htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
--disable-ltdl-install
--without-included-ltdl
+ $(use_enable doc maintainer-mode)
$(use_enable threads)
)
if use gasgano; then
@@ -56,6 +59,10 @@ src_configure() {
autotools-utils_src_configure
}
+src_compile() {
+ autotools-utils_src_compile all $(use doc && echo html)
+}
+
src_install() {
autotools-utils_src_install all $(use doc && echo install-html)
}