summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Gardner <je_fro@gentoo.org>2012-12-31 18:16:06 +0000
committerJeffrey Gardner <je_fro@gentoo.org>2012-12-31 18:16:06 +0000
commit84022df88420be201a1d605253ce6b0e7eecd538 (patch)
treea50934a2c5203f1c3a95a59374b3d0837262245e /sci-biology/ApE/ApE-2.0.7-r1.ebuild
parentAdd ~ia64, wrt bug #387959 (diff)
downloadgentoo-2-84022df88420be201a1d605253ce6b0e7eecd538.tar.gz
gentoo-2-84022df88420be201a1d605253ce6b0e7eecd538.tar.bz2
gentoo-2-84022df88420be201a1d605253ce6b0e7eecd538.zip
Forward command line arguments to ApE startup script, thanks to Markus Meier in bug #375919
(Portage version: 2.1.11.38/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sci-biology/ApE/ApE-2.0.7-r1.ebuild')
-rw-r--r--sci-biology/ApE/ApE-2.0.7-r1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/sci-biology/ApE/ApE-2.0.7-r1.ebuild b/sci-biology/ApE/ApE-2.0.7-r1.ebuild
new file mode 100644
index 000000000000..e2ac6f6477f9
--- /dev/null
+++ b/sci-biology/ApE/ApE-2.0.7-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/ApE/ApE-2.0.7-r1.ebuild,v 1.1 2012/12/31 18:16:06 je_fro Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="ApE - A Plasmid Editor"
+HOMEPAGE="http://www.biology.utah.edu/jorgensen/wayned/ape/"
+SRC_URI="http://www.biology.utah.edu/jorgensen/wayned/ape/Download/Linux/ApE_linux_current.zip -> ${P}.zip"
+
+LICENSE="ApE"
+RESTRICT="mirror"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND="dev-lang/tcl
+ dev-lang/tk"
+
+src_compile() {
+ echo
+ einfo "Nothing to compile."
+ echo
+}
+
+src_install() {
+
+cat >> "${T}/ApE" << "EOF"
+#!/bin/bash
+cmdArgs=""
+
+# AppMain.tcl searches files relative to the directory where it resides.
+# Add absolute path to file here, if necessary.
+for rfpath in "$@"; do
+ afpath="$PWD/${rfpath}"
+ if test -r "${afpath}"; then
+ cmdArgs="${cmdArgs} \"${afpath}\"";
+else
+ cmdArgs="${cmdArgs} \"${rfpath}\"";
+fi
+done
+
+eval exec tclsh "\"/usr/share/ApE-2.0.7/AppMain.tcl\"" "${cmdArgs}"
+EOF
+
+exeinto /usr/bin
+doexe "${T}/ApE"
+insinto "/usr/share/${P}"
+doins -r "${WORKDIR}"/ApE\ Linux/*
+make_desktop_entry ${PN} \
+ ApE \
+ "/usr/share/${P}/Accessory Files/Icons and images/monkey_icon.gif" \
+ "Application;Graphics;Science"
+}