summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-03-20 15:39:09 +0000
committerJustin Lecher <jlec@gentoo.org>2015-03-20 15:39:09 +0000
commita1c2fe7b8735fe493f2169912a64c2b0c788d8e2 (patch)
treeb4e4de6293419955ed957aa7c08d1d90d9069edc /sci-biology/ApE/ApE-2.0.7-r1.ebuild
parentAdd ruby22. (diff)
downloadgentoo-2-a1c2fe7b8735fe493f2169912a64c2b0c788d8e2.tar.gz
gentoo-2-a1c2fe7b8735fe493f2169912a64c2b0c788d8e2.tar.bz2
gentoo-2-a1c2fe7b8735fe493f2169912a64c2b0c788d8e2.zip
Fix tcl/tk slotting;drop old; Bump EAPI
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-biology/ApE/ApE-2.0.7-r1.ebuild')
-rw-r--r--sci-biology/ApE/ApE-2.0.7-r1.ebuild74
1 files changed, 36 insertions, 38 deletions
diff --git a/sci-biology/ApE/ApE-2.0.7-r1.ebuild b/sci-biology/ApE/ApE-2.0.7-r1.ebuild
index e2ac6f6477f9..45922e13f202 100644
--- a/sci-biology/ApE/ApE-2.0.7-r1.ebuild
+++ b/sci-biology/ApE/ApE-2.0.7-r1.ebuild
@@ -1,56 +1,54 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/ApE/ApE-2.0.7-r1.ebuild,v 1.1 2012/12/31 18:16:06 je_fro Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/ApE/ApE-2.0.7-r1.ebuild,v 1.2 2015/03/20 15:39:09 jlec Exp $
+
+EAPI=5
-EAPI=2
inherit eutils
-DESCRIPTION="ApE - A Plasmid Editor"
+DESCRIPTION="A Plasmid Editor"
HOMEPAGE="http://www.biology.utah.edu/jorgensen/wayned/ape/"
SRC_URI="http://www.biology.utah.edu/jorgensen/wayned/ape/Download/Linux/ApE_linux_current.zip -> ${P}.zip"
LICENSE="ApE"
-RESTRICT="mirror"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND="app-arch/unzip"
-RDEPEND="dev-lang/tcl
- dev-lang/tk"
+RDEPEND="
+ dev-lang/tcl:0
+ dev-lang/tk:0"
-src_compile() {
- echo
- einfo "Nothing to compile."
- echo
-}
+RESTRICT="mirror"
-src_install() {
+S="${WORKDIR}/ApE Linux/"
+
+src_compile() { :; }
-cat >> "${T}/ApE" << "EOF"
-#!/bin/bash
-cmdArgs=""
-
-# AppMain.tcl searches files relative to the directory where it resides.
-# Add absolute path to file here, if necessary.
-for rfpath in "$@"; do
- afpath="$PWD/${rfpath}"
- if test -r "${afpath}"; then
- cmdArgs="${cmdArgs} \"${afpath}\"";
-else
- cmdArgs="${cmdArgs} \"${rfpath}\"";
-fi
-done
-
-eval exec tclsh "\"/usr/share/ApE-2.0.7/AppMain.tcl\"" "${cmdArgs}"
-EOF
-
-exeinto /usr/bin
-doexe "${T}/ApE"
-insinto "/usr/share/${P}"
-doins -r "${WORKDIR}"/ApE\ Linux/*
-make_desktop_entry ${PN} \
- ApE \
+src_install() {
+ cat >> "${T}/ApE" <<- "EOF"
+ #!/bin/bash
+ cmdArgs=""
+
+ # AppMain.tcl searches files relative to the directory where it resides.
+ # Add absolute path to file here, if necessary.
+ for rfpath in "$@"; do
+ afpath="$PWD/${rfpath}"
+ if test -r "${afpath}"; then
+ cmdArgs="${cmdArgs} \"${afpath}\"";
+ else
+ cmdArgs="${cmdArgs} \"${rfpath}\"";
+ fi
+ done
+
+ eval exec tclsh "\"/usr/share/ApE-2.0.7/AppMain.tcl\"" "${cmdArgs}"
+ EOF
+
+ dobin "${T}/ApE"
+ insinto "/usr/share/${P}"
+ doins -r "${WORKDIR}"/ApE\ Linux/*
+ make_desktop_entry ${PN} ${PN} \
"/usr/share/${P}/Accessory Files/Icons and images/monkey_icon.gif" \
- "Application;Graphics;Science"
+ "Science"
}