summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2011-09-24 21:48:12 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2011-09-24 21:48:12 +0000
commitdc2e1099f2be0cafccc0e754caea8e52c8320e0a (patch)
treef750b73bc595559c4c70f51f6a16e67a3fad32eb /sci-biology/abyss/abyss-1.3.0.ebuild
parentMarked stable based on arch testing by Elijah "Armageddon" El Lazkani, TomáÅ... (diff)
downloadgentoo-2-dc2e1099f2be0cafccc0e754caea8e52c8320e0a.tar.gz
gentoo-2-dc2e1099f2be0cafccc0e754caea8e52c8320e0a.tar.bz2
gentoo-2-dc2e1099f2be0cafccc0e754caea8e52c8320e0a.zip
Version bump
(Portage version: 2.2.0_alpha45/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/abyss/abyss-1.3.0.ebuild')
-rw-r--r--sci-biology/abyss/abyss-1.3.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-biology/abyss/abyss-1.3.0.ebuild b/sci-biology/abyss/abyss-1.3.0.ebuild
new file mode 100644
index 000000000000..dbb174c71163
--- /dev/null
+++ b/sci-biology/abyss/abyss-1.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/abyss/abyss-1.3.0.ebuild,v 1.1 2011/09/24 21:48:12 weaver Exp $
+
+EAPI="4"
+
+inherit autotools
+
+DESCRIPTION="Assembly By Short Sequences - a de novo, parallel, paired-end sequence assembler"
+HOMEPAGE="http://www.bcgsc.ca/platform/bioinfo/software/abyss/"
+SRC_URI="http://www.bcgsc.ca/downloads/abyss/${P}.tar.gz"
+
+LICENSE="abyss"
+SLOT="0"
+IUSE="+mpi openmp"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-cpp/sparsehash
+ mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+
+# todo: --enable-maxk=N configure option
+# todo: fix automagic mpi toggling
+
+src_prepare() {
+ sed -i -e "s/-Werror//" configure.ac || die #365195
+ sed -i -e "/dist_pkgdoc_DATA/d" Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable openmp)
+}