summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-08-14 16:47:20 +0000
committerJustin Lecher <jlec@gentoo.org>2012-08-14 16:47:20 +0000
commit47ce39c7d4d186e1146ac9914814c70242a28354 (patch)
tree7e414263a822b3a85393d4f2bd5494b87cccaeba /sci-biology/arb
parentRaise glib dependency per bug #420331 (diff)
downloadgentoo-2-47ce39c7d4d186e1146ac9914814c70242a28354.tar.gz
gentoo-2-47ce39c7d4d186e1146ac9914814c70242a28354.tar.bz2
gentoo-2-47ce39c7d4d186e1146ac9914814c70242a28354.zip
sci-biology/arb: Version BUmp; add fix for gcc-4.7, #431228
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/arb')
-rw-r--r--sci-biology/arb/ChangeLog8
-rw-r--r--sci-biology/arb/arb-5.2.ebuild11
-rw-r--r--sci-biology/arb/arb-5.3.ebuild78
-rw-r--r--sci-biology/arb/files/arb-5.2-gcc-47.patch15
4 files changed, 107 insertions, 5 deletions
diff --git a/sci-biology/arb/ChangeLog b/sci-biology/arb/ChangeLog
index ceeeaf8aecd3..068e4e8c8211 100644
--- a/sci-biology/arb/ChangeLog
+++ b/sci-biology/arb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/arb
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/arb/ChangeLog,v 1.7 2012/03/04 09:55:06 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/arb/ChangeLog,v 1.8 2012/08/14 16:47:19 jlec Exp $
+
+*arb-5.3 (14 Aug 2012)
+
+ 14 Aug 2012; Justin Lecher <jlec@gentoo.org> arb-5.2.ebuild,
+ +files/arb-5.2-gcc-47.patch, +arb-5.3.ebuild:
+ Version BUmp; add fix for gcc-4.7, #431228
04 Mar 2012; Justin Lecher <jlec@gentoo.org> arb-5.1-r1.ebuild,
arb-5.2.ebuild:
diff --git a/sci-biology/arb/arb-5.2.ebuild b/sci-biology/arb/arb-5.2.ebuild
index 55ea8e8a81e7..b843c06f88af 100644
--- a/sci-biology/arb/arb-5.2.ebuild
+++ b/sci-biology/arb/arb-5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/arb/arb-5.2.ebuild,v 1.4 2012/03/04 09:55:06 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/arb/arb-5.2.ebuild,v 1.5 2012/08/14 16:47:19 jlec Exp $
EAPI=4
@@ -46,12 +46,15 @@ src_prepare() {
"${WORKDIR}"/${P}-linker.patch \
"${FILESDIR}"/5.1-libs.patch \
"${FILESDIR}"/5.1-bfr-overflow.patch \
- "${FILESDIR}"/${PV}-libpng15.patch
- sed -i \
+ "${FILESDIR}"/${PV}-libpng15.patch \
+ "${FILESDIR}"/${P}-gcc-47.patch
+ sed \
-e 's/all: checks/all:/' \
-e "s/GCC:=.*/GCC=$(tc-getCC) ${CFLAGS}/" \
-e "s/GPP:=.*/GPP=$(tc-getCXX) ${CXXFLAGS}/" \
- "${S}/Makefile" || die
+ -e 's:-O4::g' \
+ -e 's:-pipe::g' \
+ -i "${S}/Makefile" || die
cp config.makefile.template config.makefile
sed -i -e '/^[ \t]*read/ d' -e 's/SHELL_ANS=0/SHELL_ANS=1/' "${S}/arb_install.sh" || die
use amd64 && sed -i -e 's/ARB_64 := 0/ARB_64 := 1/' config.makefile
diff --git a/sci-biology/arb/arb-5.3.ebuild b/sci-biology/arb/arb-5.3.ebuild
new file mode 100644
index 000000000000..7cf8503a3780
--- /dev/null
+++ b/sci-biology/arb/arb-5.3.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/arb/arb-5.3.ebuild,v 1.1 2012/08/14 16:47:19 jlec Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Tools for DNA/RNA sequence database handling and data analysis, phylogenetic analysis"
+HOMEPAGE="http://www.arb-home.de/"
+SRC_URI="
+ http://download.arb-home.de/release/arb_${PV}/arbsrc.tgz -> ${P}.tgz
+ http://dev.gentoo.org/~jlec/distfiles/${P}-linker.patch.xz"
+
+SLOT="0"
+LICENSE="arb"
+IUSE="+opengl"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="app-text/sablotron
+ media-libs/libpng
+ media-libs/tiff
+ www-client/lynx
+ x11-libs/libXaw
+ x11-libs/libXpm
+ x11-libs/openmotif:0
+ opengl? (
+ media-libs/glew
+ media-libs/freeglut
+ || (
+ media-libs/mesa[motif]
+ ( media-libs/mesa x11-libs/libGLw ) ) )"
+DEPEND="${CDEPEND}
+ sys-process/time"
+RDEPEND="${CDEPEND}
+ sci-visualization/gnuplot"
+# Recommended: libmotif3 gv xfig xterm treetool java
+
+src_unpack() {
+ unpack ${A}
+ mv arbsrc* ${P}
+}
+
+src_prepare() {
+ epatch \
+ "${WORKDIR}"/${P}-linker.patch \
+ "${FILESDIR}"/5.1-libs.patch \
+ "${FILESDIR}"/5.1-bfr-overflow.patch \
+ "${FILESDIR}"/5.2-libpng15.patch \
+ "${FILESDIR}"/${PN}-5.2-gcc-47.patch
+ sed \
+ -e 's/all: checks/all:/' \
+ -e "s/GCC:=.*/GCC=$(tc-getCC) ${CFLAGS}/" \
+ -e "s/GPP:=.*/GPP=$(tc-getCXX) ${CXXFLAGS}/" \
+ -i "${S}/Makefile" || die
+ cp config.makefile.template config.makefile
+ sed -i -e '/^[ \t]*read/ d' -e 's/SHELL_ANS=0/SHELL_ANS=1/' "${S}/arb_install.sh" || die
+ use amd64 && sed -i -e 's/ARB_64 := 0/ARB_64 := 1/' config.makefile
+ use opengl || sed -i -e 's/OPENGL := 1/OPENGL := 0/' config.makefile
+ emake ARBHOME="${S}" links
+}
+
+src_compile() {
+ emake ARBHOME="${S}" PATH="${PATH}:${S}/bin" LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:${S}/lib" tarfile
+ use amd64 && mv arb.tgz arb.64.gentoo.tgz
+ use x86 && mv arb.tgz arb.32.gentoo.tgz
+ ln -s arb.*.tgz arb.tgz || die
+}
+
+src_install() {
+ ARBHOME="${D}/opt/arb" "${S}/arb_install.sh" || die
+ cat <<- EOF > "${S}/99${PN}"
+ ARBHOME=/opt/arb
+ PATH=/opt/arb/bin
+ LD_LIBRARY_PATH=/opt/arb/lib
+ EOF
+ doenvd "${S}/99${PN}"
+}
diff --git a/sci-biology/arb/files/arb-5.2-gcc-47.patch b/sci-biology/arb/files/arb-5.2-gcc-47.patch
new file mode 100644
index 000000000000..186e78e450b3
--- /dev/null
+++ b/sci-biology/arb/files/arb-5.2-gcc-47.patch
@@ -0,0 +1,15 @@
+ AWTI/AWTI_import.cxx | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/AWTI/AWTI_import.cxx b/AWTI/AWTI_import.cxx
+index 8e730ac..e3f9ff4 100644
+--- a/AWTI/AWTI_import.cxx
++++ b/AWTI/AWTI_import.cxx
+@@ -12,6 +12,7 @@
+ #include <GEN.hxx>
+
+ #include <climits>
++#include <unistd.h>
+
+ using namespace std;
+