summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-09-23 15:29:53 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-09-23 15:29:53 +0000
commit4d419a58b7176aa536f10892b87d5cca6b4637e6 (patch)
treef6476529d7ce4b6f24f07cf1ee2c3c5ee97dcb5b /sci-biology/biopython
parentFix handling of USE="-berkdb". (diff)
downloadgentoo-2-4d419a58b7176aa536f10892b87d5cca6b4637e6.tar.gz
gentoo-2-4d419a58b7176aa536f10892b87d5cca6b4637e6.tar.bz2
gentoo-2-4d419a58b7176aa536f10892b87d5cca6b4637e6.zip
Version bump
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/biopython')
-rw-r--r--sci-biology/biopython/ChangeLog7
-rw-r--r--sci-biology/biopython/biopython-1.52.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/sci-biology/biopython/ChangeLog b/sci-biology/biopython/ChangeLog
index 7e79a08d9b25..2d228924e8f2 100644
--- a/sci-biology/biopython/ChangeLog
+++ b/sci-biology/biopython/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/biopython
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/ChangeLog,v 1.36 2009/09/09 21:45:48 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/ChangeLog,v 1.37 2009/09/23 15:29:53 weaver Exp $
+
+*biopython-1.52 (23 Sep 2009)
+
+ 23 Sep 2009; Andrey Kislyuk <weaver@gentoo.org> +biopython-1.52.ebuild:
+ Version bump
*biopython-1.51 (09 Sep 2009)
diff --git a/sci-biology/biopython/biopython-1.52.ebuild b/sci-biology/biopython/biopython-1.52.ebuild
new file mode 100644
index 000000000000..ef6deb2ec800
--- /dev/null
+++ b/sci-biology/biopython/biopython-1.52.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/biopython-1.52.ebuild,v 1.1 2009/09/23 15:29:53 weaver Exp $
+
+EAPI="2"
+
+NEED_PYTHON=2.4
+inherit distutils eutils base
+
+DESCRIPTION="Biopython - Python modules for computational molecular biology"
+LICENSE="as-is"
+HOMEPAGE="http://www.biopython.org"
+SRC_URI="http://www.biopython.org/DIST/${P}.tar.gz"
+
+SLOT="0"
+IUSE="mysql postgres"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="dev-python/numpy
+ >=dev-python/reportlab-2.0
+ sys-devel/flex"
+
+RDEPEND="${DEPEND}
+ mysql? ( dev-python/mysql-python )
+ postgres? ( dev-python/psycopg )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.51-flex.patch
+)
+
+src_compile() {
+ distutils_src_compile
+}
+
+src_install() {
+ DOCS="CONTRIB DEPRECATED NEWS README"
+ distutils_src_install
+
+ dodir "/usr/share/doc/${PF}"
+ cp -r Doc/* "${D}/usr/share/doc/${PF}/" || \
+ die "Failed to install documentation."
+ dodir "/usr/share/${PN}"
+ rm -f Tests/*.pyc || \
+ die "Failed to remove precompiled test files."
+ cp -r --preserve=mode Scripts Tests "${D}/usr/share/${PN}/" || \
+ die "Failed to install shared files."
+}
+
+src_test() {
+ cd "${S}/Tests"
+ PYTHONPATH="${PYTHONPATH}:${S}" \
+ python run_tests.py --no-gui || die "Tests failed."
+}