summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-12-29 00:56:58 +0000
committerJustin Lecher <jlec@gentoo.org>2013-12-29 00:56:58 +0000
commit4e0734785ae1742813355cc00adf4271dd6864b5 (patch)
tree5fd805b4420dbed2d97d54019da2cd4fc94c8847 /sci-biology/biopython
parentdev-python/pygraphviz: Version Bump (diff)
downloadgentoo-2-4e0734785ae1742813355cc00adf4271dd6864b5.tar.gz
gentoo-2-4e0734785ae1742813355cc00adf4271dd6864b5.tar.bz2
gentoo-2-4e0734785ae1742813355cc00adf4271dd6864b5.zip
sci-biology/biopython: Add additional patch from Martin Mokrejš
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-biology/biopython')
-rw-r--r--sci-biology/biopython/ChangeLog8
-rw-r--r--sci-biology/biopython/biopython-1.62-r1.ebuild48
-rw-r--r--sci-biology/biopython/files/biopython-1.62-SffIO.patch36
3 files changed, 91 insertions, 1 deletions
diff --git a/sci-biology/biopython/ChangeLog b/sci-biology/biopython/ChangeLog
index 51abd0392438..bb30a4404636 100644
--- a/sci-biology/biopython/ChangeLog
+++ b/sci-biology/biopython/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/biopython
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/ChangeLog,v 1.72 2013/09/17 16:07:56 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/ChangeLog,v 1.73 2013/12/29 00:56:58 jlec Exp $
+
+*biopython-1.62-r1 (29 Dec 2013)
+
+ 29 Dec 2013; Justin Lecher <jlec@gentoo.org> +biopython-1.62-r1.ebuild,
+ +files/biopython-1.62-SffIO.patch:
+ Add additional patch from Martin Mokrejš
*biopython-1.62 (17 Sep 2013)
diff --git a/sci-biology/biopython/biopython-1.62-r1.ebuild b/sci-biology/biopython/biopython-1.62-r1.ebuild
new file mode 100644
index 000000000000..433cffb9ad69
--- /dev/null
+++ b/sci-biology/biopython/biopython-1.62-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/biopython-1.62-r1.ebuild,v 1.1 2013/12/29 00:56:58 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python modules for computational molecular biology"
+HOMEPAGE="http://www.biopython.org/ http://pypi.python.org/pypi/biopython/"
+SRC_URI="http://www.biopython.org/DIST/${P}.tar.gz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="mysql postgres"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pygraphviz[${PYTHON_USEDEP}]
+ dev-python/reportlab[${PYTHON_USEDEP}]
+ media-gfx/pydot[${PYTHON_USEDEP}]
+ mysql? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
+ postgres? ( dev-python/psycopg[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
+DOCS=( CONTRIB DEPRECATED NEWS README Doc/. )
+
+PATCHES=( "${FILESDIR}/${PN}-1.62-SffIO.patch" )
+
+python_test() {
+ cd Tests || die
+ ${PYTHON} run_tests.py || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ dodir /usr/share/${PN}
+ cp -r --preserve=mode Scripts Tests "${ED}"/usr/share/${PN} || die
+}
diff --git a/sci-biology/biopython/files/biopython-1.62-SffIO.patch b/sci-biology/biopython/files/biopython-1.62-SffIO.patch
new file mode 100644
index 000000000000..7f2208ef63c4
--- /dev/null
+++ b/sci-biology/biopython/files/biopython-1.62-SffIO.patch
@@ -0,0 +1,36 @@
+--- Bio/SeqIO/SffIO.py.ori 2013-09-25 13:28:51.000000000 +0200
++++ Bio/SeqIO/SffIO.py 2013-09-25 13:37:44.000000000 +0200
+@@ -383,7 +383,14 @@
+ if padding:
+ padding = 8 - padding
+ if handle.read(padding).count(_null) != padding:
+- raise ValueError("Post quality %i byte padding region contained data"
++ import warnings
++ from Bio import BiopythonParserWarning
++ warnings.warn("Your SFF file is valid but post quality %i byte "
++ "padding region contains UNUSED data. Was the "
++ "SFF file created by SRA sff-dump >2.1.7 and <2.1.10? "
++ "It did not clear some internal buffer while writing "
++ "out new data so that previous values remained in the"
++ "output unless overwritten by new real values."
+ % padding)
+ #print read, name, record_offset
+ yield name, record_offset
+--- Bio/SeqIO/SffIO.py.ori 2013-09-25 14:07:14.000000000 +0200
++++ Bio/SeqIO/SffIO.py 2013-09-25 14:08:59.000000000 +0200
+@@ -596,7 +596,14 @@
+ if padding:
+ padding = 8 - padding
+ if handle.read(padding).count(_null) != padding:
+- raise ValueError("Post quality %i byte padding region contained data"
++ import warnings
++ from Bio import BiopythonParserWarning
++ warnings.warn("Your SFF file is valid but post quality %i byte "
++ "padding region contains UNUSED data. Was the "
++ "SFF file created by SRA sff-dump >2.1.7 and <2.1.10? "
++ "It did not clear some internal buffer while writing "
++ "out new data so that previous values remained in the"
++ "output unless overwritten by new real values."
+ % padding)
+ #Follow Roche and apply most aggressive of qual and adapter clipping.
+ #Note Roche seems to ignore adapter clip fields when writing SFF,