summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2011-12-26 05:51:16 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2011-12-26 05:51:16 +0000
commitd7ddfc357cfe3a066b1f913cba260113188f9a07 (patch)
tree8079459ba57ad52569e661db6648fbde08defdf7 /sci-biology/biopython
parentVersion bump (diff)
downloadgentoo-2-d7ddfc357cfe3a066b1f913cba260113188f9a07.tar.gz
gentoo-2-d7ddfc357cfe3a066b1f913cba260113188f9a07.tar.bz2
gentoo-2-d7ddfc357cfe3a066b1f913cba260113188f9a07.zip
Version bump
(Portage version: 2.2.0_alpha74/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/biopython')
-rw-r--r--sci-biology/biopython/ChangeLog10
-rw-r--r--sci-biology/biopython/biopython-1.58.ebuild55
2 files changed, 64 insertions, 1 deletions
diff --git a/sci-biology/biopython/ChangeLog b/sci-biology/biopython/ChangeLog
index d8188ff3ab11..d8ebb4cc0485 100644
--- a/sci-biology/biopython/ChangeLog
+++ b/sci-biology/biopython/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-biology/biopython
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/ChangeLog,v 1.65 2011/06/23 14:55:47 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/ChangeLog,v 1.66 2011/12/26 05:51:16 weaver Exp $
+
+ 26 Dec 2011; Andrey Kislyuk <weaver@gentoo.org> +biopython-1.58.ebuild:
+ Version bump
+
+*biopython-1.58 (26 Dec 2011)
+
+ 26 Dec 2011; Andrey Kislyuk <weaver@gentoo.org> +biopython-1.58.ebuild:
+ Version bump
23 Jun 2011; Markos Chandras <hwoarang@gentoo.org> -biopython-1.56.ebuild:
Remove old ebuilds. Requested by Arfrever
diff --git a/sci-biology/biopython/biopython-1.58.ebuild b/sci-biology/biopython/biopython-1.58.ebuild
new file mode 100644
index 000000000000..4e219b27da2b
--- /dev/null
+++ b/sci-biology/biopython/biopython-1.58.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/biopython-1.58.ebuild,v 1.1 2011/12/26 05:51:16 weaver Exp $
+
+EAPI=3
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils eutils
+
+DESCRIPTION="Python modules for computational molecular biology"
+HOMEPAGE="http://www.biopython.org/ http://pypi.python.org/pypi/biopython/"
+SRC_URI="http://www.biopython.org/DIST/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="mysql postgres"
+
+RDEPEND="
+ dev-python/numpy
+ dev-python/reportlab
+ mysql? ( dev-python/mysql-python )
+ postgres? ( dev-python/psycopg )"
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+DOCS="CONTRIB DEPRECATED NEWS README"
+PYTHON_MODNAME="Bio BioSQL"
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}/${PN}-1.51-flex.patch"
+}
+
+src_test() {
+ testing() {
+ cd Tests
+ PYTHONPATH="$(ls -d ../build/lib.*)" "$(PYTHON)" run_tests.py
+ }
+ python_execute_function --nonfatal -s testing
+}
+
+src_install() {
+ distutils_src_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r Doc/* || die "Installation of documentation failed"
+ insinto /usr/share/${PN}
+ cp -r --preserve=mode Scripts Tests "${ED}usr/share/${PN}" || die "Installation of shared files failed"
+}