summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-09-09 13:31:32 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-09-09 13:31:32 +0000
commited25224a2bad1b17152c4f705dabcdcb85f3020e (patch)
tree1b0913b26827c8891e0c5054f01a83250a9025be /sci-biology/clustalx
parentKeyworded amd64 since it works just fine. (diff)
downloadgentoo-2-ed25224a2bad1b17152c4f705dabcdcb85f3020e.tar.gz
gentoo-2-ed25224a2bad1b17152c4f705dabcdcb85f3020e.tar.bz2
gentoo-2-ed25224a2bad1b17152c4f705dabcdcb85f3020e.zip
Added patch to fix gcc-4.3 header issue (bug #237077). Relaxed dependency on full qt:4 to qt-gui:4 only which should be sufficient. Finally, keyworded the 2.0.9 ebuild amd64 since it works fine.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-SENTINEL-2 i686)
Diffstat (limited to 'sci-biology/clustalx')
-rw-r--r--sci-biology/clustalx/ChangeLog9
-rw-r--r--sci-biology/clustalx/clustalx-2.0.9.ebuild7
-rw-r--r--sci-biology/clustalx/files/clustalx-2.0.9-gcc4.3.patch13
3 files changed, 25 insertions, 4 deletions
diff --git a/sci-biology/clustalx/ChangeLog b/sci-biology/clustalx/ChangeLog
index a33f32834a6b..bfe27048960d 100644
--- a/sci-biology/clustalx/ChangeLog
+++ b/sci-biology/clustalx/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-biology/clustalx
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/clustalx/ChangeLog,v 1.16 2008/08/28 21:18:33 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/clustalx/ChangeLog,v 1.17 2008/09/09 13:31:31 markusle Exp $
+
+ 09 Sep 2008; Markus Dittrich <markusle@gentoo.org>
+ +files/clustalx-2.0.9-gcc4.3.patch, clustalx-2.0.9.ebuild:
+ Added patch to fix gcc-4.3 header issue (bug #237077). Relaxed
+ dependency on full qt:4 to qt-gui:4 only which should be
+ sufficient. Finally, keyworded the 2.0.9 ebuild amd64 since it
+ works fine.
*clustalx-2.0.9 (28 Aug 2008)
diff --git a/sci-biology/clustalx/clustalx-2.0.9.ebuild b/sci-biology/clustalx/clustalx-2.0.9.ebuild
index 58decc180e4d..cc334fa16f60 100644
--- a/sci-biology/clustalx/clustalx-2.0.9.ebuild
+++ b/sci-biology/clustalx/clustalx-2.0.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/clustalx/clustalx-2.0.9.ebuild,v 1.1 2008/08/28 21:18:33 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/clustalx/clustalx-2.0.9.ebuild,v 1.2 2008/09/09 13:31:31 markusle Exp $
EAPI=1
@@ -12,16 +12,17 @@ SRC_URI="ftp://ftp.ebi.ac.uk/pub/software/clustalw2/${PV}/${P}-src.tar.gz"
LICENSE="clustalw"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~x86 ~amd64"
IUSE=""
-DEPEND="x11-libs/qt:4"
+DEPEND="x11-libs/qt-gui:4"
RDEPEND="sci-biology/clustalw:2"
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc4.3.patch
sed -e "s|colprot.xml|/usr/share/${PN}/colprot.xml|" \
-e "s|coldna.xml|/usr/share/${PN}/coldna.xml|" \
-e "s|colprint.xml|/usr/share/${PN}/colprint.xml|" \
diff --git a/sci-biology/clustalx/files/clustalx-2.0.9-gcc4.3.patch b/sci-biology/clustalx/files/clustalx-2.0.9-gcc4.3.patch
new file mode 100644
index 000000000000..59b4b4968ab0
--- /dev/null
+++ b/sci-biology/clustalx/files/clustalx-2.0.9-gcc4.3.patch
@@ -0,0 +1,13 @@
+# patch to fix missing headers under gcc-4.3 (see bug #237077)
+
+diff -Naur clustalx-2.0.9/Resources.cpp clustalx-2.0.9.new/Resources.cpp
+--- clustalx-2.0.9/Resources.cpp 2008-06-23 06:58:51.000000000 -0400
++++ clustalx-2.0.9.new/Resources.cpp 2008-09-09 08:57:22.000000000 -0400
+@@ -11,6 +11,7 @@
+ #include <QDir>
+ #include <QFile>
+ #include <iostream>
++#include <cstdlib>
+ using namespace std;
+
+ //environment variables