summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2008-08-27 14:52:03 +0000
committerOlivier Fisette <ribosome@gentoo.org>2008-08-27 14:52:03 +0000
commitedd99c924fbcde645d4fbdeea1bc27370efa97dc (patch)
treee3f9b0ba9004360ddd1cace4f7cd2d733e18d837 /sci-biology/cutg
parentVersion bump, thanks to notification from upstream (diff)
downloadgentoo-2-edd99c924fbcde645d4fbdeea1bc27370efa97dc.tar.gz
gentoo-2-edd99c924fbcde645d4fbdeea1bc27370efa97dc.tar.bz2
gentoo-2-edd99c924fbcde645d4fbdeea1bc27370efa97dc.zip
New upstream version.
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-biology/cutg')
-rw-r--r--sci-biology/cutg/ChangeLog9
-rw-r--r--sci-biology/cutg/cutg-160.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/sci-biology/cutg/ChangeLog b/sci-biology/cutg/ChangeLog
index 241701414cc3..c1b7c6c604f0 100644
--- a/sci-biology/cutg/ChangeLog
+++ b/sci-biology/cutg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/cutg
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/cutg/ChangeLog,v 1.49 2006/12/10 18:55:06 ribosome Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/cutg/ChangeLog,v 1.50 2008/08/27 14:52:03 ribosome Exp $
+
+*cutg-160 (27 Aug 2008)
+
+ 27 Aug 2008; Olivier Fisette <ribosome@gentoo.org> +cutg-160.ebuild:
+ New upstream version.
10 Dec 2006; Olivier Fisette <ribosome@gentoo.org> -cutg-150.ebuild:
Pruned old version.
diff --git a/sci-biology/cutg/cutg-160.ebuild b/sci-biology/cutg/cutg-160.ebuild
new file mode 100644
index 000000000000..14b1de365d5d
--- /dev/null
+++ b/sci-biology/cutg/cutg-160.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/cutg/cutg-160.ebuild,v 1.1 2008/08/27 14:52:03 ribosome Exp $
+
+DESCRIPTION="Codon usage tables calculated from GenBank"
+LICENSE="public-domain"
+HOMEPAGE="http://www.kazusa.or.jp/codon/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+SLOT="0"
+# Minimal build keeps only the indexed files (if applicable) and the
+# documentation. The non-indexed database is not installed.
+IUSE="emboss minimal"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="emboss? ( sci-biology/emboss )"
+
+src_compile() {
+ if use emboss; then
+ mkdir CODONS
+ echo
+ einfo "Indexing CUTG for usage with EMBOSS."
+ EMBOSS_DATA="." cutgextract -auto -directory "${S}" || die \
+ "Indexing CUTG failed."
+ echo
+ fi
+}
+
+src_install() {
+ if ! use minimal; then
+ mkdir -p "${D}"usr/share/${PN}
+ mv *.codon *.spsum "${D}"/usr/share/${PN} || die \
+ "Installing raw CUTG database failed."
+ fi
+ dodoc README CODON_LABEL SPSUM_LABEL || die \
+ "Failed to install documentation."
+ if use emboss; then
+ mkdir -p "${D}"/usr/share/EMBOSS/data/CODONS
+ cd CODONS
+ for file in *; do
+ mv ${file} "${D}"/usr/share/EMBOSS/data/CODONS || die \
+ "Installing the EMBOSS-indexed database failed."
+ done
+ fi
+}