summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Gardner <je_fro@gentoo.org>2011-09-20 12:58:06 +0000
committerJeffrey Gardner <je_fro@gentoo.org>2011-09-20 12:58:06 +0000
commit8bef9540dc1a7d4f51d758bbe833444126fcba8c (patch)
treea565ee1c4ac9fc38f3fb68c3ec74afe0356df794 /sci-biology/foldingathome
parentAdd patch for libpng-1.5 support. Bug #383571. Thanks to Erich Seifert <esei... (diff)
downloadgentoo-2-8bef9540dc1a7d4f51d758bbe833444126fcba8c.tar.gz
gentoo-2-8bef9540dc1a7d4f51d758bbe833444126fcba8c.tar.bz2
gentoo-2-8bef9540dc1a7d4f51d758bbe833444126fcba8c.zip
Change opts to extra_commands in init script.
(Portage version: 2.1.10.19/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/foldingathome')
-rw-r--r--sci-biology/foldingathome/ChangeLog8
-rw-r--r--sci-biology/foldingathome/files/6.34/fah-init4
-rw-r--r--sci-biology/foldingathome/foldingathome-6.34-r2.ebuild59
3 files changed, 68 insertions, 3 deletions
diff --git a/sci-biology/foldingathome/ChangeLog b/sci-biology/foldingathome/ChangeLog
index 7aa557ab6a48..b4bff35e17ed 100644
--- a/sci-biology/foldingathome/ChangeLog
+++ b/sci-biology/foldingathome/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/foldingathome
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/foldingathome/ChangeLog,v 1.33 2011/06/28 15:14:16 je_fro Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/foldingathome/ChangeLog,v 1.34 2011/09/20 12:58:05 je_fro Exp $
+
+*foldingathome-6.34-r2 (20 Sep 2011)
+
+ 20 Sep 2011; Jeff Gardner <je_fro@gentoo.org> files/6.34/fah-init,
+ +foldingathome-6.34-r2.ebuild:
+ Change opts to extra_commands in init script.
*foldingathome-6.34-r1 (28 Jun 2011)
diff --git a/sci-biology/foldingathome/files/6.34/fah-init b/sci-biology/foldingathome/files/6.34/fah-init
index 04a9389db0cd..60a5a8b51a4b 100644
--- a/sci-biology/foldingathome/files/6.34/fah-init
+++ b/sci-biology/foldingathome/files/6.34/fah-init
@@ -1,9 +1,9 @@
#!/sbin/runscript
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/foldingathome/files/6.34/fah-init,v 1.3 2011/06/28 15:14:16 je_fro Exp $
+# $
-opts="${opts} unitinfo"
+extra_commands="unitinfo"
unitinfo() {
einfo "$(head -n1 /opt/foldingathome/unitinfo.txt):"
diff --git a/sci-biology/foldingathome/foldingathome-6.34-r2.ebuild b/sci-biology/foldingathome/foldingathome-6.34-r2.ebuild
new file mode 100644
index 000000000000..c0d123b98e8e
--- /dev/null
+++ b/sci-biology/foldingathome/foldingathome-6.34-r2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $
+
+EAPI="3"
+
+inherit eutils
+
+DESCRIPTION="Folding@Home is a distributed computing project for protein folding."
+HOMEPAGE="http://folding.stanford.edu/FAQ-SMP.html"
+SRC_URI="http://www.stanford.edu/group/pandegroup/folding/release/FAH${PV}-Linux64.tgz"
+
+LICENSE="folding-at-home"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+S="${WORKDIR}"
+
+I="opt/foldingathome"
+
+QA_DT_HASH="${I}/.*"
+QA_PRESTRIPPED="${I}/fah6"
+
+pkg_setup() {
+ I="${EPREFIX}/${I}"
+}
+
+src_install() {
+ exeinto ${I}
+ doexe "${FILESDIR}"/${PV}/initfolding || die
+ doexe fah6 || die
+ newconfd "${FILESDIR}"/${PV}/folding-conf.d foldingathome || die
+ newinitd "${FILESDIR}"/${PV}/fah-init foldingathome || die
+}
+
+pkg_preinst() {
+ # the bash shell is important for "su -c" in init script
+ enewuser foldingathome -1 /bin/bash /opt/foldingathome
+}
+
+pkg_postinst() {
+ chown -R foldingathome:nogroup "${EPREFIX}"/opt/foldingathome
+ einfo "To run Folding@home in the background at boot:"
+ einfo " rc-update add foldingathome default"
+ einfo ""
+ einfo "Please run ${I}/initfolding to configure your client"
+ einfo "and edit ${EPREFIX}/etc/conf.d/foldingathome for options"
+ einfo ""
+ einfo "I encourage you to acquire a username and join team 36480."
+ einfo "http://folding.stanford.edu/English/Download#ntoc2"
+ einfo ""
+}
+
+pkg_postrm() {
+ einfo "Folding@home data files were not removed."
+ einfo " Remove them manually from ${I}"
+ einfo ""
+}