summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-09-11 02:02:25 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-09-11 02:02:25 +0000
commitf52cf1adfb03c4e76721a53e4006013e2d772492 (patch)
tree433ce2b48df3e700084ad366f6ab6588f92b479d /sci-biology/phylip
parent[taglib-extras] Bumped to version 0.1.7. (diff)
downloadgentoo-2-f52cf1adfb03c4e76721a53e4006013e2d772492.tar.gz
gentoo-2-f52cf1adfb03c4e76721a53e4006013e2d772492.tar.bz2
gentoo-2-f52cf1adfb03c4e76721a53e4006013e2d772492.zip
Version bump
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/phylip')
-rw-r--r--sci-biology/phylip/ChangeLog7
-rw-r--r--sci-biology/phylip/metadata.xml4
-rw-r--r--sci-biology/phylip/phylip-3.69.ebuild47
3 files changed, 57 insertions, 1 deletions
diff --git a/sci-biology/phylip/ChangeLog b/sci-biology/phylip/ChangeLog
index ad2513e607b1..2de0eb86fe4c 100644
--- a/sci-biology/phylip/ChangeLog
+++ b/sci-biology/phylip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/phylip
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/phylip/ChangeLog,v 1.36 2009/09/01 19:20:56 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/phylip/ChangeLog,v 1.37 2009/09/11 02:02:25 weaver Exp $
+
+*phylip-3.69 (10 Sep 2009)
+
+ 10 Sep 2009; Andrey Kislyuk <weaver@gentoo.org> +phylip-3.69.ebuild:
+ Version bump
01 Sep 2009; Olivier Fisette <ribosome@gentoo.org> -phylip-3.65-r1.ebuild,
-phylip-3.66.ebuild:
diff --git a/sci-biology/phylip/metadata.xml b/sci-biology/phylip/metadata.xml
index d4648212cbad..3302123e5718 100644
--- a/sci-biology/phylip/metadata.xml
+++ b/sci-biology/phylip/metadata.xml
@@ -1,5 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <maintainer>
+ <email>weaver@gentoo.org</email>
+ <name>Andrey Kislyuk</name>
+ </maintainer>
<herd>sci-biology</herd>
</pkgmetadata>
diff --git a/sci-biology/phylip/phylip-3.69.ebuild b/sci-biology/phylip/phylip-3.69.ebuild
new file mode 100644
index 000000000000..829fc48c215e
--- /dev/null
+++ b/sci-biology/phylip/phylip-3.69.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/phylip/phylip-3.69.ebuild,v 1.1 2009/09/11 02:02:25 weaver Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="PHYLIP - The PHYLogeny Inference Package"
+LICENSE="freedist"
+HOMEPAGE="http://evolution.genetics.washington.edu/phylip.html"
+SRC_URI="http://evolution.gs.washington.edu/${PN}/download/${P}.tar.gz"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="x11-libs/libXaw"
+
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S="${WORKDIR}/${P}/src"
+
+src_compile() {
+ sed -e "s/CFLAGS = -O3 -fomit-frame-pointer/CFLAGS = ${CFLAGS}/" \
+ -e "s/CC = cc/CC = $(tc-getCC)/" \
+ -e "s/DC = cc/DC = $(tc-getCC)/" \
+ -i Makefile || die "Patching Makefile failed."
+ mkdir ../fonts
+ emake -j1 all put || die "Compilation failed."
+ mv ../exe/font* ../fonts || die "Font move failed."
+ mv ../exe/factor ../exe/factor-${PN} || die "Renaming factor failed."
+}
+
+src_install() {
+ cd "${WORKDIR}/${P}"
+
+ dobin exe/* || die "Failed to install programs."
+
+ dodoc "${FILESDIR}"/README.Gentoo || die "Failed to install Gentoo notes."
+
+ dohtml phylip.html || die "Failed to install HTML documentation index."
+ insinto /usr/share/doc/${PF}/html/doc
+ doins doc/* || die "Failed to install HTML documentation."
+
+ insinto /usr/share/${PN}/fonts
+ doins fonts/* || die "Fonts installation failed."
+}