summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2012-02-28 05:27:53 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2012-02-28 05:27:53 +0000
commit9cef6c34cc7d58425691d2fa1e52ce09643bd0b4 (patch)
tree638481b446a35759229dfbc95cec8fc8547f36a5 /sci-biology/picard
parentOnly pass with-branding if bindist build (diff)
downloadgentoo-2-9cef6c34cc7d58425691d2fa1e52ce09643bd0b4.tar.gz
gentoo-2-9cef6c34cc7d58425691d2fa1e52ce09643bd0b4.tar.bz2
gentoo-2-9cef6c34cc7d58425691d2fa1e52ce09643bd0b4.zip
Version bump
(Portage version: 2.2.0_alpha74/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/picard')
-rw-r--r--sci-biology/picard/ChangeLog7
-rw-r--r--sci-biology/picard/picard-1.63.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/sci-biology/picard/ChangeLog b/sci-biology/picard/ChangeLog
index 2bc632b203ca..792b3b970109 100644
--- a/sci-biology/picard/ChangeLog
+++ b/sci-biology/picard/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/picard
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/picard/ChangeLog,v 1.1 2012/01/04 03:41:51 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/picard/ChangeLog,v 1.2 2012/02/28 05:27:53 weaver Exp $
+
+*picard-1.63 (28 Feb 2012)
+
+ 28 Feb 2012; Andrey Kislyuk <weaver@gentoo.org> +picard-1.63.ebuild:
+ Version bump
*picard-1.58 (04 Jan 2012)
diff --git a/sci-biology/picard/picard-1.63.ebuild b/sci-biology/picard/picard-1.63.ebuild
new file mode 100644
index 000000000000..ccec0120b474
--- /dev/null
+++ b/sci-biology/picard/picard-1.63.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/picard/picard-1.63.ebuild,v 1.1 2012/02/28 05:27:53 weaver Exp $
+
+EAPI=4
+
+#ESVN_REPO_URI="https://picard.svn.sourceforge.net/svnroot/picard/trunk"
+ESVN_REPO_URI="https://picard.svn.sourceforge.net/svnroot/picard/tags/${PV}"
+
+EANT_BUILD_TARGET="all"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_NEEDS_TOOLS="true"
+WANT_ANT_TASKS="ant-apache-bcel"
+
+inherit subversion java-pkg-2 java-ant-2
+
+DESCRIPTION="Java-based command-line utilities that manipulate SAM files"
+HOMEPAGE="http://picard.sourceforge.net/"
+SRC_URI=""
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64"
+
+COMMON_DEPS=""
+DEPEND=">=virtual/jdk-1.6
+ dev-java/ant-apache-bcel:0
+ app-arch/zip
+ ${COMMON_DEPS}"
+RDEPEND=">=virtual/jre-1.6
+ ${COMMON_DEPS}"
+
+src_install() {
+ cd dist
+ for i in *-${PV}.jar; do java-pkg_newjar $i ${i/-${PV}/}; rm $i; done
+ java-pkg_dojar *.jar
+ for i in *.jar; do java-pkg_dolauncher ${i/.jar/} --jar $i; done
+}