summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2006-01-21 18:11:39 +0000
committerOlivier Fisette <ribosome@gentoo.org>2006-01-21 18:11:39 +0000
commit03e5c3784588a923881aba785f63790b87a4f9ba (patch)
tree16f0fd4202e83dd0bd3fe2a1fc8da6b65e9ddd99 /sci-biology/qrna
parentadded to ~ppc, bug #119099 (diff)
downloadgentoo-2-03e5c3784588a923881aba785f63790b87a4f9ba.tar.gz
gentoo-2-03e5c3784588a923881aba785f63790b87a4f9ba.tar.bz2
gentoo-2-03e5c3784588a923881aba785f63790b87a4f9ba.zip
Ebuild clean-up
(Portage version: 2.0.53)
Diffstat (limited to 'sci-biology/qrna')
-rw-r--r--sci-biology/qrna/ChangeLog5
-rw-r--r--sci-biology/qrna/qrna-2.0.3c.ebuild30
2 files changed, 19 insertions, 16 deletions
diff --git a/sci-biology/qrna/ChangeLog b/sci-biology/qrna/ChangeLog
index 590d7c1381dd..8d08abf918d1 100644
--- a/sci-biology/qrna/ChangeLog
+++ b/sci-biology/qrna/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-biology/qrna
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/qrna/ChangeLog,v 1.10 2006/01/04 23:31:45 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/qrna/ChangeLog,v 1.11 2006/01/21 18:08:49 ribosome Exp $
+
+ 21 Jan 2006; Olivier Fisette <ribosome@gentoo.org> qrna-2.0.3c.ebuild:
+ Ebuild clean-up.
04 Jan 2006; Olivier Fisette <ribosome@gentoo.org> qrna-2.0.3c.ebuild:
Do not depend on "virtual/libc" (package not in system target).
diff --git a/sci-biology/qrna/qrna-2.0.3c.ebuild b/sci-biology/qrna/qrna-2.0.3c.ebuild
index 02d8e3506552..17e2339df8a5 100644
--- a/sci-biology/qrna/qrna-2.0.3c.ebuild
+++ b/sci-biology/qrna/qrna-2.0.3c.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/qrna/qrna-2.0.3c.ebuild,v 1.5 2006/01/04 23:31:45 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/qrna/qrna-2.0.3c.ebuild,v 1.6 2006/01/21 18:08:49 ribosome Exp $
inherit toolchain-funcs
@@ -22,33 +22,33 @@ src_compile () {
sed -e "s/CC = gcc/CC = $(tc-getCC)/" \
-e "s/CFLAGS = -g -O2/CFLAGS = ${CFLAGS}/" \
-i squid02/Makefile
- cd ${S}/squid
+ cd "${S}"/squid
emake || die
- cd ${S}/squid02
+ cd "${S}"/squid02
emake || die
- cd ${S}/src
+ cd "${S}"/src
emake || die
}
src_install () {
- cd ${S}/src
- dobin cfgbuild eqrna eqrna_sample main rnamat_main shuffle
- cd ${S}/squid02
+ cd "${S}"/src
+ dobin cfgbuild eqrna eqrna_sample main rnamat_main shuffle || die
+ cd "${S}"/squid02
dobin afetch alistat compalign compstruct revcomp seqsplit seqstat \
- sfetch shuffle sindex sreformat translate weight
- cd ${S}
- dobin scripts/*
+ sfetch shuffle sindex sreformat translate weight || die
+ cd "${S}"
+ dobin scripts/* || die
- newdoc 00README
+ newdoc 00README || die
insinto /usr/share/doc/${PF}
- doins documentation/*
+ doins documentation/* || die
insinto /usr/share/${PN}/data
- doins lib/*
+ doins lib/* || die
insinto /usr/share/${PN}/demos
- doins Demos/*
+ doins Demos/* || die
# Sets the path to the QRNA data files.
insinto /etc/env.d
- doins ${FILESDIR}/26qrna
+ doins "${FILESDIR}"/26qrna || die
}