summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-21 06:38:10 +0000
committerJustin Lecher <jlec@gentoo.org>2011-06-21 06:38:10 +0000
commit21a5b6b381a0495b1cb9684f538d7e9a6e4e0fcc (patch)
treeacdbbc4aab841caaaac3136620db0902a44c1bb8 /sci-biology/raxml
parentMaintainer changed to net-mail with dertobi123's permission (diff)
downloadgentoo-2-21a5b6b381a0495b1cb9684f538d7e9a6e4e0fcc.tar.gz
gentoo-2-21a5b6b381a0495b1cb9684f538d7e9a6e4e0fcc.tar.bz2
gentoo-2-21a5b6b381a0495b1cb9684f538d7e9a6e4e0fcc.zip
Tweaking ebuild, respect LDFLAGS #335629
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/raxml')
-rw-r--r--sci-biology/raxml/ChangeLog11
-rw-r--r--sci-biology/raxml/files/raxml-7.2.5-makefile.patch29
-rw-r--r--sci-biology/raxml/metadata.xml1
-rw-r--r--sci-biology/raxml/raxml-7.2.2.ebuild15
-rw-r--r--sci-biology/raxml/raxml-7.2.5-r1.ebuild41
-rw-r--r--sci-biology/raxml/raxml-7.2.5.ebuild15
6 files changed, 96 insertions, 16 deletions
diff --git a/sci-biology/raxml/ChangeLog b/sci-biology/raxml/ChangeLog
index 3efdd7ff0089..12abc66afb9a 100644
--- a/sci-biology/raxml/ChangeLog
+++ b/sci-biology/raxml/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-biology/raxml
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/raxml/ChangeLog,v 1.5 2010/01/27 15:58:33 weaver Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/raxml/ChangeLog,v 1.6 2011/06/21 06:38:10 jlec Exp $
+
+*raxml-7.2.5-r1 (21 Jun 2011)
+
+ 21 Jun 2011; Justin Lecher <jlec@gentoo.org> raxml-7.2.2.ebuild,
+ raxml-7.2.5.ebuild, +raxml-7.2.5-r1.ebuild,
+ +files/raxml-7.2.5-makefile.patch, metadata.xml:
+ Tweaking ebuild, respect LDFLAGS #335629
*raxml-7.2.5 (27 Jan 2010)
diff --git a/sci-biology/raxml/files/raxml-7.2.5-makefile.patch b/sci-biology/raxml/files/raxml-7.2.5-makefile.patch
new file mode 100644
index 000000000000..8b381e50cb58
--- /dev/null
+++ b/sci-biology/raxml/files/raxml-7.2.5-makefile.patch
@@ -0,0 +1,29 @@
+ Makefile.gcc | 6 +++---
+ 1 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile.gcc b/Makefile.gcc
+index 8d09549..59af556 100644
+--- a/Makefile.gcc
++++ b/Makefile.gcc
+@@ -1,10 +1,10 @@
+ # Makefile August 2006 by Alexandros Stamatakis
+ # Makefile cleanup October 2006, Courtesy of Peter Cordes <peter@cordes.ca>
+
+-CC = gcc
++CC ?= gcc
+
+
+-CFLAGS = -D_GNU_SOURCE -fomit-frame-pointer -funroll-loops -O2
++CFLAGS += -D_GNU_SOURCE
+ #-Wall -std=c99 -pedantic -Wunused-parameter -Wredundant-decls -Wreturn-type -Wswitch-default -Wunused-value -Wimplicit -Wimplicit-function-declaration -Wimplicit-int -Wimport -pedantic-errors -Wunused -Wunused-function -Wunused-label -Wno-int-to-pointer-cast -Wbad-function-cast -Wmissing-declarations -Wmissing-prototypes -Wnested-externs -Wold-style-definition -Wstrict-prototypes -Wdeclaration-after-statement -Wpointer-sign -Wextra -Wredundant-decls -Wunused -Wunused-function -Wunused-parameter -Wunused-value -Wunused-variable -Wformat -Wformat-nonliteral -Wparentheses -Wsequence-point -Wuninitialized -Wundef -Wbad-function-cast
+
+
+@@ -19,7 +19,7 @@ all : raxmlHPC
+ GLOBAL_DEPS = axml.h globalVariables.h
+
+ raxmlHPC : $(objs)
+- $(CC) -o raxmlHPC $(objs) $(LIBRARIES)
++ $(CC) $(LDFLAGS) -o raxmlHPC $(objs) $(LIBRARIES)
+
+ classify.o : classify.c $(GLOBAL_DEPS)
+ evaluatePartialSpecialGeneric.o : evaluatePartialSpecialGeneric.c $(GLOBAL_DEPS)
diff --git a/sci-biology/raxml/metadata.xml b/sci-biology/raxml/metadata.xml
index 3302123e5718..3f2ec4ab4025 100644
--- a/sci-biology/raxml/metadata.xml
+++ b/sci-biology/raxml/metadata.xml
@@ -6,4 +6,5 @@
<name>Andrey Kislyuk</name>
</maintainer>
<herd>sci-biology</herd>
+ <use><flag name='sse3'>Enable optimization for SSE3 capable chips</flag></use>
</pkgmetadata>
diff --git a/sci-biology/raxml/raxml-7.2.2.ebuild b/sci-biology/raxml/raxml-7.2.2.ebuild
index 8c3610ac19e2..27a52f2f18d2 100644
--- a/sci-biology/raxml/raxml-7.2.2.ebuild
+++ b/sci-biology/raxml/raxml-7.2.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/raxml/raxml-7.2.2.ebuild,v 1.3 2009/10/31 17:56:05 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/raxml/raxml-7.2.2.ebuild,v 1.4 2011/06/21 06:38:10 jlec Exp $
-EAPI="2"
+EAPI=2
inherit toolchain-funcs
@@ -10,10 +10,10 @@ DESCRIPTION="A Program for Sequential, Parallel & Distributed Inference of Large
HOMEPAGE="http://wwwkramer.in.tum.de/exelixis/software.html"
SRC_URI="http://wwwkramer.in.tum.de/exelixis/software/RAxML-${PV}.tar.bz2"
-LICENSE="GPL-2"
SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
IUSE="+threads"
-KEYWORDS="amd64 x86"
# mpi is not supported in version 7.2.2. mpi is enabled by adding -DPARALLEL to CFLAGS
DEPEND="" # mpi? ( virtual/mpi )"
@@ -22,9 +22,10 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/RAxML-${PV}"
src_prepare() {
- sed -i -e 's/CFLAGS =/CFLAGS := ${CFLAGS}/' \
+ sed \
+ -e 's/CFLAGS =/CFLAGS := ${CFLAGS}/' \
-e 's/CC = gcc/CC = '$(tc-getCC)'/' \
- Makefile.* || die
+ -i Makefile.* || die
}
src_compile() {
diff --git a/sci-biology/raxml/raxml-7.2.5-r1.ebuild b/sci-biology/raxml/raxml-7.2.5-r1.ebuild
new file mode 100644
index 000000000000..5ec6822f113d
--- /dev/null
+++ b/sci-biology/raxml/raxml-7.2.5-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/raxml/raxml-7.2.5-r1.ebuild,v 1.1 2011/06/21 06:38:10 jlec Exp $
+
+EAPI=4
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="A Program for Sequential, Parallel & Distributed Inference of Large Phylogenetic Trees"
+HOMEPAGE="http://wwwkramer.in.tum.de/exelixis/software.html"
+SRC_URI="http://wwwkramer.in.tum.de/exelixis/software/RAxML-${PV}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="sse3 +threads"
+
+# mpi is not supported in version 7.2.2. mpi is enabled by adding -DPARALLEL to CFLAGS
+DEPEND="" # mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/RAxML-${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+
+ use sse3 && append-cflags -D__SIM_SSE3
+ use threads && \
+ append-cflags -D_USE_PTHREADS && \
+ append-ldflags -pthread
+
+ tc-export CC
+}
+
+src_compile() {
+ emake -f Makefile.gcc
+}
+
+src_install() {
+ dobin raxmlHPC
+}
diff --git a/sci-biology/raxml/raxml-7.2.5.ebuild b/sci-biology/raxml/raxml-7.2.5.ebuild
index 6f3a6a52161b..b33622313705 100644
--- a/sci-biology/raxml/raxml-7.2.5.ebuild
+++ b/sci-biology/raxml/raxml-7.2.5.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/raxml/raxml-7.2.5.ebuild,v 1.1 2010/01/27 15:58:33 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/raxml/raxml-7.2.5.ebuild,v 1.2 2011/06/21 06:38:10 jlec Exp $
-EAPI="2"
+EAPI=2
inherit toolchain-funcs
@@ -10,10 +10,10 @@ DESCRIPTION="A Program for Sequential, Parallel & Distributed Inference of Large
HOMEPAGE="http://wwwkramer.in.tum.de/exelixis/software.html"
SRC_URI="http://wwwkramer.in.tum.de/exelixis/software/RAxML-${PV}.tar.bz2"
-LICENSE="GPL-2"
SLOT="0"
-IUSE="+threads"
+LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
+IUSE="+threads"
# mpi is not supported in version 7.2.2. mpi is enabled by adding -DPARALLEL to CFLAGS
DEPEND="" # mpi? ( virtual/mpi )"
@@ -22,9 +22,10 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/RAxML-${PV}"
src_prepare() {
- sed -i -e 's/CFLAGS =/CFLAGS := ${CFLAGS}/' \
+ sed \
+ -e 's/CFLAGS =/CFLAGS := ${CFLAGS}/' \
-e 's/CC = gcc/CC = '$(tc-getCC)'/' \
- Makefile.* || die
+ -i Makefile.* || die
}
src_compile() {