summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2010-11-07 20:41:37 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2010-11-07 20:41:37 +0000
commit3cea0aef645e4be44dc4e4ea1ee1a90c2179cac0 (patch)
tree2aa86b6d6eedc63a575141cac09c5c774d576449 /sci-biology/rmblast
parentSet empty DEPEND wrt #344581 by Ulrich Müller. (diff)
downloadgentoo-2-3cea0aef645e4be44dc4e4ea1ee1a90c2179cac0.tar.gz
gentoo-2-3cea0aef645e4be44dc4e4ea1ee1a90c2179cac0.tar.bz2
gentoo-2-3cea0aef645e4be44dc4e4ea1ee1a90c2179cac0.zip
New package, dependency of sci-biology/repeatmasker. Ebuild written by me
(Portage version: 2.2_rc86/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/rmblast')
-rw-r--r--sci-biology/rmblast/ChangeLog10
-rw-r--r--sci-biology/rmblast/metadata.xml9
-rw-r--r--sci-biology/rmblast/rmblast-1.2.ebuild50
3 files changed, 69 insertions, 0 deletions
diff --git a/sci-biology/rmblast/ChangeLog b/sci-biology/rmblast/ChangeLog
new file mode 100644
index 000000000000..977100d2a931
--- /dev/null
+++ b/sci-biology/rmblast/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-biology/rmblast
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/rmblast/ChangeLog,v 1.1 2010/11/07 20:41:37 weaver Exp $
+
+*rmblast-1.2 (06 Nov 2010)
+
+ 06 Nov 2010; Andrey Kislyuk <weaver@gentoo.org> +rmblast-1.2.ebuild,
+ +metadata.xml:
+ New package, dependency of sci-biology/repeatmasker. Ebuild written by me
+
diff --git a/sci-biology/rmblast/metadata.xml b/sci-biology/rmblast/metadata.xml
new file mode 100644
index 000000000000..3302123e5718
--- /dev/null
+++ b/sci-biology/rmblast/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>weaver@gentoo.org</email>
+ <name>Andrey Kislyuk</name>
+ </maintainer>
+ <herd>sci-biology</herd>
+</pkgmetadata>
diff --git a/sci-biology/rmblast/rmblast-1.2.ebuild b/sci-biology/rmblast/rmblast-1.2.ebuild
new file mode 100644
index 000000000000..60ecccc15eed
--- /dev/null
+++ b/sci-biology/rmblast/rmblast-1.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/rmblast/rmblast-1.2.ebuild,v 1.1 2010/11/07 20:41:37 weaver Exp $
+
+EAPI="3"
+
+inherit flag-o-matic toolchain-funcs
+
+MY_NCBI_BLAST_V=2.2.23+
+
+DESCRIPTION="RepeatMasker compatible version of NCBI BLAST+"
+HOMEPAGE="http://www.repeatmasker.org/RMBlast.html"
+SRC_URI="http://www.repeatmasker.org/rmblast-${PV}-ncbi-blast-${MY_NCBI_BLAST_V}-src.tar.gz"
+
+LICENSE="OSL-2.1"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="~dev-libs/boost-1.35.0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}-ncbi-blast-${MY_NCBI_BLAST_V}-src/c++"
+
+src_install() {
+ einstall || die
+}
+
+src_prepare() {
+ filter-ldflags -Wl,--as-needed
+ sed -i -e 's/-print-file-name=libstdc++.a//' \
+ -e '/sed/ s/\([gO]\[0-9\]\)\*/\1\\+/' \
+ src/build-system/configure || die
+}
+
+src_configure() {
+ tc-export CXX CC
+
+ "${S}"/configure --without-debug \
+ --with-mt \
+ --without-static \
+ --with-dll \
+ --prefix="${ED}"/opt/${PN} \
+ --with-boost=/usr/include/boost-1_35/boost \
+ || die
+}
+
+src_install() {
+ emake install || die
+}