summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-08-03 15:04:04 +0000
committerJustin Lecher <jlec@gentoo.org>2012-08-03 15:04:04 +0000
commit4b263b6834269a131e098993bdfc8ba5fd8d34d2 (patch)
tree0baa73341a884649ad4cef039cc51cdc4e3085a9 /sci-biology/rnaview/files/rnaview-20040713-makefile.patch
parentsci-libs/scotch: Sort seds so that they work with -frecord-gcc-switches, #429... (diff)
downloadgentoo-2-4b263b6834269a131e098993bdfc8ba5fd8d34d2.tar.gz
gentoo-2-4b263b6834269a131e098993bdfc8ba5fd8d34d2.tar.bz2
gentoo-2-4b263b6834269a131e098993bdfc8ba5fd8d34d2.zip
sci-biology/rnaview: Respect CFLAGS, #429536; Bump to EAPI=4
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/rnaview/files/rnaview-20040713-makefile.patch')
-rw-r--r--sci-biology/rnaview/files/rnaview-20040713-makefile.patch88
1 files changed, 54 insertions, 34 deletions
diff --git a/sci-biology/rnaview/files/rnaview-20040713-makefile.patch b/sci-biology/rnaview/files/rnaview-20040713-makefile.patch
index 5d9ecd99cf25..1af72f581fbf 100644
--- a/sci-biology/rnaview/files/rnaview-20040713-makefile.patch
+++ b/sci-biology/rnaview/files/rnaview-20040713-makefile.patch
@@ -1,39 +1,18 @@
-Fix install paths, respect LDFLAGS, CFLAGS
+ Makefile | 20 +++++++++++++++++---
+ rnaml2ps/Makefile | 19 ++++++++++++-------
+ 2 files changed, 29 insertions(+), 10 deletions(-)
-http://bugs.gentoo.org/show_bug.cgi?id=336196
-
---- rnaml2ps/Makefile
-+++ rnaml2ps/Makefile
-@@ -5,16 +5,21 @@
- RNADRAW = rnaml2ps
- OBJS_RNADRAW = rnaml2ps.o nrutil.o
+diff --git a/Makefile b/Makefile
+index 452e6c4..00d35f0 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,4 +1,4 @@
+-CC = cc
++CC ?= cc
-+all: $(RNADRAW)
-+
- $(RNADRAW): $(OBJS_RNADRAW)
-- $(CC) -o $(RNADRAW) $(OBJS_RNADRAW) -lm
-+ $(CC) $(LDFLAGS) -o $(RNADRAW) $(OBJS_RNADRAW) -lm
- nrutil.o : nrutil.c
-- cc -c nrutil.c
-+ $(CC) $(CFLAGS) -c nrutil.c
- rnaml2ps.o : rnaml2ps.c
-- cc -c rnaml2ps.c
-+ $(CC) $(CFLAGS) -c rnaml2ps.c
-
-
--.PHONY : clean
-+.PHONY : clean all install
- clean:
-- rm *.o
-+ rm -f *.o
-+
-+install:
-+ install -D -m 0755 $(RNADRAW) $(DESTDIR)/usr/bin/$(RNADRAW)
---- Makefile
-+++ Makefile
-@@ -56,9 +56,14 @@
+@@ -56,12 +56,17 @@ OBJ_FILE = $(OBJ)/rnaview.o \
$(OBJ)/multiple.o \
$(OBJ)/statistics.o
@@ -48,8 +27,12 @@ http://bugs.gentoo.org/show_bug.cgi?id=336196
+CFLAGS += $(LINCLUDES)
$(RNAVIEW) : $(HFILES) $(OBJ_FILE)
- $(CC) $(CFLAGS) -o $@ $(OBJ_FILE) $(LDFLAGS) -lm $(MALLOCLIB)
-@@ -111,6 +116,15 @@
+- $(CC) $(CFLAGS) -o $@ $(OBJ_FILE) $(LDFLAGS) -lm $(MALLOCLIB)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(OBJ_FILE) -lm $(MALLOCLIB)
+
+
+
+@@ -111,6 +116,15 @@ $(OBJ)/statistics.o : $(SRC)/statistics.c
clean:
@rm -f $(OBJ)/*.o
@rm -f $(ALLTARGETS)
@@ -65,3 +48,40 @@ http://bugs.gentoo.org/show_bug.cgi?id=336196
export:
mkdir -p $(EXPORT_DIR)
+diff --git a/rnaml2ps/Makefile b/rnaml2ps/Makefile
+index d207655..2278ccc 100644
+--- a/rnaml2ps/Makefile
++++ b/rnaml2ps/Makefile
+@@ -1,20 +1,25 @@
+-CFLAGS = -O
+-CC = cc
++CFLAGS ?= -O
++CC ?= cc
+
+ # ++++++++++++++++++++++++++++ Program RNADRAW
+ RNADRAW = rnaml2ps
+ OBJS_RNADRAW = rnaml2ps.o nrutil.o
+
++all: $(RNADRAW)
++
+ $(RNADRAW): $(OBJS_RNADRAW)
+- $(CC) -o $(RNADRAW) $(OBJS_RNADRAW) -lm
++ $(CC) $(LDFLAGS) -o $(RNADRAW) $(OBJS_RNADRAW) -lm
+
+ nrutil.o : nrutil.c
+- cc -c nrutil.c
++ $(CC) $(CFLAGS) -c nrutil.c
+
+ rnaml2ps.o : rnaml2ps.c
+- cc -c rnaml2ps.c
++ $(CC) $(CFLAGS) -c rnaml2ps.c
+
+
+-.PHONY : clean
++.PHONY : clean all install
+ clean:
+- rm *.o
++ rm -f *.o
++
++install:
++ install -D -m 0755 $(RNADRAW) $(DESTDIR)/usr/bin/$(RNADRAW)