summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-12-07 15:50:08 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-12-07 15:50:08 +0000
commit6caa4a51b6c2616d58ff82cebabe45591ef1b609 (patch)
treed2298fc56f4fcf3793c70434b22c55165d065f8e /sci-biology/tophat/tophat-1.0.12.ebuild
parentlinux-2.6.32 support, bug #295930. (diff)
downloadgentoo-2-6caa4a51b6c2616d58ff82cebabe45591ef1b609.tar.gz
gentoo-2-6caa4a51b6c2616d58ff82cebabe45591ef1b609.tar.bz2
gentoo-2-6caa4a51b6c2616d58ff82cebabe45591ef1b609.zip
Import from Science overlay and version bump. Thanks to Philippe Veber.
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/tophat/tophat-1.0.12.ebuild')
-rw-r--r--sci-biology/tophat/tophat-1.0.12.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-biology/tophat/tophat-1.0.12.ebuild b/sci-biology/tophat/tophat-1.0.12.ebuild
new file mode 100644
index 000000000000..e691698188d7
--- /dev/null
+++ b/sci-biology/tophat/tophat-1.0.12.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/tophat/tophat-1.0.12.ebuild,v 1.1 2009/12/07 15:50:08 weaver Exp $
+
+EAPI="2"
+
+inherit autotools
+
+DESCRIPTION="A fast splice junction mapper for RNA-Seq reads"
+HOMEPAGE="http://tophat.cbcb.umd.edu/"
+SRC_URI="http://tophat.cbcb.umd.edu/downloads/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64"
+
+DEPEND="sci-biology/bowtie"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # fix gcc-4.4 missing include
+ sed -i '/#include <string>/ a #include <stdio.h>' "${S}/src/gff_juncs.cpp" || die
+ # fix parallel make race
+ sed -i -e 's/\$(top_builddir)\/src\///g' src/Makefile.am || die
+ eautoreconf || die
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS NEWS THANKS
+}