summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2005-02-20 02:31:40 +0000
committerOlivier Fisette <ribosome@gentoo.org>2005-02-20 02:31:40 +0000
commit098c83a0ea3dc2b1407259b29de469ad6b74c57c (patch)
tree4b0088a1ed06341512cd8086447e5ab33db948f1 /sci-biology/treeviewx
parentAdd patch to fix sgml error and pdf/ps misdetection #73458. (diff)
downloadgentoo-2-098c83a0ea3dc2b1407259b29de469ad6b74c57c.tar.gz
gentoo-2-098c83a0ea3dc2b1407259b29de469ad6b74c57c.tar.bz2
gentoo-2-098c83a0ea3dc2b1407259b29de469ad6b74c57c.zip
Added a patch which might fix bug #82455.
(Portage version: 2.0.51.16)
Diffstat (limited to 'sci-biology/treeviewx')
-rw-r--r--sci-biology/treeviewx/ChangeLog6
-rw-r--r--sci-biology/treeviewx/files/nodeiterator.h.patch31
-rw-r--r--sci-biology/treeviewx/treeviewx-0.4.ebuild10
3 files changed, 45 insertions, 2 deletions
diff --git a/sci-biology/treeviewx/ChangeLog b/sci-biology/treeviewx/ChangeLog
index 6c7fffe15720..834509a3ed11 100644
--- a/sci-biology/treeviewx/ChangeLog
+++ b/sci-biology/treeviewx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-biology/treeviewx
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/treeviewx/ChangeLog,v 1.3 2005/01/30 18:21:09 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/treeviewx/ChangeLog,v 1.4 2005/02/20 02:31:40 ribosome Exp $
+
+ 19 Feb 2005; Olivier Fisette <ribosome@gentoo.org>
+ +files/nodeiterator.h.patch, treeviewx-0.4.ebuild:
+ Added a patch which might solve bug #82455.
30 Jan 2005; Olivier Fisette <ribosome@gentoo.org> treeviewx-0.4.ebuild:
Ebuild cleanup.
diff --git a/sci-biology/treeviewx/files/nodeiterator.h.patch b/sci-biology/treeviewx/files/nodeiterator.h.patch
new file mode 100644
index 000000000000..4b99c72f7c42
--- /dev/null
+++ b/sci-biology/treeviewx/files/nodeiterator.h.patch
@@ -0,0 +1,31 @@
+--- nodeiterator.h.old 2002-02-24 15:37:17.000000000 -0500
++++ nodeiterator.h 2005-02-19 21:09:31.000000000 -0500
+@@ -20,7 +20,7 @@
+ */
+
+ // $Id: nodeiterator.h.patch,v 1.1 2005/02/20 02:31:40 ribosome Exp $
+-
++
+ /**
+ * @file nodeiterator.h
+ *
+@@ -128,15 +128,15 @@
+
+ template <class N> N *PreorderIterator<N>::begin ()
+ {
+- cur = root;
+- return cur;
++ this->cur = this->root;
++ return this->cur;
+ }
+
+ template <class N> N *PreorderIterator<N>::next ()
+ {
+- if (cur->GetChild())
++ if (this->cur->GetChild())
+ {
+- stk.push (cur);
++ this->stk.push (cur);
+ N *p = (N *)(cur->GetChild());
+ cur = p;
+ }
diff --git a/sci-biology/treeviewx/treeviewx-0.4.ebuild b/sci-biology/treeviewx/treeviewx-0.4.ebuild
index fa113cc6130d..6b6dec32be81 100644
--- a/sci-biology/treeviewx/treeviewx-0.4.ebuild
+++ b/sci-biology/treeviewx/treeviewx-0.4.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/treeviewx/treeviewx-0.4.ebuild,v 1.2 2005/01/30 18:21:09 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/treeviewx/treeviewx-0.4.ebuild,v 1.3 2005/02/20 02:31:40 ribosome Exp $
+
+inherit eutils
DESCRIPTION="A phylogenetic tree viewer"
HOMEPAGE="http://darwin.zoology.gla.ac.uk/~rpage/treeviewx/"
@@ -25,6 +27,12 @@ pkg_setup() {
fi
}
+src_unpack() {
+ unpack ${A}
+ cd ${S}/TreeLib
+ epatch ${FILESDIR}/nodeiterator.h.patch
+}
+
src_compile() {
econf || die
# The configure script may pick the Unicode wxGTK.