summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2010-02-14 19:50:11 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2010-02-14 19:50:11 +0000
commitc31e9547c0421343225d843664691c5433029c48 (patch)
tree206671245d40e17267aae17023b9a49d6a6cb536 /sci-biology/vaal/files
parentp.use.mask media-gfx/sanebackends v4l (diff)
downloadgentoo-2-c31e9547c0421343225d843664691c5433029c48.tar.gz
gentoo-2-c31e9547c0421343225d843664691c5433029c48.tar.bz2
gentoo-2-c31e9547c0421343225d843664691c5433029c48.zip
Apply patches, fix bug 294738 and move binaries to libexec
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/vaal/files')
-rw-r--r--sci-biology/vaal/files/vaal-1.2-as-needed.patch22
-rw-r--r--sci-biology/vaal/files/vaal-1.2-respect-flags.patch60
2 files changed, 82 insertions, 0 deletions
diff --git a/sci-biology/vaal/files/vaal-1.2-as-needed.patch b/sci-biology/vaal/files/vaal-1.2-as-needed.patch
new file mode 100644
index 000000000000..31649010dbe3
--- /dev/null
+++ b/sci-biology/vaal/files/vaal-1.2-as-needed.patch
@@ -0,0 +1,22 @@
+--- VAAL.orig/MakeDepend.cc 2008-12-18 17:05:48.000000000 +0100
++++ VAAL/MakeDepend.cc 2010-02-14 13:42:23.734370178 +0100
+@@ -1195,9 +1195,6 @@
+ }
+ }
+ mf << " -L. -L$(LIB) -L$(OBJ) $(LINK_LIBS)";
+- for ( set<string>::iterator dep_iter = lib_deps.begin();
+- dep_iter != lib_deps.end(); ++dep_iter )
+- mf << " " << "$(" << *dep_iter << "_LFLAGS)";
+ for ( set<string>::iterator dep_iter = sharedlib_deps.begin();
+ dep_iter != sharedlib_deps.end(); ++dep_iter ) {
+ // Extract the symbolic name of this library from its filename.
+@@ -1208,6 +1205,9 @@
+ mf << " -l" << sharedlib_name;
+ }
+ mf << " -l" << libname;
++ for ( set<string>::iterator dep_iter = lib_deps.begin();
++ dep_iter != lib_deps.end(); ++dep_iter )
++ mf << " " << "$(" << *dep_iter << "_LFLAGS)";
+ mf << "\n\t" << "/bin/rm $(OBJ)/lib" << libname << ".a\n";
+ }
+ }
diff --git a/sci-biology/vaal/files/vaal-1.2-respect-flags.patch b/sci-biology/vaal/files/vaal-1.2-respect-flags.patch
new file mode 100644
index 000000000000..d3420556b608
--- /dev/null
+++ b/sci-biology/vaal/files/vaal-1.2-respect-flags.patch
@@ -0,0 +1,60 @@
+--- VAAL.orig/Makefile.in 2009-04-02 21:43:42.000000000 +0200
++++ VAAL/Makefile.in 2010-02-14 14:20:26.222370302 +0100
+@@ -161,12 +161,16 @@
+ COMPILER = @CC@
+ CPLUSPLUS = @CXX@
+
++CFLAGS = @CFLAGS@
++CXXFLAGS = @CXXFLAGS@
++LDFLAGS = @LDFLAGS@
++
+ # QUIET=yes causes the compiler to be less verbose about warnings.
+ QUIET = no
+
+ # DEBUG=yes forces out-of-date executables to be built with symbolic
+ # debugging information. Any other value is ignored.
+-DEBUG = yes
++DEBUG = no
+
+ # OPTIM=<compiler optimization> forces user-defined optimizations to be used,
+ # rather than the compiler-specific default.
+@@ -174,7 +178,7 @@
+ # If OPTIM=none, then no optimization is used.
+ # If unset, defaults are used.
+ # -fno-exceptions
+-OPTIM =
++OPTIM = none
+
+ # PROFILE=yes builds sampled-profiling (i.e. gprof) executables. Any other
+ # value is ignored.
+@@ -317,6 +321,7 @@
+ # Setup final compilation options:
+
+ CPP_OPTIONS = \
++ $(CXXFLAGS) \
+ $(SYS_WARN) \
+ $(SYS_OPT) \
+ $(SYS_DEBUG) \
+@@ -328,6 +333,7 @@
+ @INCLUDES@
+
+ LINK_OPTIONS = \
++ $(LDFLAGS) \
+ $(SYS_DEBUG) \
+ $(SYS_LINK) \
+ $(OMP_LINK) \
+@@ -406,12 +406,12 @@
+ $(CPLUSPLUS) $(CPPO) $(CPPC) $(SYS_LANG) $(MAKEDEPEND_OPTS) -o $(BIN)/MakeDepend $(SRC)/MakeDepend.cc
+
+ checkLock: $(SRC)/util/checkLock.cc
+- $(CPLUSPLUS) $(SRC)/util/checkLock.cc -o $(BIN)/checkLock
++ $(CPLUSPLUS) $(CXXFLAGS) $(SRC)/util/checkLock.cc $(LDFLAGS) -o $(BIN)/checkLock
+
+ random/Random.o: random/Random.cc
+ @ mkdir -p $(OBJ)/${@D}
+ cp $(SRC)/random/Random.cc $(SRC)/random/Random.c
+- $(CC) $(SYS_LANG) -c $(SRC)/random/Random.cc -w -Drandom=randomx -Dsrandom=srandomx -o $(OBJ)/random/Random.o
++ $(CC) $(CFLAGS) $(SYS_LANG) -c $(SRC)/random/Random.cc -w -Drandom=randomx -Dsrandom=srandomx -o $(OBJ)/random/Random.o
+ rm $(SRC)/random/Random.c
+
+ MemTracker.o: MemTracker.cc