summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-01-06 08:33:15 +0000
committerJustin Lecher <jlec@gentoo.org>2014-01-06 08:33:15 +0000
commit00ea496e2b48f977d94b72a89b27ca5b9ad59ec2 (patch)
tree81e0e65eea4aa057da9bdf11a787347441f65691 /sci-biology
parentsci-biology/clustalw: Drop old and clean base.eclass usage (diff)
downloadgentoo-2-00ea496e2b48f977d94b72a89b27ca5b9ad59ec2.tar.gz
gentoo-2-00ea496e2b48f977d94b72a89b27ca5b9ad59ec2.tar.bz2
gentoo-2-00ea496e2b48f977d94b72a89b27ca5b9ad59ec2.zip
sci-biology/clustalx: Make sure only system libs are used
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/clustalx/ChangeLog9
-rw-r--r--sci-biology/clustalx/clustalx-2.1-r1.ebuild43
2 files changed, 50 insertions, 2 deletions
diff --git a/sci-biology/clustalx/ChangeLog b/sci-biology/clustalx/ChangeLog
index 13830d677d82..fc44ff6df259 100644
--- a/sci-biology/clustalx/ChangeLog
+++ b/sci-biology/clustalx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/clustalx
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/clustalx/ChangeLog,v 1.29 2013/03/11 15:02:36 jlec Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/clustalx/ChangeLog,v 1.30 2014/01/06 08:33:15 jlec Exp $
+
+*clustalx-2.1-r1 (06 Jan 2014)
+
+ 06 Jan 2014; Justin Lecher <jlec@gentoo.org> +clustalx-2.1-r1.ebuild:
+ Make sure only system libs are used
11 Mar 2013; Justin Lecher <jlec@gentoo.org> -clustalx-1.83-r2.ebuild,
metadata.xml:
diff --git a/sci-biology/clustalx/clustalx-2.1-r1.ebuild b/sci-biology/clustalx/clustalx-2.1-r1.ebuild
new file mode 100644
index 000000000000..c685633a4461
--- /dev/null
+++ b/sci-biology/clustalx/clustalx-2.1-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/clustalx/clustalx-2.1-r1.ebuild,v 1.1 2014/01/06 08:33:15 jlec Exp $
+
+EAPI=5
+
+inherit eutils qt4-r2
+
+DESCRIPTION="Graphical interface for the ClustalW multiple alignment program"
+HOMEPAGE="http://www.ebi.ac.uk/tools/clustalw2/"
+SRC_URI="http://www.clustal.org/download/current/${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4"
+RDEPEND="${DEPEND}
+ >=sci-biology/clustalw-${PV}"
+
+src_prepare() {
+ sed \
+ -e "s|colprot.xml|${EPREFIX}/usr/share/${PN}/colprot.xml|" \
+ -e "s|coldna.xml|${EPREFIX}/usr/share/${PN}/coldna.xml|" \
+ -e "s|colprint.xml|${EPREFIX}/usr/share/${PN}/colprint.xml|" \
+ -i ClustalQtParams.h || \
+ die "Failed to patch shared files location."
+ sed \
+ -e "s|clustalx.hlp|${EPREFIX}/usr/share/${PN}/clustalx.hlp|" \
+ -i HelpDisplayWidget.cpp || \
+ die "Failed to patch help file location."
+ rm -rf usr || die
+}
+
+src_install() {
+ dobin clustalx
+ insinto /usr/share/${PN}
+ doins colprot.xml coldna.xml colprint.xml clustalx.hlp
+ make_desktop_entry ${PN} ClustalX
+}