summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-04-25 23:08:33 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-04-25 23:08:33 +0000
commit2b1a4d7f91d6533aaf3d7959b56f4a5ae03b7ad1 (patch)
treebddd0ed2adac2c0e7119374fe0fd420d3d4371c0 /sci-biology
parentBump to 1.1, fixes second half of #263867 (diff)
downloadgentoo-2-2b1a4d7f91d6533aaf3d7959b56f4a5ae03b7ad1.tar.gz
gentoo-2-2b1a4d7f91d6533aaf3d7959b56f4a5ae03b7ad1.tar.bz2
gentoo-2-2b1a4d7f91d6533aaf3d7959b56f4a5ae03b7ad1.zip
Version bump
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/paml/ChangeLog9
-rw-r--r--sci-biology/paml/paml-4.2b.ebuild39
2 files changed, 46 insertions, 2 deletions
diff --git a/sci-biology/paml/ChangeLog b/sci-biology/paml/ChangeLog
index 14a46a4f9dff..b923e3fdc55a 100644
--- a/sci-biology/paml/ChangeLog
+++ b/sci-biology/paml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/paml
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/paml/ChangeLog,v 1.4 2008/09/07 12:02:02 markusle Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/paml/ChangeLog,v 1.5 2009/04/25 23:08:33 weaver Exp $
+
+*paml-4.2b (25 Apr 2009)
+
+ 25 Apr 2009; Andrey Kislyuk <weaver@gentoo.org> +paml-4.2b.ebuild:
+ Version bump
*paml-4.1 (07 Sep 2008)
diff --git a/sci-biology/paml/paml-4.2b.ebuild b/sci-biology/paml/paml-4.2b.ebuild
new file mode 100644
index 000000000000..324c907c870b
--- /dev/null
+++ b/sci-biology/paml/paml-4.2b.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/paml/paml-4.2b.ebuild,v 1.1 2009/04/25 23:08:33 weaver Exp $
+
+inherit toolchain-funcs
+
+MY_P="${PN}42"
+DESCRIPTION="Phylogenetic Analysis by Maximum Likelihood"
+HOMEPAGE="http://abacus.gene.ucl.ac.uk/software/paml.html"
+SRC_URI="http://abacus.gene.ucl.ac.uk/software/${PN}${PV}.tar.gz"
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+RDEPEND=""
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ cd src
+ emake \
+ -f Makefile.UNIX \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ || die "make failed"
+}
+
+src_install() {
+ pushd "${S}"/src
+ dobin baseml codeml basemlg mcmctree pamp evolver yn00 chi2
+ popd
+ dodoc README.txt doc/*
+ insinto /usr/share/${PN}/control
+ doins *.ctl || die "Failed to install control files"
+ insinto /usr/share/${PN}/dat
+ doins stewart* *.dat dat/* || die "Failed to install data files"
+ insinto /usr/share/${PN}
+ doins -r examples/ || die "Failed to install examples"
+}