summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-07-17 07:48:28 +0000
committerJustin Lecher <jlec@gentoo.org>2013-07-17 07:48:28 +0000
commit56a9d037e34a99d70cbcd31c0eb1ce8c08d34b3e (patch)
tree650922a65f35f679e474b3a8a8c6f601e44a6302 /sci-biology
parentVersion bump (diff)
downloadgentoo-2-56a9d037e34a99d70cbcd31c0eb1ce8c08d34b3e.tar.gz
gentoo-2-56a9d037e34a99d70cbcd31c0eb1ce8c08d34b3e.tar.bz2
gentoo-2-56a9d037e34a99d70cbcd31c0eb1ce8c08d34b3e.zip
sci-biology/last: Version Bump
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/last/ChangeLog7
-rw-r--r--sci-biology/last/last-299.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/sci-biology/last/ChangeLog b/sci-biology/last/ChangeLog
index 9d026984773c..161c495c0c25 100644
--- a/sci-biology/last/ChangeLog
+++ b/sci-biology/last/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/last
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/last/ChangeLog,v 1.21 2013/03/11 16:05:24 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/last/ChangeLog,v 1.22 2013/07/17 07:48:28 jlec Exp $
+
+*last-299 (17 Jul 2013)
+
+ 17 Jul 2013; Justin Lecher <jlec@gentoo.org> +last-299.ebuild:
+ Version Bump
11 Mar 2013; Justin Lecher <jlec@gentoo.org> metadata.xml:
Drop Andrey as maintainer so that bugs get assigned to sci-biology directly
diff --git a/sci-biology/last/last-299.ebuild b/sci-biology/last/last-299.ebuild
new file mode 100644
index 000000000000..f9fa2ae95561
--- /dev/null
+++ b/sci-biology/last/last-299.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/last/last-299.ebuild,v 1.1 2013/07/17 07:48:28 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit eutils toolchain-funcs python-r1
+
+DESCRIPTION="Genome-scale comparison of biological sequences"
+HOMEPAGE="http://last.cbrc.jp/"
+SRC_URI="http://last.cbrc.jp/${P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+src_prepare() {
+ sed \
+ -e 's:-o $@:$(LDFLAGS) -o $@:g' \
+ -i src/makefile || die
+}
+
+src_compile() {
+ emake \
+ -e -C src \
+ CXX="$(tc-getCXX)" \
+ CC="$(tc-getCC)" \
+ STRICT="" || die
+}
+
+src_install() {
+ local i
+
+ dobin src/last{al,db,ex}
+
+ dodoc doc/*.txt ChangeLog.txt README.txt
+ dohtml doc/*html
+
+ cd scripts || die
+ for i in *py; do
+ python_parallel_foreach_impl python_newscript ${i} ${i%.py}
+ done
+ dobin *sh
+}