summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-07-02 12:47:34 +0000
committerJustin Lecher <jlec@gentoo.org>2013-07-02 12:47:34 +0000
commit5711e7d5c920f0bea5c4115a9d2498a1f9674701 (patch)
tree0dab38f8d0bd3d968159a18828903e9b01584a85 /sci-biology
parentremove old (diff)
downloadgentoo-2-5711e7d5c920f0bea5c4115a9d2498a1f9674701.tar.gz
gentoo-2-5711e7d5c920f0bea5c4115a9d2498a1f9674701.tar.bz2
gentoo-2-5711e7d5c920f0bea5c4115a9d2498a1f9674701.zip
sci-biology/biopython: Fix deps for python
(Portage version: 2.2.0_alpha186/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/biopython/ChangeLog5
-rw-r--r--sci-biology/biopython/biopython-1.61.ebuild12
2 files changed, 8 insertions, 9 deletions
diff --git a/sci-biology/biopython/ChangeLog b/sci-biology/biopython/ChangeLog
index 4513c05c7205..52f4ef7be870 100644
--- a/sci-biology/biopython/ChangeLog
+++ b/sci-biology/biopython/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-biology/biopython
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/ChangeLog,v 1.70 2013/06/06 08:38:13 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/ChangeLog,v 1.71 2013/07/02 12:47:34 jlec Exp $
+
+ 02 Jul 2013; Justin Lecher <jlec@gentoo.org> biopython-1.61.ebuild:
+ Fix deps for python
06 Jun 2013; Justin Lecher <jlec@gentoo.org> biopython-1.61.ebuild:
Keyword ~-linux
diff --git a/sci-biology/biopython/biopython-1.61.ebuild b/sci-biology/biopython/biopython-1.61.ebuild
index 08e5fe14a85a..22ccbb08daef 100644
--- a/sci-biology/biopython/biopython-1.61.ebuild
+++ b/sci-biology/biopython/biopython-1.61.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/biopython-1.61.ebuild,v 1.2 2013/06/06 08:38:13 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/biopython-1.61.ebuild,v 1.3 2013/07/02 12:47:34 jlec Exp $
EAPI=5
@@ -17,7 +17,9 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
IUSE="mysql postgres"
-RDEPEND="
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
dev-python/matplotlib[${PYTHON_USEDEP}]
dev-python/networkx[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
@@ -29,13 +31,7 @@ RDEPEND="
DEPEND="${RDEPEND}
sys-devel/flex"
-#PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
-
-#DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
DOCS=( CONTRIB DEPRECATED NEWS README )
-#PYTHON_MODNAME="Bio BioSQL"
-
-#PATCHES=( "${FILESDIR}"/${PN}-1.51-flex.patch )
python_test() {
cd Tests