summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-13 13:13:57 +0000
committerJustin Lecher <jlec@gentoo.org>2013-02-13 13:13:57 +0000
commit83c3a265041f20252ec713198221b5a2e8d64216 (patch)
tree1e42493693235d13985a81d2ae3348b873ee14ba /sci-biology
parentUpstream fix to unicode issue, -unicode.patch, for removal next release, fixe... (diff)
downloadgentoo-2-83c3a265041f20252ec713198221b5a2e8d64216.tar.gz
gentoo-2-83c3a265041f20252ec713198221b5a2e8d64216.tar.bz2
gentoo-2-83c3a265041f20252ec713198221b5a2e8d64216.zip
sci-biology/vienna-rna: Version Bump; move to EAPI=5, new python eclasses; autotools-utils
(Portage version: 2.2.0_alpha162/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/vienna-rna/ChangeLog10
-rw-r--r--sci-biology/vienna-rna/files/vienna-rna-2.1.1-bindir.patch10
-rw-r--r--sci-biology/vienna-rna/files/vienna-rna-2.1.1-impl-decl.patch15
-rw-r--r--sci-biology/vienna-rna/files/vienna-rna-2.1.1-prll.patch30
-rw-r--r--sci-biology/vienna-rna/files/vienna-rna-2.1.1-setup.py27
-rw-r--r--sci-biology/vienna-rna/vienna-rna-2.1.1.ebuild112
6 files changed, 203 insertions, 1 deletions
diff --git a/sci-biology/vienna-rna/ChangeLog b/sci-biology/vienna-rna/ChangeLog
index db40e35eadfb..43d90cdc1e91 100644
--- a/sci-biology/vienna-rna/ChangeLog
+++ b/sci-biology/vienna-rna/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-biology/vienna-rna
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/vienna-rna/ChangeLog,v 1.46 2013/01/31 10:57:35 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/vienna-rna/ChangeLog,v 1.47 2013/02/13 13:13:57 jlec Exp $
+
+*vienna-rna-2.1.1 (13 Feb 2013)
+
+ 13 Feb 2013; Justin Lecher <jlec@gentoo.org> +vienna-rna-2.1.1.ebuild,
+ +files/vienna-rna-2.1.1-bindir.patch,
+ +files/vienna-rna-2.1.1-impl-decl.patch, +files/vienna-rna-2.1.1-prll.patch,
+ +files/vienna-rna-2.1.1-setup.py:
+ Version Bump; move to EAPI=5, new python eclasses; autotools-utils
31 Jan 2013; Justin Lecher <jlec@gentoo.org> vienna-rna-1.8.5.ebuild,
metadata.xml:
diff --git a/sci-biology/vienna-rna/files/vienna-rna-2.1.1-bindir.patch b/sci-biology/vienna-rna/files/vienna-rna-2.1.1-bindir.patch
new file mode 100644
index 000000000000..6d35ecea9b0f
--- /dev/null
+++ b/sci-biology/vienna-rna/files/vienna-rna-2.1.1-bindir.patch
@@ -0,0 +1,10 @@
+diff --git a/Utils/Makefile.am b/Utils/Makefile.am
+index f42ebf4..d84a0f1 100644
+--- a/Utils/Makefile.am
++++ b/Utils/Makefile.am
+@@ -1,4 +1,4 @@
+-pkgbindir = $(pkgdatadir)/bin
++pkgbindir = $(prefix)/bin
+ pkgbin_PROGRAMS = b2ct popt
+
+ pscript = b2mt.pl ct2b.pl dpzoom.pl mountain.pl relplot.pl rotate_ss.pl cmount.pl colorrna.pl coloraln.pl refold.pl switch.pl
diff --git a/sci-biology/vienna-rna/files/vienna-rna-2.1.1-impl-decl.patch b/sci-biology/vienna-rna/files/vienna-rna-2.1.1-impl-decl.patch
new file mode 100644
index 000000000000..de457f318e8e
--- /dev/null
+++ b/sci-biology/vienna-rna/files/vienna-rna-2.1.1-impl-decl.patch
@@ -0,0 +1,15 @@
+ Readseq/readseq.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Readseq/readseq.c b/Readseq/readseq.c
+index 8af7b39..56a25ae 100644
+--- a/Readseq/readseq.c
++++ b/Readseq/readseq.c
+@@ -171,6 +171,7 @@ link -w -o readseq -t MPST -c 'MPS '
+ #include <stdio.h>
+ #include <string.h>
+ #include <ctype.h>
++#include <stdlib.h>
+
+ #include "ureadseq.h"
+
diff --git a/sci-biology/vienna-rna/files/vienna-rna-2.1.1-prll.patch b/sci-biology/vienna-rna/files/vienna-rna-2.1.1-prll.patch
new file mode 100644
index 000000000000..ee4aef5c3308
--- /dev/null
+++ b/sci-biology/vienna-rna/files/vienna-rna-2.1.1-prll.patch
@@ -0,0 +1,30 @@
+ Readseq/Makefile | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/Readseq/Makefile b/Readseq/Makefile
+index f073aaa..05f2edd 100644
+--- a/Readseq/Makefile
++++ b/Readseq/Makefile
+@@ -6,11 +6,11 @@
+ #
+
+ # pick an ANSI C compiler (the default Sun CC is not ANSI)
+-CC=gcc # Gnu C Compiler
++CC?=gcc # Gnu C Compiler
+ #CC=cc # SGI Irix
+ #CC=vcc # some DEC Ultrix
+
+-CFLAGS=
++CFLAGS?=
+ #CFLAGS= -DSMALLCHECKSUM # if you prefer to use a GCG-standard 13 bit checksum
+ # instead of a full 32 bit checksum. This may enhance compatibility w/ GCG software
+
+@@ -40,7 +40,7 @@ all: build test
+
+ build: $(SOURCES)
+ @echo "Compiling readseq..."
+- $(CC) $(LDFLAGS) $(CFLAGS) -o readseq readseq.c ureadseq.c
++ $(CC) $(LDFLAGS) $(CFLAGS) -o readseq readseq.c ureadseq.c ureadasn.c
+
+ # if using NCBI, uncomment these lines in place of build: above
+ #build: $(SOURCES)
diff --git a/sci-biology/vienna-rna/files/vienna-rna-2.1.1-setup.py b/sci-biology/vienna-rna/files/vienna-rna-2.1.1-setup.py
new file mode 100644
index 000000000000..57f6b712ba3d
--- /dev/null
+++ b/sci-biology/vienna-rna/files/vienna-rna-2.1.1-setup.py
@@ -0,0 +1,27 @@
+from distutils.core import setup, Extension
+import os
+import sys
+
+old_filename = os.path.join("Perl", "RNA.py")
+new_filename = os.path.join("Perl", "__init__.py")
+if os.path.exists(old_filename):
+ os.rename(old_filename, new_filename)
+
+extra_link_args = []
+
+extension = Extension("_RNA",
+ ["Perl/RNA_wrap.c"],
+ libraries=['RNA'],
+ library_dirs=['lib'],
+ extra_link_args=extra_link_args
+ )
+
+setup(name="RNA",
+ version="2.1.1",
+ description="Vienna RNA",
+ author="Ivo Hofacker, Institute for Theoretical Chemistry, University of Vienna",
+ url="http://www.tbi.univie.ac.at/RNA/",
+ package_dir = {'RNA':'Perl'},
+ packages = ['RNA'],
+ ext_modules=[extension],
+ )
diff --git a/sci-biology/vienna-rna/vienna-rna-2.1.1.ebuild b/sci-biology/vienna-rna/vienna-rna-2.1.1.ebuild
new file mode 100644
index 000000000000..3872a6eab80e
--- /dev/null
+++ b/sci-biology/vienna-rna/vienna-rna-2.1.1.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/vienna-rna/vienna-rna-2.1.1.ebuild,v 1.1 2013/02/13 13:13:57 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+DISTUTILS_OPTIONAL=true
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils distutils-r1 multilib perl-module toolchain-funcs
+
+DESCRIPTION="RNA secondary structure prediction and comparison"
+HOMEPAGE="http://www.tbi.univie.ac.at/~ivo/RNA/"
+SRC_URI="http://www.tbi.univie.ac.at/~ronny/RNA/ViennaRNA-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="vienna-rna"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc openmp python static-libs"
+
+DEPEND="
+ dev-lang/perl
+ media-libs/gd
+ doc? ( dev-texlive/texlive-latex )
+ python? (
+ ${PYTHON_DEPS}
+ dev-lang/swig )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/ViennaRNA-${PV}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-bindir.patch
+ "${FILESDIR}"/${P}-prll.patch
+ "${FILESDIR}"/${P}-impl-decl.patch
+)
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ sed -i 's/ getline/ v_getline/' Readseq/ureadseq.c || die
+ sed -i 's/@PerlCmd@ Makefile.PL/& INSTALLDIRS=vendor/' Perl/Makefile.am || die
+
+ autotools-utils_src_prepare
+
+ if use python; then
+ cp "${FILESDIR}"/${P}-setup.py "${S}"/setup.py || die
+ PATCHES=()
+ distutils-r1_src_prepare
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-cluster
+ $(use_enable openmp) )
+
+ use doc || \
+ myeconfargs+=(
+ --without-doc-pdf
+ --without-doc-html
+ --without-doc
+ )
+ autotools-utils_src_configure
+ sed \
+ -e "s:LIBDIR = /usr/lib:LIBDIR = ${D}/usr/$(get_libdir):" \
+ -e "s:INCDIR = /usr/include:INCDIR = ${D}/usr/include:" \
+ -i RNAforester/g2-0.70/Makefile || die
+ sed \
+ -e "s:CC=gcc:CC=$(tc-getCC):" \
+ -e "s:^CFLAGS=:CFLAGS=${CFLAGS}:" \
+ -i Readseq/Makefile || die
+ use python && distutils-r1_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ autotools-utils_src_compile -C Readseq build CC=$(tc-getCC)
+
+ # TODO: Add (optional?) support for the NCBI toolkit.
+ if use python; then
+ pushd Perl > /dev/null
+ mv RNA_wrap.c{,-perl} || die
+ swig -python RNA.i || die
+ popd > /dev/null
+ distutils-r1_src_compile
+ mv Perl/RNA_wrap.c{-perl,} || die
+ fi
+}
+
+src_test() {
+ autotools-utils_src_compile -C Perl check
+ autotools-utils_src_compile -C Readseq test
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if ! use static-libs; then
+ rm -f "${ED}"/usr/$(get_libdir)/*.a || die
+ fi
+
+ newbin Readseq/readseq readseq-vienna
+ dodoc Readseq/Readseq.help
+ newdoc Readseq/Readme README.readseq
+ newdoc Readseq/Formats Formats.readseq
+
+ # remove perlocal.pod to avoid file collisions (see #240358)
+ fixlocalpod || die "Failed to remove perlocal.pod"
+ use python && distutils-r1_src_install
+}