summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2005-02-23 04:04:17 +0000
committerOlivier Fisette <ribosome@gentoo.org>2005-02-23 04:04:17 +0000
commit98b923d69b7698345738f44753a3c59e496c769d (patch)
treebddca7d36e365fa7bfa3c213c26f6b79a2e236f4 /sci-biology
parentadd patch by richard juckes for gcc4 #82907 (diff)
downloadgentoo-2-98b923d69b7698345738f44753a3c59e496c769d.tar.gz
gentoo-2-98b923d69b7698345738f44753a3c59e496c769d.tar.bz2
gentoo-2-98b923d69b7698345738f44753a3c59e496c769d.zip
Added support for the "emboss" and "minimal" "USE" flags.
(Portage version: 2.0.51.16)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/aaindex/ChangeLog5
-rw-r--r--sci-biology/aaindex/aaindex-6.0.ebuild18
-rw-r--r--sci-biology/cutg/ChangeLog6
-rw-r--r--sci-biology/cutg/cutg-143.ebuild40
-rw-r--r--sci-biology/cutg/cutg-144.ebuild16
-rw-r--r--sci-biology/cutg/files/digest-cutg-1431
6 files changed, 29 insertions, 57 deletions
diff --git a/sci-biology/aaindex/ChangeLog b/sci-biology/aaindex/ChangeLog
index 83ec934591c1..8e8044e0e6f3 100644
--- a/sci-biology/aaindex/ChangeLog
+++ b/sci-biology/aaindex/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-biology/aaindex
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/aaindex/ChangeLog,v 1.3 2005/01/14 22:47:33 j4rg0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/aaindex/ChangeLog,v 1.4 2005/02/23 03:59:50 ribosome Exp $
+
+ 22 Feb 2005; Olivier Fisette <ribosome@gentoo.org> aaindex-6.0.ebuild:
+ Added support for the "emboss" and "minimal" "USE" flags.
14 Jan 2005; Lina Pezzella <j4rg0n@gentoo.org> aaindex-6.0.ebuild:
Stable ppc-macos.
diff --git a/sci-biology/aaindex/aaindex-6.0.ebuild b/sci-biology/aaindex/aaindex-6.0.ebuild
index 5bd319ddde9c..62e5995d2f45 100644
--- a/sci-biology/aaindex/aaindex-6.0.ebuild
+++ b/sci-biology/aaindex/aaindex-6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/aaindex/aaindex-6.0.ebuild,v 1.3 2005/01/14 22:47:33 j4rg0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/aaindex/aaindex-6.0.ebuild,v 1.4 2005/02/23 03:59:50 ribosome Exp $
DESCRIPTION="Amino acid indices and similarity matrices"
HOMEPAGE="http://www.genome.ad.jp/aaindex"
@@ -12,32 +12,36 @@ SRC_URI="ftp://ftp.genome.ad.jp/pub/db/genomenet/${PN}/${PN}.doc
LICENSE="public-domain"
SLOT="0"
KEYWORDS="x86 ~ppc ppc-macos"
-IUSE="no-emboss no-rawdb"
+IUSE="emboss minimal"
+# Minimal build keeps only the indexed files (if applicable) and the documentation.
+# The non-indexed database is not installed.
S=${WORKDIR}
src_unpack() {
+ echo
einfo "No archive to unpack."
+ echo
}
src_compile() {
- # Index the database for use with emboss if emboss is installed and
- # the user did not explicitly request not to index the database.
- if [ -e /usr/bin/aaindexextract ] && ! use no-emboss; then
+ if use emboss; then
mkdir AAINDEX
+ echo
einfo "Indexing AAindex for usage with EMBOSS."
EMBOSS_DATA=. aaindexextract -auto -infile ${DISTDIR}/${PN}1 || die \
"Indexing AAindex failed."
+ echo
fi
}
src_install() {
- if ! use no-rawdb; then
+ if ! use minimal; then
insinto /usr/share/${PN}
doins ${DISTDIR}/{${PN}{1,2},list_of_{matrices,indices}}
fi
dodoc ${DISTDIR}/${PN}.doc
- if [ -e /usr/bin/aaindexextract ] && ! use no-emboss; then
+ if use emboss; then
insinto /usr/share/EMBOSS/data/AAINDEX
doins AAINDEX/*
fi
diff --git a/sci-biology/cutg/ChangeLog b/sci-biology/cutg/ChangeLog
index abd14fc0ed05..2a9c99889d90 100644
--- a/sci-biology/cutg/ChangeLog
+++ b/sci-biology/cutg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-biology/cutg
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/cutg/ChangeLog,v 1.6 2005/02/02 21:24:46 j4rg0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/cutg/ChangeLog,v 1.7 2005/02/23 04:04:17 ribosome Exp $
+
+ 22 Feb 2005; Olivier Fisette <ribosome@gentoo.org> -cutg-143.ebuild,
+ cutg-144.ebuild:
+ Added support for the "emboss" and "minimal" "USE" flags.
02 Feb 2005; Lina Pezzella <j4rg0n@gentoo.org> cutg-144.ebuild:
Stable ppc-macos
diff --git a/sci-biology/cutg/cutg-143.ebuild b/sci-biology/cutg/cutg-143.ebuild
deleted file mode 100644
index 77a02d91a74a..000000000000
--- a/sci-biology/cutg/cutg-143.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/cutg/cutg-143.ebuild,v 1.2 2005/01/01 13:05:19 corsair Exp $
-
-DESCRIPTION="Codon usage tables calculated from GenBank"
-HOMEPAGE="http://www.kazusa.or.jp/codon/"
-SRC_URI="ftp://ftp.kazusa.or.jp/pub/codon/current/compressed/CUTG.${PV}.tar.gz"
-LICENSE="public-domain"
-
-SLOT="0"
-KEYWORDS="x86 ~ppc"
-IUSE="no-emboss no-rawdb"
-
-S=${WORKDIR}
-
-src_compile() {
- # Index the database for use with emboss if emboss is installed and
- # the user did not explicitly request not to index the database.
- if [ -e /usr/bin/cutgextract ] && ! use no-emboss; then
- mkdir CODONS
- einfo "Indexing CUTG for usage with EMBOSS."
- EMBOSS_DATA=. cutgextract -auto -directory ${S} || die \
- "Indexing CUTG failed."
- fi
-}
-
-src_install() {
- if ! use no-rawdb; then
- mkdir -p ${D}/usr/share/${PN}
- mv *.codon *.spsum ${D}/usr/share/${PN}
- fi
- dodoc README
- if [ -e /usr/bin/cutgextract ] && ! use no-emboss; then
- mkdir -p ${D}/usr/share/EMBOSS/data/CODONS
- cd CODONS
- for file in *; do
- mv ${file} ${D}/usr/share/EMBOSS/data/CODONS
- done
- fi
-}
diff --git a/sci-biology/cutg/cutg-144.ebuild b/sci-biology/cutg/cutg-144.ebuild
index a7402d0b784a..6c9048b77e65 100644
--- a/sci-biology/cutg/cutg-144.ebuild
+++ b/sci-biology/cutg/cutg-144.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/cutg/cutg-144.ebuild,v 1.5 2005/02/02 21:24:46 j4rg0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/cutg/cutg-144.ebuild,v 1.6 2005/02/23 04:04:17 ribosome Exp $
DESCRIPTION="Codon usage tables calculated from GenBank"
HOMEPAGE="http://www.kazusa.or.jp/codon/"
@@ -9,28 +9,30 @@ LICENSE="public-domain"
SLOT="0"
KEYWORDS="x86 ~ppc ppc-macos ~ppc64"
-IUSE="no-emboss no-rawdb"
+IUSE="emboss minimal"
+# Minimal build keeps only the indexed files (if applicable) and the documentation.
+# The non-indexed database is not installed.
S=${WORKDIR}
src_compile() {
- # Index the database for use with emboss if emboss is installed and
- # the user did not explicitly request not to index the database.
- if [ -e /usr/bin/cutgextract ] && ! use no-emboss; then
+ if use emboss; then
mkdir CODONS
+ echo
einfo "Indexing CUTG for usage with EMBOSS."
EMBOSS_DATA=. cutgextract -auto -directory ${S} || die \
"Indexing CUTG failed."
+ echo
fi
}
src_install() {
- if ! use no-rawdb; then
+ if ! use minimal; then
mkdir -p ${D}/usr/share/${PN}
mv *.codon *.spsum ${D}/usr/share/${PN}
fi
dodoc README
- if [ -e /usr/bin/cutgextract ] && ! use no-emboss; then
+ if use emboss; then
mkdir -p ${D}/usr/share/EMBOSS/data/CODONS
cd CODONS
for file in *; do
diff --git a/sci-biology/cutg/files/digest-cutg-143 b/sci-biology/cutg/files/digest-cutg-143
deleted file mode 100644
index 55572f7df18e..000000000000
--- a/sci-biology/cutg/files/digest-cutg-143
+++ /dev/null
@@ -1 +0,0 @@
-MD5 8f3ccb3c31e1383ac987d8e46c9f5610 CUTG.143.tar.gz 117357602