summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-17 11:14:56 +0000
committerJustin Lecher <jlec@gentoo.org>2013-02-17 11:14:56 +0000
commitc1cfc0182ba7e476d80375bc47c045ace1437449 (patch)
tree5dd9c77de4c15175c026900598b876b1b7c85b5b /sci-biology
parentsci-biology/sibsim4: Respect CC, CFLAGS and LDFLAGS, #328431 (diff)
downloadgentoo-2-c1cfc0182ba7e476d80375bc47c045ace1437449.tar.gz
gentoo-2-c1cfc0182ba7e476d80375bc47c045ace1437449.tar.bz2
gentoo-2-c1cfc0182ba7e476d80375bc47c045ace1437449.zip
sci-biology/shrimp: Force sse2 support by the cpu, #337401
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/shrimp/ChangeLog5
-rw-r--r--sci-biology/shrimp/shrimp-2.2.3.ebuild8
2 files changed, 10 insertions, 3 deletions
diff --git a/sci-biology/shrimp/ChangeLog b/sci-biology/shrimp/ChangeLog
index 48b0c3bb3798..1e4a0a17648c 100644
--- a/sci-biology/shrimp/ChangeLog
+++ b/sci-biology/shrimp/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-biology/shrimp
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/shrimp/ChangeLog,v 1.19 2013/02/17 09:38:27 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/shrimp/ChangeLog,v 1.20 2013/02/17 11:14:56 jlec Exp $
+
+ 17 Feb 2013; Justin Lecher <jlec@gentoo.org> shrimp-2.2.3.ebuild:
+ Force sse2 support by the cpu, #337401
17 Feb 2013; Justin Lecher <jlec@gentoo.org> shrimp-2.0.1.ebuild,
-shrimp-2.1.0.ebuild, shrimp-2.2.3.ebuild, metadata.xml:
diff --git a/sci-biology/shrimp/shrimp-2.2.3.ebuild b/sci-biology/shrimp/shrimp-2.2.3.ebuild
index 60b5ec023245..942dfd58cefb 100644
--- a/sci-biology/shrimp/shrimp-2.2.3.ebuild
+++ b/sci-biology/shrimp/shrimp-2.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/shrimp/shrimp-2.2.3.ebuild,v 1.4 2013/02/17 09:38:27 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/shrimp/shrimp-2.2.3.ebuild,v 1.5 2013/02/17 11:14:56 jlec Exp $
EAPI=5
@@ -17,7 +17,7 @@ SRC_URI="http://compbio.cs.toronto.edu/shrimp/releases/SHRiMP_${MY_PV}.src.tar.g
LICENSE="shrimp"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="custom-cflags"
+IUSE="custom-cflags +sse2"
# file collision on /usr/bin/utils #453044
DEPEND="!sci-mathematics/cado-nfs"
@@ -25,6 +25,10 @@ RDEPEND="${DEPEND}"
S=${WORKDIR}/SHRiMP_${MY_PV}
+pkg_pretend() {
+ use sse2 || die "This package needs sse2 support in your CPU"
+}
+
pkg_setup() {
if [[ ${CC} == *gcc* ]] && ! tc-has-openmp; then
elog "Please set CC to an OPENMP capable compiler (e.g. gcc[openmp] or icc"